SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue Tech

Reply
 
Thread Tools Display Modes
Old 06-09-2016, 05:06 PM   #1
boat-tech25
New Member
boat-tech25 is on a distinguished road
 
Join Date: Jun 2016
Posts: 2
Default Stalling issue

Can anyone help,
2004 Vue 2.2 lt. occasional rough idle, stalling when coasting to a stop.
Have replaced crank position sensor, cleaned air temp sensor, fuel psi remained above 50 psi when it stalled. Someone told me air temp sensor is being used as a mass air flow sensor. Has left my wife stranded and i only could get it to stall for me one time. It started back up ran rough for a second then fine after that. No codes logged in computer. Any help would be greatly appreciated.
boat-tech25 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-09-2016, 11:12 PM   #2
far2grumpy
Master Member
far2grumpy is a splendid one to beholdfar2grumpy is a splendid one to beholdfar2grumpy is a splendid one to beholdfar2grumpy is a splendid one to beholdfar2grumpy is a splendid one to beholdfar2grumpy is a splendid one to beholdfar2grumpy is a splendid one to beholdfar2grumpy is a splendid one to behold
 
far2grumpy's Avatar
 
Join Date: Oct 2008
Location: Cedar Rapids, IA
Posts: 8,122
 

2005 VUE 3.5L
2007 VUE 3.5L
Default Re: Stalling issue

Quote:
Originally Posted by boat-tech25 View Post
Can anyone help,
2004 Vue 2.2 lt. occasional rough idle, stalling when coasting to a stop.
Have replaced crank position sensor, cleaned air temp sensor, fuel psi remained above 50 psi when it stalled. Someone told me air temp sensor is being used as a mass air flow sensor. Has left my wife stranded and i only could get it to stall for me one time. It started back up ran rough for a second then fine after that. No codes logged in computer. Any help would be greatly appreciated.
There are some really smart 2.2 owners who will probably offer quality advice ... looks like you're stuck with me until they weigh-in.

I've attached three FSM extracts pertaining to problems similar to yours. There's a whole shopping list of possibilities and you've probably completed some of them. Send a PM with email address if you'd like any of the referenced files.

From my own experiences and reading many 2.2 threads I could suggest a few off-the-wall possibilities:

Could be a bad pre-cat O2 sensor - they've been known to provide really bad fuel advice to ECM - especially after engine reaches normal operating temperatures. One clue is if engine starts and operates normally for a short period and then starts to misfire. The preferred method to eliminate sensor is to locate the wiring harness connection and unplugging sensor. You can operate engine as much as you like - however, it will be running in OPEN loop which means you'll be able to smell a rich mixture in exhaust, mileage will be poor and you'll never pass emission testing.

Is there any correlation with misfiring and filling gas tank? There's an EVAP purge valve on engine - commanded by ECM - that selectively draws fuel fumes from gas tank through a carbon canister on as required basis. If this valve sticks open the engine vacuum system is compromised and engine will not run smoothly - if at all.

Another possibility is a clogged exhaust system. I've had this problem in past where a piece of debris in muffler would intermittently block the exhaust and engine will cough, spit and refuse to operate normally until the blockage is removed. You can isolate this problem in minutes if you have access to a simple vacuum gauge.
Attached Images
File Type: jpg Misfire 1 of 3.jpg (99.2 KB, 3 views)
File Type: jpg Misfire 2 of 3.jpg (89.8 KB, 2 views)
File Type: jpg Misfire 3 of 3.jpg (75.1 KB, 2 views)
...
I visit forum monthly, if at all. Feel free to send private messages if you think I can help. Don't use visitor message as I never check those.
far2grumpy is offline   Reply With Quote
Old 06-10-2016, 12:23 AM   #3
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 44,891
 

2003 L-Series 3.0L Sedan
Default Re: Stalling issue

While waiting for smart 2.2L owners to chime in, there may be some other easy things to check. What's mileage? Spark plugs replaced at 100k miles? Air filter? Throttle ever cleaned?
fdryer is offline   Reply With Quote
Old 06-10-2016, 06:11 AM   #4
waiter21
Advanced Member
waiter21 is a name known to allwaiter21 is a name known to allwaiter21 is a name known to allwaiter21 is a name known to allwaiter21 is a name known to allwaiter21 is a name known to all
 
Join Date: Feb 2016
Location: NW Ohio
Posts: 708

2003 VUE 2.2L
Default Re: Stalling issue

Is the Service Engine soon light on? Are there any codes set?
...
2003 Vue - 2.2L with Manual Trans. (Swapped)
Originally had 2.2L and Auto trans.
waiter21 is offline   Reply With Quote
Old 06-13-2016, 07:14 PM   #5
boat-tech25
New Member
boat-tech25 is on a distinguished road
 
Join Date: Jun 2016
Posts: 2
Default Re: Stalling issue

Thanks to all, have finally resolved issue, Replaced what saturn called the air temp. sensor or air charge sensor. Now runs smooth as silk and no more stalling. To answer your questions for help with future similar inquiry's, mileage 128,000. spark plugs changed on schedule, no misfires ( have scanner to confirm ) pre O2 thru a code recently and was replaced. I'm back in good graces with my wife.

Thanks again.....
boat-tech25 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not starting issue became a stalling issue l3uster L-Series Tech 19 05-12-2014 02:05 PM
its been a bad day.....stalling issue. please help solarcar_sc1 S-Series Tech 5 04-27-2014 02:35 AM
99 sl2 stalling issue sccaligirl S-Series General 13 01-15-2014 02:30 PM
Please Help! 03 Vue Stalling Issue Cindy17932 Vue Tech 2 02-26-2013 07:26 PM
97 SC2 Stalling Issue dsorenson28 S-Series Tech 4 01-14-2007 01:27 PM


All times are GMT -4. The time now is 01:28 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.