SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Aura > Aura General

Reply
 
Thread Tools Display Modes
Old 04-30-2021, 05:56 AM   #1
mister saturn
New Member
mister saturn is on a distinguished road
 
Join Date: Mar 2008
Posts: 9
Default 2007 Aura XE not working correctly with aftermarket radio?

I know that the turn signal chime won't work without a special connector, but my dash display doesn't work correctly with another radio as well. The display shuts down randomly and won't show the correct speed, gas level, temp, etc. Any idea what's going on?
mister saturn is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-01-2021, 12:58 AM   #2
imaddicted2u
Advanced Member
imaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to behold
 
imaddicted2u's Avatar
 
Join Date: Jun 2013
Location: Nova Scotia
Posts: 758

2008 AURA XE
Default Re: 2007 Aura XE not working correctly with aftermarket radio?

Did you hack the wiring to connect the aftermarket stereo? Did you use an interface adapter?
The only possible connection between the radio and gauge cluster that I can see is the GMLAN communications wiring. I think the GMLAN bus wires are pink and connected to pins 9 and 10 on the 14 pin connector. If left unconnected (unterminated) it might mess up communications on the data bus, causing the issues you see on the gauge cluster. Did you get a check engine light or any codes?
Can you put back the original stereo to see if the problem goes away?
...
2008 Saturn Aura XE 3.5L 4 spd
2000 Saturn SL1 1.9L SOHC (Retired)
imaddicted2u is offline   Reply With Quote
Old 05-01-2021, 01:15 AM   #3
mister saturn
New Member
mister saturn is on a distinguished road
 
Join Date: Mar 2008
Posts: 9
Default Re: 2007 Aura XE not working correctly with aftermarket radio?

Quote:
Originally Posted by imaddicted2u View Post
Did you hack the wiring to connect the aftermarket stereo? Did you use an interface adapter?
The only possible connection between the radio and gauge cluster that I can see is the GMLAN communications wiring. I think the GMLAN bus wires are pink and connected to pins 9 and 10 on the 14 pin connector. If left unconnected (unterminated) it might mess up communications on the data bus, causing the issues you see on the gauge cluster. Did you get a check engine light or any codes?
Can you put back the original stereo to see if the problem goes away?
I soldered the new radio's wires to the aftermarket harness wires. The power wire on the harness needs to tap a fuse from the passenger fuse box. I tried pretty much all the fuses, the radio worked but still had an effect on the dash. I don't think the check engine light was on, don't have the means to check the codes though. As soon as I put the stock radio back everything went back to normal.
mister saturn is offline   Reply With Quote
Old 05-01-2021, 01:24 AM   #4
imaddicted2u
Advanced Member
imaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to behold
 
imaddicted2u's Avatar
 
Join Date: Jun 2013
Location: Nova Scotia
Posts: 758

2008 AURA XE
Default Re: 2007 Aura XE not working correctly with aftermarket radio?

The GMLAN wires are connected to load resistors inside the stock radio. Leaving the wires floating can cause communication problems on all the modules connected to the GMLAN. A proper interface adapter will allow the aftermarket radio to be connected and avoid the issues you are seeing, along with the ones you don't see. There are many Aura threads that discuss the interface adapter options.
...
2008 Saturn Aura XE 3.5L 4 spd
2000 Saturn SL1 1.9L SOHC (Retired)
imaddicted2u is offline   Reply With Quote
Old 05-01-2021, 03:29 AM   #5
mister saturn
New Member
mister saturn is on a distinguished road
 
Join Date: Mar 2008
Posts: 9
Default Re: 2007 Aura XE not working correctly with aftermarket radio?

Quote:
Originally Posted by imaddicted2u View Post
The GMLAN wires are connected to load resistors inside the stock radio. Leaving the wires floating can cause communication problems on all the modules connected to the GMLAN. A proper interface adapter will allow the aftermarket radio to be connected and avoid the issues you are seeing, along with the ones you don't see. There are many Aura threads that discuss the interface adapter options.
So a Metra LC-GMRC-LAN-03 adapter would fix the issues?
mister saturn is offline   Reply With Quote
Old 05-01-2021, 07:38 AM   #6
imaddicted2u
Advanced Member
imaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to beholdimaddicted2u is a splendid one to behold
 
imaddicted2u's Avatar
 
Join Date: Jun 2013
Location: Nova Scotia
Posts: 758

2008 AURA XE
Default Re: 2007 Aura XE not working correctly with aftermarket radio?

That looks like the right interface.
https://www.crutchfield.com/p_120LCL...Interface.html
...
2008 Saturn Aura XE 3.5L 4 spd
2000 Saturn SL1 1.9L SOHC (Retired)
imaddicted2u is offline   Reply With Quote
Reply

Bookmarks

Tags
radio


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Aura trunk release not working pjm0322 Aura General 16 06-11-2021 06:07 PM
2007 Aura XR (3.6L) - A/C Not working Cherokee_Indian Aura General 2 07-16-2018 07:14 PM
Help Installing Aftermarket Radio in 07 Aura dutche99 Aura General 1 05-30-2018 10:57 PM
08 Aura xe aftermarket radio. Solar0987 Aura General 0 01-22-2017 06:09 PM
2007 Aura XE radio going bad? Jackalope Aura General 8 12-26-2012 08:56 PM


All times are GMT -4. The time now is 07:15 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.