SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 09-17-2021, 05:03 AM   #1
Slowsl1808
New Member
Slowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of light
 
Join Date: Jun 2018
Posts: 8
Default Intermittent long crank times when cold?

I have a 98 sl1 and after sitting for 8+ hours more often then not it will not start on the first crank like it used to and I can sit there and hold it for 10 seconds and still nothing, if I simply turn the ignition off and back to crank it starts but usually chugs at 500rpm for a few seconds before jumping up to 1000+rpm, not always but usually.

I threw a few parts at it and it didn't solve anything, rebuilt fuel injectors,new ngk bkr4's, both ect & iat sensors & crank sensor.

Fuel filter,TPS,map sensor, plug wires,both ignition coils have been changed 45xxx miles ago, I change plugs and ects every 20xxx.

Fuel filter is ptc pgf846, I've heard generic filters can cause issues but could this be the case if it worked fine all this time? Could it have developed a bleed down situation?

I have not been able to test fuel pressure after sitting as I had to borrow the pressure gauge but key on shows 44psi & idle shows 48psi, I really don't want to drop my tank if I don't need to.

As of now my options seem to be change the pump, fuel pressure reg, ignition module or go with a Gf1846 fuel filter, what would you guys do?

Thanks.
Slowsl1808 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-17-2021, 08:40 AM   #2
Waiex191
Master Member
Waiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to behold
 
Waiex191's Avatar
 
Join Date: Oct 2016
Location: Poplar Grove, IL
Posts: 3,202

1999 SL2
1998 SC2
Default Re: Intermittent long crank times when cold?

On my '98, I turn the key to the run position and wait for the pump to run and then stop. If you put your seatbelt on while you wait it is about the right amount of time. Then turn the key to start. Try it, may be an easy fix.
...
Bryan Cotton
'99 SL2, 5SP bought new
Rebuilt at 204,067 September 2017
Engine, subframe, diff pin mod, brake lines, headliner, alternator, and so on!
'98 SC2, 5SP bought 2018
Waiex191 is offline   Reply With Quote
Old 09-17-2021, 02:13 PM   #3
Slowsl1808
New Member
Slowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of light
 
Join Date: Jun 2018
Posts: 8
Default Re: Intermittent long crank times when cold?

Quote:
Originally Posted by Waiex191 View Post
On my '98, I turn the key to the run position and wait for the pump to run and then stop. If you put your seatbelt on while you wait it is about the right amount of time. Then turn the key to start. Try it, may be an easy fix.
Yeah I tried this at first & it doesn't make a difference, I cycled the ignition on/off 5 times with a 5 second gap each and it doesn't seem to change anything, it's weird how after the first crank it will start on the second usually followed by a 2 second low idle/chug before shooting up to 1k+
Slowsl1808 is offline   Reply With Quote
Old 09-17-2021, 04:10 PM   #4
billr
Master Member
billr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to behold
 
Join Date: Jul 2013
Posts: 6,236
Default Re: Intermittent long crank times when cold?

Are you using live-data to check TP, ECT, and MAP? Throwing parts at it does not ensure that the signal/circuit is OK.

Also, check fuel pressure with a gauge.; and be sure to check when you are having a long-crank episode.
billr is offline   Reply With Quote
Old 09-17-2021, 05:45 PM   #5
Slowsl1808
New Member
Slowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of light
 
Join Date: Jun 2018
Posts: 8
Default Re: Intermittent long crank times when cold?

Quote:
Originally Posted by billr View Post
Are you using live-data to check TP, ECT, and MAP? Throwing parts at it does not ensure that the signal/circuit is OK.

Also, check fuel pressure with a gauge.; and be sure to check when you are having a long-crank episode.
Yes I checked the ects,iats,both o2's,TPS and map through live data and the only thing that caught my eye was the TPS only hits 91% at full throttle but I could only test the TPS with the engine off to prevent pissing off my neighbors, I didn't think anything much of that because it appears to throw the percentages in the right range until I hit full throttle.

I threw those parts at it because I've never changed them before and I change out the ects/iats every 20xxx, I'm at 190xxx miles I'd rather do it now then wait for them to fail, I got this car in very rough shape and due to using it for work it's important that I don't get stranded.

I guess I need to buy a pressure gauge to have on hand and test it after sitting for long periods.
Slowsl1808 is offline   Reply With Quote
Old 09-18-2021, 02:41 PM   #6
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,239
 

2003 L-Series 3.0L Sedan
Default Re: Intermittent long crank times when cold?

Anytime anyone cranks their engine for 10 seconds without the engine ever starting up would imply spark, fuel pump operation, injectors pulsing, and cylinders are soaking wet with raw fuel. Removing spark plugs should confirm this. In every electronic fuel injected engine (from experience) has a well known characteristic of near instant starting whether in hot/humid or subfreezing conditions due to sophisticated EFI systems. Every vehicle with an EFI system should never take more than a few seconds to startup.

Replacing the coolant once with the flat nosed brass one addresses the original faulty factory one with a round nose resin design that fails in virtually every S-series from '91-'01. When the original sensor failed, its nose cracked, leaking coolant into the tiny terminals and into the two pin connector, corroding it. The sensor operates on 5v/low current. The two pin connector ruined from corrosion must be replaced as no amount of cleaning or tweaking fixes it. Left in place without replacing the connector often results in the same hard starting scenarios of a flooded, rich running engine. If the connector isn't found online, junk yards are one source, The alternative is using a pc connector and splicing it into wiring, siliconing the connection for weather resistance. Examine your two pin connector for evidence of coolant corrosion from a damaged sensor leak. The sensor only needs to be replaced once with the flat nosed brass one.

Checking for spark by removing plug wires on coils should show spark jumping across both coil towers when someone turns the ign key to START. Checking for fuel pressure should be done on a cold engine with a fuel pressure gauge before turning the ign key. An intermittent spark or fuel issue can be difficult to diagnose unless there's a clear method for testing. Spark should be consistently seen while cranking the engine (presuming a fully charged battery). Fuel pressure should be as you mentioned and remain high as soon as ign is turned ON before starting and remain high during starting and when the engine's running. Turning on ign without starting is the pcm automatically programmed to run the fuel pump for 2-3 seconds then shuts off if the engine isn't started - a safety issue. Afterwards, pressure should hold without bleeding down. When starting, the crank sensor sends (clock) timing signals to the pcm. The pcm relies on crank sensor signals to; turn on fuel pump, initiate spark and pulse injectors. Without crank sensor signals the ocm is just an expensive door stop. The crank sensor is reliable until it fails with loss of fuel pump, spark and injector operation all at once.
fdryer is offline   Reply With Quote
Old 09-28-2021, 09:03 AM   #7
boomerB5
Junior Member
boomerB5 is on a distinguished road
 
Join Date: Nov 2020
Location: Twin Cities
Posts: 28

1999 SL1
2005 RELAY-2
Default Re: Intermittent long crank times when cold?

I've got a very similar start-up issue with my 1999 SL1.

After changing the ECTS (was the old, cracked resin type), plugs (they were nasty), plug wires, and front O2 sensor...it would rarely start on the first crank. Typically the second key turn would work. But sometimes a third was needed.

I think all the extra cranking took a toll on the starter, because it died. Luckilly I knew about giving it a whack to force a little more life into it. After replacing the starter things maybe improved a little. But two cranks were generally needed.

Then I finally got around to changing the intake manifold gasket. (thanks to the member who shared the step-by-step...it helped a ton) It had been idling rough and sure enough it had the bad robot wrinkle. I also cleaned the injectors since they had to be removed.

Today, it sometimes fires on the first key turn after about two seconds. But it always fires on the second. After searching the forums I ran across a suggestion (sorry I do not recall from whom) to turn the key to ON (not crank it to start) until the gauges stop their chattering, then turn to OFF. Then back to ON until the Wrench Service light goes off. As soon as the wrench light goes off, crank the key...and it starts just like it should within one second.

I suspect the fuel filter (which contains the pressure regulator) needs to be replaced. Once I get around to that, I will share the results.
...
1999 Metallic Blackberry SL1 -- 167,xxx miles

2005 Rust Relay -- 278,xxx miles
boomerB5 is offline   Reply With Quote
Old 09-28-2021, 11:52 AM   #8
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,239
 

2003 L-Series 3.0L Sedan
Default Re: Intermittent long crank times when cold?

Can you check initial ign on fuel pressure with a fuel pressure gauge? This can hep you to visually see from a pressure gauge what the fuel pump and combination filter/pressure regulator are either outputting ideal, lower or bleeding pressure prematurely. A pressure gauge would be a valuable tool to have whether you own one or can borrow one from AutoZone or Advance Auto. Other auto parts stores may have similar too loan programs.

The engine doesn't need to crank or run. Simply turning on ignition prompts the pcm program to run the fuel pump for 2 seconds then shut off of the engine isn't started while a check valve prevents pressure from bleeding off for a few minutes. This is enough time to observe pump pressure if not up to specs and if pressure bleed off occurs sooner than later. Low fuel pressure is one reason for hard starting. Intermittent spark is another reason. Low compression would be another reason with a high mileage engine.
fdryer is offline   Reply With Quote
Old 10-13-2021, 04:32 PM   #9
Slowsl1808
New Member
Slowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of light
 
Join Date: Jun 2018
Posts: 8
Default Re: Intermittent long crank times when cold?

It was intermittent low fuel pressure after sitting for extended periods, I caught it with the fuel pressure gauge.

My fuel filter was broken internally, something had shifted (you could hear it if you shook the filter) and would sometimes cause the pressure to drop low after sitting, I took the not so old ptc fuel filter out and swapped it with a gki and no longer have start up problems.
Slowsl1808 is offline   Reply With Quote
Old 10-13-2021, 04:52 PM   #10
Waiex191
Master Member
Waiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to behold
 
Waiex191's Avatar
 
Join Date: Oct 2016
Location: Poplar Grove, IL
Posts: 3,202

1999 SL2
1998 SC2
Default Re: Intermittent long crank times when cold?

Excellent! Good work!
...
Bryan Cotton
'99 SL2, 5SP bought new
Rebuilt at 204,067 September 2017
Engine, subframe, diff pin mod, brake lines, headliner, alternator, and so on!
'98 SC2, 5SP bought 2018
Waiex191 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
no crank, intermittent up north S-Series Tech 15 11-22-2016 01:25 AM
Starts cold & hot, but not warm without a long crank time ncpi S-Series Tech 8 06-21-2013 09:53 PM
2000 SL2 Cold Starting Issues [Crank crank crank...] RarestRX S-Series Tech 8 02-12-2012 12:58 PM
97 SC2 DOHC will not crank at times E.M.D. S-Series Tech 4 09-16-2010 03:45 PM
long warm up times xupthree60 S-Series Tech 7 10-24-2006 10:16 AM


All times are GMT -4. The time now is 04:28 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.