SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 09-17-2021, 05:03 AM   #1
Slowsl1808
New Member
Slowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of lightSlowsl1808 is a glorious beacon of light
 
Join Date: Jun 2018
Posts: 8
Default Intermittent long crank times when cold?

I have a 98 sl1 and after sitting for 8+ hours more often then not it will not start on the first crank like it used to and I can sit there and hold it for 10 seconds and still nothing, if I simply turn the ignition off and back to crank it starts but usually chugs at 500rpm for a few seconds before jumping up to 1000+rpm, not always but usually.

I threw a few parts at it and it didn't solve anything, rebuilt fuel injectors,new ngk bkr4's, both ect & iat sensors & crank sensor.

Fuel filter,TPS,map sensor, plug wires,both ignition coils have been changed 45xxx miles ago, I change plugs and ects every 20xxx.

Fuel filter is ptc pgf846, I've heard generic filters can cause issues but could this be the case if it worked fine all this time? Could it have developed a bleed down situation?

I have not been able to test fuel pressure after sitting as I had to borrow the pressure gauge but key on shows 44psi & idle shows 48psi, I really don't want to drop my tank if I don't need to.

As of now my options seem to be change the pump, fuel pressure reg, ignition module or go with a Gf1846 fuel filter, what would you guys do?

Thanks.
Slowsl1808 is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
no crank, intermittent up north S-Series Tech 15 11-22-2016 01:25 AM
Starts cold & hot, but not warm without a long crank time ncpi S-Series Tech 8 06-21-2013 09:53 PM
2000 SL2 Cold Starting Issues [Crank crank crank...] RarestRX S-Series Tech 8 02-12-2012 12:58 PM
97 SC2 DOHC will not crank at times E.M.D. S-Series Tech 4 09-16-2010 03:45 PM
long warm up times xupthree60 S-Series Tech 7 10-24-2006 10:16 AM


All times are GMT -4. The time now is 06:51 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.