SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn Astra > Astra General

Reply
 
Thread Tools Display Modes
Old 10-11-2021, 11:20 AM   #1
3mk
New Member
3mk is on a distinguished road
 
Join Date: Oct 2021
Posts: 2
Default C1233 Code - Front Left Wheel Speed Sensor Fix?

Hi everyone,

My 2009 XR has had the C1233 code for some time, as a result my ABS light and traction control lights have been stuck on.

Before I order any parts, is there any way to test if the sensor is indeed bad? Could cleaning it some how work? My speedometer seems to be working just fine.


Likewise, do I need to replace the whole hub, or is just the sensor itself fine? (Part number 13118565)

EDIT: My scan tool states C1233 is for the front left, but I see some posts online claiming 1233 is the front right, can anyone confirm?

Last edited by 3mk; 10-11-2021 at 11:31 AM. Reason: More info
3mk is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 10-11-2021, 02:06 PM   #2
AstraFasta
Advanced Member
AstraFasta has a spectacular aura aboutAstraFasta has a spectacular aura about
 
Join Date: May 2015
Posts: 817
 
Default Re: C1233 Code - Front Left Wheel Speed Sensor Fix?

That may be "C1233 00 Right Front Wheel Speed Sensor Circuit Low Input". But it could also be the left, so you need to CHECK BOTH RIGHT AND LEFT.

https://www.vauxhallownersnetwork.co.../#post-4195678

Main suspects are wheel hub, wiring, connectors. These rarely fail on the Astra but do from time to time. There are upstream systems but I wouldn't worry about those now.

- Inspect the wires coming out of the hubs for damage. Be careful as those are delicate and if you pull them out of the hub you need a new hub. Close to the hub, a rusty spinning axle can break the wires so look there carefully and make sure there is clearance!

- Are the big connectors near the hubs loose or damaged. Carefully disconnect, look for grime and damage. Clean. You can clean and reconnect to see if that helps.

- Check the wire going from those connectors towards the engine bay for damage also.

See if that helps. If not, if you have a DMM:

- Disconnect the speed sensor near the wheel, check that there is resistance on the two wires from the hub (e.g. there should be resistance say 1k ohms but 0 ohms would indicate trouble IME).

- Spin the wheel by hand and see if the DMM shows AC Voltage increase with speed. Should show a little voltage even turning wheel slowly.

You can start your research with this video
https://www.youtube.com/watch?v=hk8zgqW3fsY
AstraFasta is online now   Reply With Quote
Old 10-11-2021, 09:43 PM   #3
3mk
New Member
3mk is on a distinguished road
 
Join Date: Oct 2021
Posts: 2
Default Re: C1233 Code - Front Left Wheel Speed Sensor Fix?

Thank you for the thorough response! That's very helpful, I'll give the wiring a glance and cleaning this week.
3mk is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
left front suspension clunk on speed bump rfisher L-Series Tech 24 02-22-2019 07:52 AM
Wheel speed sensor issues code c0035 Saturn072014 Vue Tech 7 02-02-2018 06:27 PM
2008 Vue C0045 Left Rear Wheel Speed Sensor Code bz1lvn 2008 Vue 3 08-11-2017 12:14 PM
left front wheel bearing again foolonthehill S-Series Tech 24 12-26-2011 01:16 PM
04 Vue AWD V6 - Left front wheel clicking noise manually turn wheel when on jack johnnyphive Vue General 14 08-03-2010 08:19 PM


All times are GMT -4. The time now is 10:50 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.