SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 09-24-2022, 07:07 PM   #1
SL-2owner
New Member
SL-2owner is on a distinguished road
 
Join Date: Mar 2022
Posts: 3

2001 SL2
Default I've tried everything but still Poor MPG, odd shifting + more

2001 Saturn SL2 w/ 72,000 miles. So far I've replaced valvebody with sonnax valve body, cleaned tps iac, cleaned throttle body, replaced ect, cleaned egr valve, replaced spark plugs with ngk, changed battery (die hard), new air filter and transmission filter, new fuel filter, techron--I think that's it--yet like I said I'm still experiencing symptoms.

--Poor mpg--last tank I got the worst I've ever had, 17 mpg!
--Car accelerating on its own--sometimes from stop lights if i let go of brake, it'll go from 0 to about 20 and it'll continue on its own without me pressing the gas until I go up a steep hill or brake. It doesn't do this every day, like once every 1 or two
--Most annoying and frequent. Odd shifting--Sometimes car shifts completely drama free. But for the most part going up gears rpms will stay high 3-4 seconds longer than usual, then the car will correct itself but the car jerks--not violently, just slightly. No slamming or slippage that I've noticed.

Other things to note:
--the car does just fine highwaay driving. I drove to Harrisburg PA from north Jersey last week and averaged over 43 a tank. The power also feels fine when at higher speeds for an extended period of time

--there's no pattern to these symptoms. Granted it's the same symptoms that keep reoccurring but when they happen is completely at random and why I can't say.

--Took it in to three mechanics, all claimed the car looked just fine and no lighs or codes, though the mpg and other symptoms tell otherwise.

I bought the car in Feb, noticed issues in March and have been trying to get the car up to speed ever since but no dice yet. I really have no clue as to what it could possibly be at this point. The only other thing I can think of is vacuum leak, but if that comes back negative then i might have to throw in the towel trying to fix it (A part of me reasoned that it's just the quirks that come with a car being 20+ years old). If anyone has some ideas as to what might fix it at this point or any input really that'd be greatly appreciated
SL-2owner is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-25-2022, 08:27 AM   #2
fetchitfido
Super Member
fetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant future
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 15,180
 

2001 SC2
Default Re: I've tried everything but still Poor MPG, odd shifting + more

Some sort of vacuum leak for sure. Intermittent issues are often impossible to diagnose unless there's a specific pattern of actions to reproduce.

It's usually a bad idea to clean the IAC so I'd replace it. I'd be tempted to replace the TB as well even if it means a higher mileage unit, seals can dry out and tear when the car is a lawn ornament for so long.

I'd also check the 5v power lines going to a couple sensors, if that isn't solid enough the sensors will read wonky and it'll do odd things. The 5v power is sourced inside the PCM so the only way to fix a 5v issue is a PCM replacement.
fetchitfido is offline   Reply With Quote
Old 09-25-2022, 01:59 PM   #3
dtuuri
Member
dtuuri is a name known to alldtuuri is a name known to alldtuuri is a name known to alldtuuri is a name known to alldtuuri is a name known to alldtuuri is a name known to all
 
Join Date: Feb 2008
Location: Madison, OH
Posts: 110

1991 SC
Default Re: I've tried everything but still Poor MPG, odd shifting + more

Quote:
Originally Posted by SL-2owner View Post
--Poor mpg--... 17 mpg!
--Car accelerating on its own--...if i let go of brake,...without me pressing the gas It doesn't do this every day,
Odd shifting-- will stay high 3-4 seconds longer than usual, then the car will correct itself but the car jerks
--the car does just fine highwaay driving.
--Took it in to three mechanics, all claimed the car looked just fine and no lighs or codes,
Sounds to me like maybe your gas pedal is just sticking. Maybe the return spring is weak? When it is idling high, lift the hood and twist the throttle linkage to the idle stop to see if RPMs come down. That's all I can offer I'm not a mechanic, just another owner.
dtuuri is offline   Reply With Quote
Old 09-28-2022, 10:45 PM   #4
toggenburg
Master Member
toggenburg has much to be proud oftoggenburg has much to be proud oftoggenburg has much to be proud oftoggenburg has much to be proud oftoggenburg has much to be proud oftoggenburg has much to be proud oftoggenburg has much to be proud oftoggenburg has much to be proud oftoggenburg has much to be proud of
 
toggenburg's Avatar
 
Join Date: Apr 2010
Location: Beautiful Blue Ridge Mountains of Bedford, Virginia. Born once? Die twice. ------ Born twice? Die once.
Posts: 3,597

2001 SL1
Default Re: I've tried everything but still Poor MPG, odd shifting + more

"the car does just fine highwaay driving. I drove to Harrisburg PA from north Jersey last week and averaged over 43 a tank."

This is a puzzle, unless you have super heavy and slow moving traffic commutes giving you 17 mpg.
A lead footed owner usually does not get 43 on any open road.

Why such a great difference?
toggenburg is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard shifting, poor ride quality Feels S-Series General 0 10-25-2014 01:37 AM
2001 300 Wagon, poor mleage and rough shifting. gdh12 L-Series Tech 4 08-25-2013 08:10 PM
Anwser to service wrench poor shifting Garciavision L-Series Tech 3 04-26-2011 11:12 AM
no power ,high rpm miss,poor shifting mbers1 S-Series Tech 5 11-03-2005 07:25 AM
Poor shifting Tim T S-Series General 13 07-14-2005 01:47 PM


All times are GMT -4. The time now is 07:21 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.