SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 04-20-2020, 07:51 PM   #381
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

Quote:
Originally Posted by Cheyne View Post
I had that same Stant failure last fall.
I know everyone here says Stant only. However, this is the only repair I do repeatedly. Itís annoying. So, Iím doing something different and made in Israel is far better than China or the other cheep parts countries.
1996SL11.9L is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-22-2020, 05:25 PM   #382
NWSaturn247
Senior Member
NWSaturn247 will become famous soon enoughNWSaturn247 will become famous soon enough
 
NWSaturn247's Avatar
 
Join Date: Feb 2012
Location: PNW
Posts: 1,163
 

1999 SL2
Default Re: 1996SL11.9L's 2002 SL1

^^^ yep, I installed a made in China Stant on my '93 Saturn, which worked great

for about two years. Then started running cooler.

I have the made in Israel, Murray thermostat installed in my '99, about year and a half, functioning great so far.

I have the original housing set aside just in case a made in Germany Stant makes an appearance
...
1999 SL2 A4 -96k miles
Currently sipping Mobil 1 + Delvac 1300 + LM2009 + Rislone

3 ounces Lucas UCL per fill-up



.....
1993 SL2 SOLD @189k
NWSaturn247 is offline   Reply With Quote
Old 05-14-2020, 10:00 PM   #383
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

The reman AC compressor I installed last spring just had the clutch fail. Just like my factory one did. Itís out of warranty.

I guess Iím going junking soon. Iím not spending another 400 on a compressor.
1996SL11.9L is offline   Reply With Quote
Old 05-15-2020, 06:41 AM   #384
454cid
Advanced Member
454cid is a jewel in the rough454cid is a jewel in the rough454cid is a jewel in the rough
 
Join Date: May 2019
Posts: 743
Default Re: 1996SL11.9L's 2002 SL1

Quote:
Originally Posted by NWSaturn247 View Post
I have the original housing set aside just in case a made in Germany Stant makes an appearance
I don't think any Stant is made in Germany unless they're getting thermostats from a German company for specific German car applications.
...
2000 SL2 Automatic 200,XXX miles.
1999 Chevy K3500
454cid is offline   Reply With Quote
Old 05-24-2020, 12:45 PM   #385
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

On the 4Runner Fourm I belong to a bunch of people have ended up with counterfeit NGK spark plugs.

I looked at the Dual ground plugs in a double platinum and they seem to be legit.

Itís time to change out those EK heat range 6 plugs. They have around 60k miles on them now. I put the Denso equivalent in my wifeís outback.

I almost but the platinums in the Subaru.

Now that itís warm out Iím getting 43mpg for work taking the city route. I can drive 30-35mph in 5th gear. It helps a lot.

Iím also starting to see coolant weep out the headgasket area of cylinder 4.
1996SL11.9L is offline   Reply With Quote
Old 06-22-2020, 08:58 PM   #386
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

A friend of mine retired his 2001 from the rear drivers side suspension rust.

I got the AC compressor off of it. It pulled 30Ēhg almost instantly. Left it on for over an hour, checked for leaks and charged it.

I got AC again.
1996SL11.9L is offline   Reply With Quote
Old 06-24-2020, 01:37 PM   #387
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 13,199
 

2002 SC2
1998 SL2
Default Re: 1996SL11.9L's 2002 SL1

Quote:
Originally Posted by 1996SL11.9L View Post
A friend of mine retired his 2001 from the rear drivers side suspension rust.

I got the AC compressor off of it. It pulled 30Ēhg almost instantly. Left it on for over an hour, checked for leaks and charged it.

I got AC again.
Nice. You've had quite a bit of woes with compressors, iirc.

Went to use mine the other day, was a nope. Put the gauges on, pressures are normal - clutch is not engaging even with low pressure safety switch jumped. Sigh . . . 90F + and humid last week.
glad to be working from home
Quote:
On the 4Runner Fourm I belong to a bunch of people have ended up with counterfeit NGK spark plugs.
Was it a common source or were they showing up in random places?
...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 151k DD
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles
alordofchaos is offline   Reply With Quote
Old 06-28-2020, 08:32 PM   #388
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

Quote:
Originally Posted by alordofchaos View Post
Nice. You've had quite a bit of woes with compressors, iirc.

Went to use mine the other day, was a nope. Put the gauges on, pressures are normal - clutch is not engaging even with low pressure safety switch jumped. Sigh . . . 90F + and humid last week.
glad to be working from home
Was it a common source or were they showing up in random places?
It seemed to be both eBay and Amazon. I bought the double platinum 6EK dual ground plugs and they look legit. I have over 50k on my regular 6EK plugs and itís time to swap them out.

Sounds like your clutch gave out.
1996SL11.9L is offline   Reply With Quote
Old 08-19-2020, 07:22 PM   #389
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

I finally changed the spark plugs.

They had 60k miles on them. They were eroded to around .055 gap.
Attached Images
File Type: jpg 02B92D42-102A-4DE8-A9FE-DFF563912122.jpg (137.6 KB, 5 views)
1996SL11.9L is offline   Reply With Quote
Old 04-13-2021, 07:20 AM   #390
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

So, recently Iíve been having TPS issues. AKA after driving awhile the position at idle wonít be zero anymore. Stoping and starting it would put it back to 0 again. That sensor was aftermarket and was installed the weekend I bought this car a few years ago when this thread was started.

So, I put in a Autozone TPS and all was good for around 3 months. Then I bought a BWD from advanced auto and three months now itís doing the same thing. Started this mornings 25 mile drive to work and by the halfway Mark it drifted up to a 3 at idle. It eventually ended up at 5% at idle and pulling back on the throttle bellcrank made no difference. I canít find anything wrong with my throttle body mechanically. Are all aftermarket TPSís crap now?

I guess itís time to go junking and look for a few OEM ones.

Now that itís above 50 degrees Iím averaging 45mpg for my tank.

To be continued.
1996SL11.9L is offline   Reply With Quote
Old 04-13-2021, 11:08 AM   #391
billr
Master Member
billr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to behold
 
Join Date: Jul 2013
Posts: 6,002
Default Re: 1996SL11.9L's 2002 SL1

If you want to spend $5 to mail them to me, I will disassemble/inspect to see if they are really bad or you are throwing TPS units at a wiring/PCM/linkage problem. I can't guarantee an absolute verdict, but am will to give it a try. Send PM if interested.
billr is offline   Reply With Quote
Old 04-13-2021, 12:47 PM   #392
1996SL11.9L
Senior Member
1996SL11.9L has a spectacular aura about1996SL11.9L has a spectacular aura about
 
1996SL11.9L's Avatar
 
Join Date: Sep 2009
Location: Stouchsburg, PA
Posts: 1,955
 

2002 SL1
Default Re: 1996SL11.9L's 2002 SL1

Quote:
Originally Posted by billr View Post
If you want to spend $5 to mail them to me, I will disassemble/inspect to see if they are really bad or you are throwing TPS units at a wiring/PCM/linkage problem. I can't guarantee an absolute verdict, but am will to give it a try. Send PM if interested.
Thanks for the offer. I guess I could do that too.....instrumentation is part of my job.

Iíll ohm it cold and hot this off stretch. It still is linear from idle to WOT. It just seems to build some resistance with heat.....
1996SL11.9L is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 sc2 b.c.m. piperpilot S-Series Tech 2 11-12-2014 09:34 PM
2002 sl 1 Dee631 S-Series Tech 1 11-04-2014 05:36 PM
2002 SC2/Metra 70-2002 stereo harness issue Kai S-Series Tech 4 12-14-2008 03:41 PM
2002 SL1 Help Please reddragonflys20 S-Series Tech 9 11-21-2006 04:26 PM
2002 Sc2 Sps mle S-Series General 1 07-02-2005 07:33 PM


All times are GMT -4. The time now is 10:11 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.