SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series General

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-24-2021, 03:17 PM   #1
vinnyM
New Member
vinnyM is on a distinguished road
 
Join Date: Feb 2021
Posts: 6
Default L200 2002 won't stay on running

Hi, my Saturn L200 2002 has approx. 175k, has run perfectly the same I took it off the lot in '02. Always did usual/general maintenance to it over the years. No major issues with the car at all.
About 2 weeks ago in cold weather, I tried to start car in driveway, it turned slowly but would not turn over. Tried again, same thing...I figured the battery is about 5 years old, let me replace it. Everything was dim in the car/dashboard etc Bought new battery from AutoNation, hooked it up..turned the key once..all the lights came on like a Xmas tree, figured that was the problem, car turned over fine, then conked out in 2 secs. Now the car won't stay on for 2 secs...turns over fine. I've changed the battery out before with this car, no problem before.
Towed it to my garage, they can't figure out the problem (yet). they tested the fuel pump (enough pressure) they found some of the grounds were shorted...replaced those, they thought the computer was fried, they replaced it, same thing happens..car conks out in 2 secs. It never did this before in all the 20 years, ran fine, ran smooth. Can anyone give any advice what this might be? The garage said the alternator is fine, they have the computers hooked up to it doing all the tests they can't find anything.
I did notice after I changed the battery when I first turned the key once the fuel pump in the back/tank sounded "louder" and a bit more of a whirrr...and when the car wouldn't stay on I tried to start a few times then I started getting a gas smell, so I stopped...but the garage tested the fuel pressure and said its good. I think this is something simple...
I tried the 10 min. security key test etc...same thing happens. Security light does not come on btw...but the other maintenance lights come on.
Can anyone pls offer any advice or something similar that may have happened to you? thanks Vinny
vinnyM is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Does not stay running dragonem S-Series Tech 2 07-23-2014 04:01 PM
SC1 Won't stay running alfasteve L-Series Tech 1 05-29-2012 03:18 PM
SC1 won't stay running alfasteve S-Series Tech 4 05-29-2012 09:08 AM
91 sc won't stay running medwards22 S-Series Tech 24 05-05-2009 02:52 PM
Help! L200 Won't Stay Running.. tfmc369 L-Series Tech 3 06-07-2007 02:14 PM


All times are GMT -4. The time now is 08:54 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.