SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Astra > Astra Tech

Reply
 
Thread Tools Display Modes
Old 04-10-2017, 10:50 PM   #1
Valikir433
New Member
Valikir433 is on a distinguished road
 
Join Date: Aug 2012
Location: Michigan
Posts: 8

2008 Astra XE
Default Radio not outputting sound

I drive a 2008 Astra and have just recently came across the problem of my radio not outputting sound. I say outputting sound because the display still is lit and I can switch between the CD and the radio just fine and it displays radio station information and CD track number like usual. The board computer functions (avg. fuel consumption, avg. speed, etc.) work fine I just can't hear anything no matter what the input source is for the radio. My first thought was maybe a fuse so I went and pulled the fuse for the radio and it was fine so I replaced it and when I started up the car the radio was working again but this only lasted for about 2 days. Has anyone else had a similar problem or even a way I can troubleshoot this further? I thought after it did a reset (like what happened when I pulled the fuse) that it might be okay for quite a while but I'd rather not have to pull the fuse every couple of days.
Thanks in advance
Valikir433 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-11-2017, 11:13 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 44,830
 

2003 L-Series 3.0L Sedan
Default Re: Radio not outputting sound

This may be an intermittent problem. Hopefully its just that and not a serious issue. By intermittent, I mean one possibility if your radio uses an aux port for inputting signals from an mp3 player. A Nissan Sentra had this same problem when sounds died. A factory radio without a CD or other options. The display was fine and tuning stations worked but zero sounds. Then a few months later sounds returned. I don't have a radio with an aux port but my guess is this Sentra and person uses the aux port to play recorded mp3 music from a portable device. Like headphone ports, a set of electrical contacts disconnect signals. When these contacts oxidize and cannot make contact, signals are lost. These signals are the inputs to the amp. When the port connections don't reconnect after a plug it's removed, sounds are lost as if the radio amp failed. The aux contacts aren't reconnecting. The simplest solution is to plug in the mp3 player or exercise the aux port by connecting and disconnecting a plug several times to see if sounds returns. Plugging in an mp3 player with sounds returning verifies the aux port is the problem.
fdryer is offline   Reply With Quote
Old 04-11-2017, 06:37 PM   #3
tackepj
Senior Member
tackepj will become famous soon enough
 
tackepj's Avatar
 
Join Date: Nov 2004
Location: Seven Valleys, PA
Posts: 1,243
 

2008 Astra XE
Default Re: Radio not outputting sound

No aux port in any factory Astra radio (sadly).
...
Former: 2005 L300, 2007 VUE Green Line
Current: 2008 Astra XE
tackepj is offline   Reply With Quote
Old 04-12-2017, 11:35 AM   #4
emg77
Advanced Member
emg77 has a spectacular aura aboutemg77 has a spectacular aura aboutemg77 has a spectacular aura about
 
emg77's Avatar
 
Join Date: May 2005
Location: Michigan
Posts: 905
 

2008 Astra XR
Default Re: Radio not outputting sound

I had problems early on with the volume knob not working right, and losing sound intermittently. I was able to adjust the volume with the steering wheel controls (which you don't have if you have the XE version). That's the only thing I can think of.

I'd offer you my OEM radio, since I replaced mine with an aftermarket Eonon, but the cost to install it back in the car, get a dealer to use a tech 2 "divorce it" from the screen, etc, would make it not worth the time and money (stupid anti-theft features).

If you plan on keeping the car and can find one cheap, the Parrot MKi9200 is a nice upgrade (you need a wiring harness too). I hardly use my radio anymore and just play everything over my phone through the Parrot system.
...
Drives: 2014 Volt, 2017 Acadia
Past Cars: 08 Astra, 15 Acadia, 12 Enclave, 09 Traverse, 05 Vue, 04 Grand Prix, 00 Alero, 97 LeSabre, 72 Cutlass S
emg77 is offline   Reply With Quote
Old 01-25-2018, 09:54 AM   #5
Layoira
Senior Member
Layoira is on a distinguished road
 
Layoira's Avatar
 
Join Date: Aug 2008
Location: St.John's, Newfoundland, Canada
Posts: 1,512
 

2008 Astra XR
Default Re: Radio not outputting sound

The wiring that runs down the drivers side sill panel and in the doors is usually the problem for this. It is a design flaw, there is not enough slack and every time you open the rear drivers side door if itís too wide you can fray and damage the wires going into the door inside the gromet there.

Take them out and take a look. Chances are you have damaged wires.

Quick and easy repair and itís a known issue in this car.

That would be the first place I would look. Good luck!
...
~Christina~
Astra XR5: 3M Film,GID, Arm Rest, SRi Wheel, Tints (50/35/13), Pioneer Nav Unit, Debadged, Glovebox Cooling, VXR Surrounds, Painted Grill, XP Spoiler, HIDS, Footwell Lighting. Pics Up :)
Layoira is offline   Reply With Quote
Old 02-10-2018, 01:45 PM   #6
PaulR
Member
PaulR will become famous soon enough
 
Join Date: Dec 2012
Location: Appleton, WI
Posts: 269
Default Re: Radio not outputting sound

Quote:
Originally Posted by Valikir433 View Post
I drive a 2008 Astra and have just recently came across the problem of my radio not outputting sound. I say outputting sound because the display still is lit and I can switch between the CD and the radio just fine and it displays radio station information and CD track number like usual. The board computer functions (avg. fuel consumption, avg. speed, etc.) work fine I just can't hear anything no matter what the input source is for the radio. My first thought was maybe a fuse so I went and pulled the fuse for the radio and it was fine so I replaced it and when I started up the car the radio was working again but this only lasted for about 2 days. Has anyone else had a similar problem or even a way I can troubleshoot this further? I thought after it did a reset (like what happened when I pulled the fuse) that it might be okay for quite a while but I'd rather not have to pull the fuse every couple of days.
Thanks in advance
I have had the same problem in my XE. The radio sound usually comes back on after a couple of days or weeks. It is not worth the trouble to track down the problem, for me anyways, with intermittent things such as these.
...
PaulR

2008 XR3 5 speed, heated seats, leather, premium sound , 18" wheels, center armrest
2008 XE5 5 speed, heated seats, panoramic moonroof
PaulR is offline   Reply With Quote
Old 02-12-2018, 03:45 PM   #7
Astra08
Member
Astra08 is on a distinguished road
 
Astra08's Avatar
 
Join Date: Oct 2010
Location: Marietta, GA
Posts: 173

2008 Astra XR
Default Re: Radio not outputting sound

Quote:
Originally Posted by tackepj View Post
No aux port in any factory Astra radio (sadly).
Not completely accurate. The one in mine was sourced from the UK and it does have the factory aux port.

For those who want to keep the stock look and feel it's an option.
Astra08 is offline   Reply With Quote
Reply

Bookmarks

Tags
2008, astra, radio, saturn


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No sound from radio picaman Ion General 8 08-31-2014 10:54 AM
no sound from radio butters122706 L-Series Tech 0 01-13-2013 09:18 AM
VUE Radio-Not getting sound LuvMyVue04 Vue Tech 6 11-12-2006 01:45 PM
Help With '03 ION Radio - No Sound Jeremy4152 Ion Tech 3 09-27-2005 03:51 AM
Radio POP sound Plastic Gravity Miscellaneous Tech 1 10-26-2001 03:11 AM


All times are GMT -4. The time now is 03:13 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.