SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech

Reply
 
Thread Tools Display Modes
Old 02-18-2019, 01:54 PM   #1
Catfishgold
New Member
Catfishgold is on a distinguished road
 
Join Date: Feb 2019
Posts: 3
Question 01 L300 Tranny Shifting hard

Hello,

I have a 2001 Saturn L300 v6 3.0 180k miles. It Has began Shifting hard, Showing codes p0717, p0742, p1780.

I was thinking replace the input shaft speed sensor first to see if that is the issue, unfortunately i cannot locate it. Any help is appreciated. The vehicle has new plugs about a year ago, both coil packs have been replaced. Timing job, replacing belt and tension pulley. Water pump was replaced at same time. New rear shocks and replaced on coil spring. replaced rear valve cover gasket, the oil leak killed two alternators so it had to be done lol. It is my fiance's car and the last 10k miles the car has experienced more and more issues. All repairs have been done by me or father in-law. Would really like to continue repairing what we can on our own as i do not want to dump too much money into the vehicle. We were about to replace front struts when this issue arose.
Catfishgold is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-18-2019, 03:42 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,069
 

2003 L-Series 3.0L Sedan
Default Re: 01 L300 Tranny Shifting hard

While not expert on automatics, was xmission oil and filler ever replaced? This has no bearing on input speed sensor operation as its monitoring drive sprocket teeth to generate signals. I can imagine two scenarios for failure; iron filings attracted to the magnetic sensor and altering its ability to generate signals or sensor failure. Sensor failure can be measured for resistance, between 615-835 ohms if you can get to wiring. P0717 is input shaft speed sensor error.

P0742 is about torque converter (TCC) clutch solenoid issues. P1780 is about canbus communication error between ecm and tcm.
Attached Images
File Type: jpg TifToGif.jpg (44.6 KB, 5 views)
fdryer is offline   Reply With Quote
Old 02-18-2019, 03:57 PM   #3
Catfishgold
New Member
Catfishgold is on a distinguished road
 
Join Date: Feb 2019
Posts: 3
Default Re: 01 L300 Tranny Shifting hard

She has had the car for about 6 years and it was her grandfathers before that. I can tell you that no transmission service has been done while the car has been with us so at least 6 years and around 40,000 miles of no service.

I watched a tear down video of the 4t40e and it appears the iss is inside the transmission behind the valve body. Is that correct? Also the video mentioned the possibility of iron shavings confusing the sensor.
Catfishgold is offline   Reply With Quote
Old 02-18-2019, 04:07 PM   #4
Catfishgold
New Member
Catfishgold is on a distinguished road
 
Join Date: Feb 2019
Posts: 3
Default Re: 01 L300 Tranny Shifting hard

Also I replaced the coil pack for a misfire about 2 months ago. When the codes were ran none of these new codes were there, so they have all been thrown in the last 2 months. Just for a reference in the amount of time these ses codes have been present. The symptoms of the hard shift started about a week ago.
Catfishgold is offline   Reply With Quote
Old 02-18-2019, 05:14 PM   #5
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,069
 

2003 L-Series 3.0L Sedan
Default Re: 01 L300 Tranny Shifting hard

Saturn (GM) service manuals lack details like photos, line drawings, engineering cutaways from years ago when more details made it easier for everyone to have a good idea of a part ID and where its located. The single drawing in service manuals to replace the iss appears to be inside the xmission so I chose not to include it here. Suggesting measuring resistance might help before presuming a failed part and wasting time tearing apart your xmission. Although not representative of any history from public forums, no one has reported a faulty input speed sensor in our xmissions. P0742 is another code - I don't recall it being reported here. P1780, about canbus communication does occur from time to time but its an alert more than a real condition since its more about module communications amongst themselves with a flag to announce 'Mom, Charlie isn't washing his hands again..." type of error code. Other than damaged wiring harnesses, P1780, in my opinion, may be the least of your problems.

The ecm has two siamese multiple pin connectors on the right rear of the engine plugged into the top of the 4"x4"(?) ecm. The tcm is under the passenger side windshield cowling where you can see the multi-wire harness on the firewall showing where it disappears into the corner of the plastic cowling.

Personally, I'd be more inclined to try examining wire harnesses, their connections then finding the best access to measure iss sensor resistance before presuming sensor fault where the xmission is removed/accessed for sensor replacement. Its always your choice to find the best way for repairs - diy, dealer or repair shop.
fdryer is offline   Reply With Quote
Reply

Bookmarks

Tags
2001 l300, hard shifting, input shaft speed sensor, ses light


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
01 L300 Service Wrench Light and Hard Shifting morashon L-Series Tech 8 05-11-2016 05:20 PM
hard shifting tranny AGAIN pinturbo75 S-Series Tech 14 07-19-2014 12:53 PM
03 l300 shifting hard SACTOWNMOM L-Series General 14 07-17-2011 10:11 PM
Hard Shifting on L300, U Codes? how to fix? lcluvinlife L-Series Tech 4 05-01-2010 09:07 PM
Hard shifting tranny BradJK S-Series Tech 5 02-06-2008 08:01 PM


All times are GMT -4. The time now is 10:56 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.