SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion General

Reply
 
Thread Tools Display Modes
Old 10-17-2016, 10:27 PM   #1
mickey2077
Junior Member
mickey2077 is on a distinguished road
 
Join Date: May 2007
Posts: 22
Default Front Passenger Turn Signal Issue

I have a 2003 Saturn Ion2 an the front passenger turn signal is not working. When you try to turn the signal on you get a rapid clicking that normally indicates the bulb is faulty. I changed the bulb twice and still nothing. I turned on the hazard lights and only the left is working. I disconnected and reconnected all the plugs that go to the headlight unit and nothing. When the lights are turned on the amber lamp does glow but will not blink when the signal is engaged. Any help that anyone can provide would be greatly appreciated.
Thank you!!!
mickey2077 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-07-2016, 11:01 AM   #2
busdriver1957
New Member
busdriver1957 is on a distinguished road
 
Join Date: Jan 2016
Posts: 5
Default Re: Front Passenger Turn Signal Issue

Mickey,I too had this problem with my 04 ion. I ended up changing the sock assembly. Fixed the problem
busdriver1957 is offline   Reply With Quote
Old 11-09-2016, 09:53 PM   #3
PoisonIvy
New Member
PoisonIvy is on a distinguished road
 
Join Date: Nov 2016
Posts: 7
Default Re: Front Passenger Turn Signal Issue

When I changed my front passenger bulb about a week ago, I buttoned everything up and found the exact same issue. The daytime running light worked, but I wasn't getting the signal. I pulled the headlight out again and adjusted the bulb a bit, and it then worked. So I had a set of dental tools (from a hardware store), and used one to pull/pry the 'tabs' out a bit to make sure they were contacting the points on the bulb base snugly.

If you don't use the higher volt rated bulb it'll burn out pretty quickly. Often melting the base. So make sure the contact points in the socket aren't covered in melted plastic or burn marks, that need cleaning. Maybe a little scraping with a screwdriver or file might clean them up if they are.
PoisonIvy is offline   Reply With Quote
Old 03-14-2017, 01:09 AM   #4
Elsongs
Member
Elsongs is on a distinguished road
 
Elsongs's Avatar
 
Join Date: Jun 2005
Location: Los Angeles
Posts: 199
 

2005 ION-2 Sedan
Default Re: Front Passenger Turn Signal Issue

I had this problem a couple years ago. The bulb was fine but the contacts were "slightly burned out" that there was no electrical contact. I used some sandpaper to clean it off and used a tiny piece of folded aluminum foil to help establish contact. From then on everything was fine.
Elsongs is offline   Reply With Quote
Reply

Bookmarks

Tags
blinkers, ion 2, turn signals


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signal Issue Darkfyre13 S-Series Tech 5 07-01-2016 02:21 PM
Turn Signal Issue rocket321 Vue Tech 4 09-29-2012 11:12 PM
Turn Signal issue--- 94 SL2 2NDSOUT S-Series Tech 9 10-20-2009 06:36 PM
Turn Signal issue HWWD L-Series Tech 8 08-30-2007 02:04 PM
Turn signal issue leftlaneloony Ion General 5 10-02-2003 12:26 PM


All times are GMT -4. The time now is 05:22 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.