SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General

Closed Thread
 
Thread Tools Display Modes
Old 03-01-2005, 05:18 PM   #1
MadAdam
Junior Member
MadAdam is on a distinguished road
 
Join Date: Feb 2005
Location: Michigan
Posts: 31
 

1997 SL2
Default Can't lube my steering components?

My '97 SL2 has developed a loud low squeeking or rubbing noise when I turn in either direction. The noise seems to go away when it is wet outside(during rain or after wet snow). My power steering fluid level is fine and I think I can rule this system out as the problem. After consulting my Haynes' manual, I learned that all steering components are sealed at the factory and do not require lubrication. Is this true even for Saturn's with 180K? Does anyone have any ideas as to what might be causing this and if there is anything I can do myself to fix it?
MadAdam is offline  
SaturnFans.com Sponsored Links
Old 03-02-2005, 12:40 AM   #2
sierrap615
Master Member
sierrap615 is on a distinguished road
 
sierrap615's Avatar
 
Join Date: Aug 2003
Location: Downers Grove, Illinois
Posts: 2,538
 
Default Re: Can't lube my steering components?

first determine if the sound is comming from inside or outside the cab.

chances are its outside. i would inspect the tie-rod jounts first. if they are found bad, they can not be lubed, the LCA needs replaced.
sierrap615 is offline  
Old 03-02-2005, 04:58 PM   #3
MadAdam
Junior Member
MadAdam is on a distinguished road
 
Join Date: Feb 2005
Location: Michigan
Posts: 31
 

1997 SL2
Default Re: Can't lube my steering components?

Thanks for the suggestion. The noise is deffinitely coming from outside the cab, and it sounds like it is directly in front of the driver's side straigh down the column. It kind of sounds like rubber rubbing on rubber. After searching and reviewing other posts with steering issues I think I should also check my steering rack. Others have reffered to a grinding noise while turning, and their problem was the steering rack. I think my tie rod ends are original so they probably need to be replaced as well. Thanks again for the suggestion.
MadAdam is offline  
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing a/c components bender S-Series Tech 8 08-06-2008 03:54 PM
New 6.5 components in the rear mac99sl2 S-Series Mods 15 04-22-2008 09:52 PM
components in an 02 sc2 Garrick S-Series General 0 03-14-2008 12:47 PM
Which suspension components? lilcraigford Mods and Performance 5 07-19-2005 09:49 AM
FS: A/C components, and various other items project_sl-2 Classifieds 3 06-29-2004 07:31 AM


All times are GMT -4. The time now is 10:08 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.