SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 01-14-2006, 12:10 AM   #1
dbarrett5381
Junior Member
dbarrett5381 is on a distinguished road
 
Join Date: Jan 2006
Posts: 15
Dizzy weird noises and other symptoms on 2000 sl2 98000 miles

Hi, I bought my sl2 6 months ago with 88000 miles on it. Since them I have had some issues and was hoping for some help. The first, most annoying issue, is an issue where I have a sound coming from the front drivers side that sounds to me like an exhaust leak. It sounds like a high performance muffler up there. It only does it at low rpms, like when I am idling or just starting out in first gear. 2nd issue is the fact that I am getting about 240 miles to a tank of gas! Is this normal? My suv gets better mileage than that! 3rd problem is a rough Idle (feels like it is missing) Now let me tell you what I have already tried in an effort to correct these issues. 1. changed upper motor mount 2. changed ects (didn't check connector but will do that tomorrow) 3 changed spark plugs and wires 4. changed air filter 5. sea foam does anyone know what could be causing these problems?
dbarrett5381 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-14-2006, 01:51 AM   #2
dansl2
Advanced Member
dansl2 is on a distinguished road
 
dansl2's Avatar
 
Join Date: May 2005
Location: Oakland CA
Posts: 963

2000 SL2
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

Welcome to the board!
Do you have the stock intake or is it modified? That could account for "performance muffler noise".
Have you cleaned the TB? That is, removed it & cleaned butterfly & IAS? That & cleaning your EGR could help with the rough idle. Probably should replace the PCV if you haven't already also.
...
Experience is something you don't get until just after you need it.
dansl2 is offline   Reply With Quote
Old 01-14-2006, 01:56 AM   #3
dbarrett5381
Junior Member
dbarrett5381 is on a distinguished road
 
Join Date: Jan 2006
Posts: 15
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

It is stock intake, I already replaced pcv (forgot to add that to my list) I was goint to try cleaning the egr tomorrow. I would do the throttle body and IAS too but I don't know what those are! I will do a search and see what I come up with. Any other ideas about the noise?
dbarrett5381 is offline   Reply With Quote
Old 01-14-2006, 11:55 AM   #4
dansl2
Advanced Member
dansl2 is on a distinguished road
 
dansl2's Avatar
 
Join Date: May 2005
Location: Oakland CA
Posts: 963

2000 SL2
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

TB=Throttle Body
IAS=Intake Air Sensor (sometimes it is called AIS) attached to the TB
Cleaning the TB is REALLY easy, should take maybe 45 minutes for the job. There are only 4 bolts holding it on, but I think earlier models two. Disconnect the two electrical bundles, the vacumn lines, & the throttle cable (all really easily done). When you remove it, be careful you don't tear the gasket, or you'll have to see the dealer for that. Remove the IAC-a pointy thing with a spring around it,(you'll need a torx drive for this, size 20 I think)-careful not to loose that gasket either- then spray the heck out of the inside & butterfly valve with carb cleaner. Use an old toothbrush to scrub off the stubborn carbon & make sure you spray out the access ports. Also spray the AIC pintle & spring to get all the carbon off there too. Don't mess with the pintle, as it should be in the retracted position & if it extends it can be a bear to get back on the TB. Spray the outside of the TB also to make sure there isn't any grung binding the throttle spring. Reassemble & replace. Should be good to go. You may want to use contact cleaner on the electrical connectors & some dielectric grease on them before reattaching.

Don't have a suggestion on the noise, other than maybe a leak at the exhaust manifold , or a hole in the flex pipe? Any exhaust mods done on it? On the other hand, it just could be the normal sound of our powerful 1.9 engine.
...
Experience is something you don't get until just after you need it.

Last edited by dansl2; 01-14-2006 at 12:03 PM.
dansl2 is offline   Reply With Quote
Old 01-14-2006, 12:27 PM   #5
Razorbak
Master Member
Razorbak is on a distinguished road
 
Razorbak's Avatar
 
Join Date: Aug 2004
Location: Chicagoland
Posts: 2,860
 

1996 SL2
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

Quote:
Originally Posted by dansl2
Have you cleaned the TB? That is, removed it & cleaned butterfly & IAS? That & cleaning your EGR could help with the rough idle. Probably should replace the PCV if you haven't already also.
Quote:
TB=Throttle Body
IAS=Intake Air Sensor (sometimes it is called AIS) attached to the TB
The Intake Air Temperature (IAT) sensor is located near the front of the vehicle on the air filter housing. The Idle Air Control (IAC) valve is attached to the throttle body. Here's a good exploded parts schematic that sierrap615 posted for reference.

http://www.saturnfans.com/photos/sho...hp/photo/15887

Quote:
Cleaning the TB is REALLY easy, should take maybe 45 minutes for the job. There are only 4 bolts holding it on, but I think earlier models two. Disconnect the two electrical bundles, the vacumn lines, & the throttle cable (all really easily done). When you remove it, be careful you don't tear the gasket, or you'll have to see the dealer for that. Remove the IAC-a pointy thing with a spring around it,(you'll need a torx drive for this, size 20 I think)-careful not to loose that gasket either- then spray the heck out of the inside & butterfly valve with carb cleaner. Use an old toothbrush to scrub off the stubborn carbon & make sure you spray out the access ports. Also spray the AIC pintle & spring to get all the carbon off there too. Don't mess with the pintle, as it should be in the retracted position & if it extends it can be a bear to get back on the TB. Spray the outside of the TB also to make sure there isn't any grung binding the throttle spring. Reassemble & replace. Should be good to go. You may want to use contact cleaner on the electrical connectors & some dielectric grease on them before reattaching.
Your cleaning procedure is very good.

Last edited by Razorbak; 01-14-2006 at 12:35 PM.
Razorbak is offline   Reply With Quote
Old 01-14-2006, 12:35 PM   #6
Old_Coot
Member
Old_Coot is on a distinguished road
 
Old_Coot's Avatar
 
Join Date: Dec 2005
Posts: 359
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

About that exhaust noise, if you want to narrow it down you can use a stethescope, or a chunk of hose with one end near your ear, and the other end can be moved around in the area you suspect the noise is coming from.

When it gets louder you are in the general area, then do a visual to confirm it.
Old_Coot is offline   Reply With Quote
Old 01-14-2006, 12:43 PM   #7
dbarrett5381
Junior Member
dbarrett5381 is on a distinguished road
 
Join Date: Jan 2006
Posts: 15
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

cool thanks for all the tips. I will be tackling thi project today and hope to get everything working properly. I am not a mechanic but am really good at following directions. I have done all the work on my car. I feel confident that I can do pretty much anything except an engine swap. I will report back here with results.
dbarrett5381 is offline   Reply With Quote
Old 01-15-2006, 06:51 PM   #8
dbarrett5381
Junior Member
dbarrett5381 is on a distinguished road
 
Join Date: Jan 2006
Posts: 15
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

well I cleaned the entire throttle body, replaced thermostat, replaced ects (again), replaced ects connector, cleaned egr and changed tensioner and belt. any other ideas? I am now very discouraged and wish I never would have bought a saturn. Does anyone know about how much I can get out of a 2000 sl2 (blue), manual, with 98000 miles on it? thanks
dbarrett5381 is offline   Reply With Quote
Old 01-15-2006, 09:00 PM   #9
dansl2
Advanced Member
dansl2 is on a distinguished road
 
dansl2's Avatar
 
Join Date: May 2005
Location: Oakland CA
Posts: 963

2000 SL2
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

Sorry to hear you are so fustrated. Did any of the things you replaced/cleaned affect performance, good or bad? What is it doing or not doing that has your shorts in a bunch? Rough idle could be you just need to run a bottle of Techron system cleaner & the front engine noise could be...well, I don't know what that could be right now.
...
Experience is something you don't get until just after you need it.
dansl2 is offline   Reply With Quote
Old 01-15-2006, 09:21 PM   #10
dbarrett5381
Junior Member
dbarrett5381 is on a distinguished road
 
Join Date: Jan 2006
Posts: 15
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

I guess the thing that I am so frustrated about is gas mileage and the noise from the front. over the last six months I have calculated my gas mileage everytime I fill up and from filling up twice a week every month for the last six months I have gotten 24.6 miles per gallon, does this sound right? I bought this car for better gas mileage and I am not getting it, my suv gets better mileage then that and it has a 3.5 liter v6 in it. I think if I was getting better gas mileage I could live with the rest. As far as techron goes, I run a bottle of that every oil change, plus I just seafoamed everything 3500 miles ago? any suggestions
dbarrett5381 is offline   Reply With Quote
Old 01-15-2006, 09:22 PM   #11
dbarrett5381
Junior Member
dbarrett5381 is on a distinguished road
 
Join Date: Jan 2006
Posts: 15
Default Re: weird noises and other symptoms on 2000 sl2 98000 miles

oh and about the performance, the only thing that changed is now the tensioner doesn't make noise, but as far as everything else goes it didn't change anything.
dbarrett5381 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Transmission noises 68datster S-Series Tech 6 03-16-2008 06:09 PM
a/c trouble, 2000 sl2 with 78k miles tmelville S-Series Tech 22 06-11-2007 08:12 PM
weird noises 83trekker S-Series General 15 09-07-2005 07:14 PM
More odd noises from my 2000 SL2 Admiral Beez S-Series General 3 10-19-2004 10:15 PM
Weird idle symptoms RobB2 S-Series Tech 1 06-15-2004 11:10 AM


All times are GMT -4. The time now is 06:50 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.