SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 10-23-2004, 09:48 PM   #1
plum_sc2
Member
plum_sc2 is on a distinguished road
 
Join Date: Jul 2003
Location: Clifton Park, NY
Posts: 100

1993 SC2
2003 VUE 3.0L
Default cooling system refill problem.....

........drained the rad and block, about 6 qts came out.....did a flush with the prestone stull but didn't seem to take the 7 qt capacity....... and the high coolant temp ligh now flashes...........did a second flush and same results...................


my question is.........is there a trick to making sure the system is full?
...
1993 SC2 - 168,000 miles
2003 Vue - 104,000 miles
plum_sc2 is offline  
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cooling System Problem? kyasarin S-Series Tech 7 07-26-2009 09:14 AM
Cooling System jdw34 Vue Tech 2 07-23-2008 06:14 PM
Weird cooling system problem sc2095 S-Series Tech 11 07-29-2004 07:58 PM
Cooling System over pressure problem flyingw80 S-Series Tech 22 10-23-2003 11:36 AM
Cooling system problem looneyluden Miscellaneous Tech 6 10-25-2000 07:41 PM


All times are GMT -4. The time now is 05:22 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2023, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.