SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General

Reply
 
Thread Tools Display Modes
Old 05-27-2022, 03:14 PM   #1
mAxius
Junior Member
mAxius is on a distinguished road
 
Join Date: Jun 2012
Posts: 20
 
Default Im back <3 with a fun one

So upstream o2 sensor out car drives fine starts does what it is supposed to do.

Got new o2 sensor put in, connected it and car sputters and dies.

Idea's I am thinking it's the exhaust / catalyst had to go back to old faithful because the other 20-year-old car i have access to broke something on the right side and is thunking fw/reverse/ breaks on
mAxius is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 05-27-2022, 04:05 PM   #2
trottida
Master Member
trottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud of
 
trottida's Avatar
 
Join Date: Oct 2005
Location: North of North of Toronto, Northern Ontario, Canada
Posts: 3,025
 

1999 SL2
2001 SL1
Default Re: Im back <3 with a fun one

You have a GEN3 (2000-2002)? Your precat which is part of the exhaust manifold is plugged. You'll need to remove the manifold an rip out the core of the precat to regain flow. I've heard you can do it from the bottom too without removing the manifold from the engine.

...
1999 SL2 MT (299,400 km @ 11/2021)
2012 Ford Focus SEL HB MT
2011 Suburban LT

Past Saturns
2001 SL1 MT (438,500 km 11y)
1993 SW2 AT (10y)
2001 LW200 MT (3.5y)
1992 SL2 MT (5y)

:canada:
trottida is offline   Reply With Quote
Old 05-27-2022, 04:13 PM   #3
fetchitfido
Super Member
fetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant future
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 15,182
 

2001 SC2
Default Re: Im back <3 with a fun one

Not sure why you replaced the O2 sensor when the O2 sensor removal test told you the exhaust was restricted.

If the exhaust is in overall decent shape (or at least weldable) and you have a welder you can drill a couple holes in it to see where the restriction is, then weld the hole up when you're done. The pre-cat is the most likely culprit, but the main converter is likely and depending on how that's failed it could plug up the muffler as well.
fetchitfido is offline   Reply With Quote
Old 05-27-2022, 04:36 PM   #4
trottida
Master Member
trottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud of
 
trottida's Avatar
 
Join Date: Oct 2005
Location: North of North of Toronto, Northern Ontario, Canada
Posts: 3,025
 

1999 SL2
2001 SL1
Default Re: Im back <3 with a fun one

Here's what the inside looks like and what gets clogged up.

Perhaps your engine is running rich causing carbonization. Carbonization in the engine and exhaust is common in these cars when you have a failing thermostat, bad ETCS and/or fouled ETCS harness connector. For a GEN3 your temp gauge in the cluster should read around 1/3rd (see photo below). If it is around 1/4 then you likely have these issues. This would be the root cause of a clogged pre-cat. The PCM signal for coolant temperature reads cool so the engine management increases fuel to bring the engine to proper operating temperature (~193 F) which it never does because of the failed component(s). Extended running like this causes the black sooty carbon build up.



...
1999 SL2 MT (299,400 km @ 11/2021)
2012 Ford Focus SEL HB MT
2011 Suburban LT

Past Saturns
2001 SL1 MT (438,500 km 11y)
1993 SW2 AT (10y)
2001 LW200 MT (3.5y)
1992 SL2 MT (5y)

:canada:
trottida is offline   Reply With Quote
Old 05-27-2022, 05:06 PM   #5
mAxius
Junior Member
mAxius is on a distinguished road
 
Join Date: Jun 2012
Posts: 20
 
Default Re: Im back <3 with a fun one

Quote:
Originally Posted by trottida View Post
You have a GEN3 (2000-2002)? Your precat which is part of the exhaust manifold is plugged. You'll need to remove the manifold an rip out the core of the precat to regain flow. I've heard you can do it from the bottom too without removing the manifold from the engine.

i have one w/o the precat i think its the cat i dont think in over 295k it has ever been fully changed
mAxius is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
I'm Back! Here We Go Again! Dennyj1992 S-Series General 18 03-23-2015 02:57 PM
Help, My back seat will not go back up! calvarystand Astra General 9 03-04-2013 02:16 PM
test drove Vue RL and RAV4 back to back MJD1001 2008 Vue 4 08-13-2007 09:55 PM
Ion Buy-Back KevinF Ion General 5 10-20-2006 02:00 PM
Welcome Back ;-) NVMY03GT L-Series Tech 1 10-18-2006 10:26 PM


All times are GMT -4. The time now is 03:39 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.