SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 03-24-2008, 12:43 PM   #1
ekistler
New Member
ekistler is on a distinguished road
 
Join Date: Mar 2008
Posts: 7
Dizzy Saturn TAAT misery..... Please Help!!

I have a 97 SL2 with 50,000 miles on it and the automatic tranny failed. This was a catstrophic failure where the internal bearing race on the output shaft chewed it's way through the bellhousing and logged between the converter and the housing. Obviously, a lost cause.

I purchased a used 94 MP7 transmission from a parts clearing house in Illinois for the bargain price of $150 including free shipping to Pittsburgh, PA. It has 95,000 miles on it. For this price, I figured that it may have some hidden issues so, I ordered the ATSG manual and a full rebuild kit just to be safe. It was a good thing that I did open it up as, I found a broken caged needle bearing assembly on the input saft that I had to replaced. I also welded the differential pin while I was in there just to be safe. I replaced all of the clutch packs, filters and seals. I also completely rebuilt the valve body and cleaned all of the iron deposits left from the casting process.

After putting the tranny back in I am getting codes P0732 - Gear 2 Incorrect ratio , P0733 - Gear 3 Incorrect ratio , P0734 - Gear 4 Incorrect ratio and then the tranny goes into 2nd gear limp mode and I have to clear the codes with a scanner. I checked the line pressure per ATSG and received 67 psi at idle in park, 232 psi at idle in park with line pressure solenoid fuse removed and 245 psi at idle in drive. These are all well within the range specified. I put 60 miles on the tranny and it is still doing the same thing.

I don't notice anything unusual about the shifts. They seem firm, but not abrupt and I don't get any reverse slam. The car seems to downshift correctly and I haven't noticed any slipping from the gears. I replaced the valvebody with another rebuilt one just to be sure and it is the same. I do notice a slight warbling noise at moderate to heavy acceleration in 1st and 2nd gear. The pitch increases with engine speed.

Does anyone have any suggestions on what might be causing this? Anything would be a great help right now! Thanks for reading.
ekistler is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 03-24-2008, 02:12 PM   #2
tacinc1
Junior Member
tacinc1 is on a distinguished road
 
Join Date: Feb 2008
Posts: 21
Default Re: Saturn TAAT misery..... Please Help!!

From what I've read here, you may not have a compatable tranny for
the sl2. At min. the PCM isn't right for a mp7 tranny. Search this site
for more info.
tacinc1 is offline   Reply With Quote
Old 03-24-2008, 02:36 PM   #3
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,715
 

1996 SW2
Default Re: Saturn TAAT misery..... Please Help!!

No, the PCM is correct for the MP7 tranny. I was gonna say you're getting those codes because the gear ratios changed over the years. But looky here, they didn't. (Link courtesy of the "Low" Silva bros. and DifferentRacing.)

Are you sure the donor is an MP7? Did you see it marked on the case?
madpogue is offline   Reply With Quote
Old 03-24-2008, 02:36 PM   #4
ekistler
New Member
ekistler is on a distinguished road
 
Join Date: Mar 2008
Posts: 7
Default Re: Saturn TAAT misery..... Please Help!!

Thanks for the post. I verified the ratios on both this site and the ATSG manual and they are exact. I even went as far as to remove the tranny again and swap the gear clusters and input shaft from another 97 MP7 tranny as well as a rebuilt valvebody from another 97 MP7 tranny. I replaced the input shaft nut with a new one. This just has me stumped. I have looked at every post on this site related to the S-Series with the P0734 codes and I am going to recheck the electricals around the engine compartent again.

Does anybody have any other ideas on this one? Should I be concerned about the slight warbling noise under moderate to heavy acceleration? Honestly, I can't remember what it sounded like before. This may just be hamonics in the valvebody?
ekistler is offline   Reply With Quote
Old 03-24-2008, 02:39 PM   #5
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,715
 

1996 SW2
Default Re: Saturn TAAT misery..... Please Help!!

Water under the bridge, but before going thru all that, I probably would've opted for a 5-speed swap.....
madpogue is offline   Reply With Quote
Old 03-24-2008, 02:41 PM   #6
ekistler
New Member
ekistler is on a distinguished road
 
Join Date: Mar 2008
Posts: 7
Default Re: Saturn TAAT misery..... Please Help!!

Thanks MadPogue. I actually went as far with the second set of gears as to put them on a visual comparator with the original set to verify that the were indeed the same.
ekistler is offline   Reply With Quote
Old 03-24-2008, 02:42 PM   #7
ekistler
New Member
ekistler is on a distinguished road
 
Join Date: Mar 2008
Posts: 7
Default Re: Saturn TAAT misery..... Please Help!!

Wife's car...... Not an option for a 5-speed.
ekistler is offline   Reply With Quote
Old 03-24-2008, 05:09 PM   #8
Dr B
Senior Member
Dr B is on a distinguished road
 
Dr B's Avatar
 
Join Date: Mar 2005
Location: Alabama
Posts: 1,498

1992 SL2
1993 SL2
Default Re: Saturn TAAT misery..... Please Help!!

Turbine speed sensor ,sending bad data to pcm, maybe! ?
look on the front side near the spin on filter,check this sensor .
The pcm compares the signal from there /to V S S (in back) for gear ratio checks ,and to measure slipping of clutches ........
...
Have A Great Day , it is YOUR choice !
Dr B is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
rebuild mp7 transmission, Saturn TAAT transmission, Locks up in reverse, help mordo2 S-Series Tech 5 05-23-2016 09:28 AM
SATURN (TAAT) Valve body info on delay, slip/bang, or no reverse Glenn B S-Series Tech 2 02-18-2009 02:55 PM
looking for an exploaded view of a Saturn Taat transmission. mordo2 S-Series Tech 13 09-02-2006 12:48 AM
Saturn TAAT rebuilt type 2 valve body for sale rkuris Classifieds 1 08-09-2005 01:06 AM
Put her out of her misery? Nuke S-Series General 21 03-10-2005 04:37 PM


All times are GMT -4. The time now is 10:48 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.