SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Closed Thread
 
Thread Tools Display Modes
Old 05-18-2001, 02:38 PM   #1
Jon94SoLo2
Guest
 
Posts: n/a
Default Open exaust causing engine "miss"?????

I have a 94 SL2 and right now I have no muffler. I have a catalytic converter and a "cherry bomb" resonater in the stock location, but that's it (yes, I know, it's quite loud). When I rev the engine to 2000 rpms in neutral and hold it there, the engine misses consistently and rythmically. The air filter (K&N on SPS HotShot intake) is not clogged and I've recently changed my spark plugs, wires and PCM engine coolant temp sensor. The Throttle Body doesn't look dirty either. I've also recently changed my EGR valve.

I took it to the local Saturn dealership to have it diagnosed. They are telling me that they can't do an adequate test on the car because of the "custom" exaust. I had another dealership tell me a few months ago that my "custom" intake and exaust is causing the EGR and O2 sesnor to "act up".

I'm thinking, just change the O2 sensor and see what hapens, but I loathe "part changers". I'd rather have a complete test run to find the source of the problem and correct it.

What should I do?

Jon
 
SaturnFans.com Sponsored Links
Old 05-18-2001, 09:33 PM   #2
ssicarman
Super Member
ssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to behold
 
ssicarman's Avatar
 
Join Date: Oct 2000
Location: Western Canada
Posts: 10,467
 
Default Open exaust causing engine

Does the miss show up when you are driving the car or just in neutral when you rev it up? If only in neutral then don't worry about. 2000 RPM in neutral (not driving) is not a normal condition. Granted it should not do that but then you have modified the car and this certainly may cause the condition. If the miss is there driving then you need to keep looking for a problem.
Old joke but relevant here I think: Guy goes to the doctor and says "When I do this it hurts". Doctor says "Don't do that".
ssicarman is offline  
Old 05-19-2001, 10:39 PM   #3
Plastic Gravity
Guest
 
Posts: n/a
Default Open exaust causing engine

Isn't the no load rev-limiter different in Autos and manuals? I can see plenty of reasons for having it set low on an auto car in neutral...can anyone say neutral drops!!!!

Heheheheh. I have no idea if that's the probelm or not. When I opened up the exhaust and intake I incurred a "rear firing photon launcher" as one of my friends calls it. For about a month I had the cat off(no increase in anything besides noise, BTW) and between shifts a small blue'white flame would come out of the tail pipe, and then a POP sound...its not loud, not like a backfire...but a distinctive POP sound. After replaceing the cat, the flame departed, but not the occasional pop sound. The Air temp sensor is disconected...that may have something to do with it, I dunno.
 
Old 05-21-2001, 06:48 PM   #4
93KidCar
Junior Member
93KidCar is on a distinguished road
 
Join Date: Dec 2000
Posts: 47
Default Open exaust causing engine

Other than noise, what were you after by removing the CAT? Many many many magazine tests have shown that such mods do not do anything to help with power, since that is not the most restrictive part of the system these days. When cats first came out, that might not have been the case, but today, the systems are tested for thousands of hours and you're seeing the effects of messing with things. Besides, you're now dumping the combustion products into the atmosphere & that is just plain irresponsible.
93KidCar is offline  
Old 05-21-2001, 06:50 PM   #5
93KidCar
Junior Member
93KidCar is on a distinguished road
 
Join Date: Dec 2000
Posts: 47
Default Open exaust causing engine

Sorry, I misread what you had removed. I just couldn't believe that a Saturn owner would knowingly pollute.. I take that part back, but my comments about messing with the system stand.
93KidCar is offline  
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Drivers' door stuck as "open" - Help!!!! Naru S-Series General 4 12-23-2009 01:04 PM
Brake light on/off causing "click" in speakers PlasticCarsRock S-Series Tech 9 06-18-2009 02:25 PM
This causing my "squeaky" front end? JerryHughes S-Series General 73 04-18-2009 10:36 AM
Will unplugging O2 put "warm" obdII car in open loop?? tgferg67global S-Series Tech 1 06-24-2005 05:30 AM
"Trunk open" light keeps coming on sportster64 L-Series General 3 11-15-2004 07:08 PM


All times are GMT -4. The time now is 03:45 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.