SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 02-15-2021, 06:52 PM   #1
Ccrussell
Member
Ccrussell has a spectacular aura aboutCcrussell has a spectacular aura aboutCcrussell has a spectacular aura about
 
Join Date: Nov 2014
Location: Nys country
Posts: 261

1999 SL1
1999 SC2
Default Sl1 engine rebuild

Hello,
Just started my engine today after a rebuild.
Had the block honed, head serviced, everything checked and cleaned by machinist.Did the assembly myself with the factory shop manual, taking my time and triple checked everything as I progressed. Checked clearances, used torque wrench as required. Used assembly lube, packed the oil pump with Vaseline and pre-lubed as per Oldnuc procedure. When starting I had a flooding condition twice until I sorted that out corrected it and installed a fresh set of plugs .
Motor started ran about 1000 RPM then settle down into a nice idle I ran it this way for about 15 to 20 minutes.
Temperature gauge started to climb noticed I was not getting any coolant coming back around to the coolant tank via the small pipe from the far side of the engine.
Shut the car off decided to let it cool took the dog for a walk. Came back 90 minutes later double checked that I had installed the thermostat ,
started the car back up it started immediately. This time however it had a horrific sound as though something a tool for example had fallen down into the serpentine belt . shut it off immediately.
Investigated sound, found nothing mechanical happening, started it again the noise was still there. Shut it off immediately. Checked the oil which now smelled fuel diluted.
Shut it off within about 10 seconds dumped my oil which as I said smelled fuel diluted and looked a bit cloudy.
I have since pulled the oil filter and drained the oil.
Please advise have I damaged a bearing at this point? Right at this moment I am so disgusted I feel as though I need to throw in the towel what did I do?
Anyone please weigh in would be appreciated.
Ccrussell is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Rebuild? 64waves L-Series Tech 25 01-29-2013 07:09 AM
First Engine Rebuild JewFro297 S-Series Tech 16 07-04-2012 10:16 AM
Who wants to help me rebuild my engine? sps SOHC S-Series Tech 1 01-29-2005 04:17 PM
Seeking advice on engine rebuild (Subaru.. and rebuild done) Scyan Miscellaneous Tech 8 06-13-2003 09:38 AM
95 SL1 engine rebuild, need help Mark85 S-Series Tech 7 08-26-2002 09:11 AM


All times are GMT -4. The time now is 06:14 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.