SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Closed Thread
 
Thread Tools Display Modes
Old 10-25-2003, 05:26 PM   #1
brotherhay
Junior Member
brotherhay is on a distinguished road
 
Join Date: Oct 2003
Location: Wisconsin
Posts: 27
Dizzy instrument panel non functioning

I recently purchased a '93 SL2. It had some minor problems, and one that I cant figure out. The instrument panel is non-functional, and its not the fuses. The lights work that illuminate the panel, but the tach, speedometer, odo, trip, fuel and heat gauges dont work at all. Before i go drop a substantial amount at a dealer, maybe someone could give me pointer at how i could approach fixing it myself. I am electronically literate so i should be able to achieve the task if its not too involved. Please help me!!!!
brotherhay is offline  
SaturnFans.com Sponsored Links
Old 10-25-2003, 07:19 PM   #2
wolfman
Super Member
wolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of light
 
wolfman's Avatar
 
Join Date: Jun 2002
Location: Texas
Posts: 12,066
 
Default

Keep in mind the car has TWO fuses boxes. One under teh hood, and another behind a kick panel that just pops of the LEFT side of the passenger side front seat foot well. Provided you have checked BOTH fuse boxes, the main harness plug on the back of the instrument cluster may have come loose. (Although I can't imagine how) or the harness plug running from the PCM to the cluster may be loose/unplugged at the PCM (under the dash drivers side big shiney metal box) or the connector behind the trim panel (left side) in the DRIVER'S side foot well.
...
Old Saturns never die, people KILL them, so check your damn oil!
"Unthinking respect for authority is the greatest enemy of truth." Albert Einstein
wolfman is offline  
Old 10-25-2003, 09:19 PM   #3
Saturn-Eh!
Senior Member
Saturn-Eh! is on a distinguished road
 
Saturn-Eh!'s Avatar
 
Join Date: Jul 2003
Location: The Great White North
Posts: 1,715
 
Default

Do any of the warning lights at the bottom of the cluster work? If not, as above, I would suspect the connector at the back of the cluster (under the dashtop).
Saturn-Eh! is offline  
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Panel dogpile S-Series Tech 8 02-09-2007 09:39 AM
Who knows how to get the instrument panel out? ryanmcabee Vue General 2 12-19-2005 03:26 PM
Instrument Panel.. Help!! JoshM20 S-Series Tech 3 05-23-2005 04:30 AM
Instrument panel SaturnVue'03 Vue General 8 12-26-2003 11:22 PM
instrument panel non functioning brotherhay S-Series General 6 10-30-2003 03:02 AM


All times are GMT -4. The time now is 06:44 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.