SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General

Closed Thread
 
Thread Tools Display Modes
Old 10-25-2003, 04:59 PM   #1
brotherhay
Junior Member
brotherhay is on a distinguished road
 
Join Date: Oct 2003
Location: Wisconsin
Posts: 27
Dizzy instrument panel non functioning

I recently purchased a '93 SL2. It had some minor problems, and one that I cant figure out. The instrument panel is non-functional, and its not the fuses. The lights work that illuminate the panel, but the tach, speedometer, odo, trip, fuel and heat gauges dont work at all. Before i go drop a substantial amount at a dealer, maybe someone could give me pointer at how i could approach fixing it myself. I am electronically literate so i should be able to achieve the task if its not too involved. Please help me!!!!
brotherhay is offline  
SaturnFans.com Sponsored Links
Old 10-25-2003, 05:07 PM   #2
sloppyo
Junior Member
sloppyo is on a distinguished road
 
Join Date: Sep 2003
Posts: 48
Default

have you checked the intrument panel fluid lately???
sloppyo is offline  
Old 10-25-2003, 05:17 PM   #3
Dr. Bob
Master Member
Dr. Bob is on a distinguished road
 
Join Date: Mar 2000
Location: SE Minnesota
Posts: 2,041
Default

Quote:
have you checked the intrument panel fluid lately???
Snorted pop out my nose when I read that!!!

I'd say get a manual and test light, then troubleshoot the power and grounds to the gauge cluster to start. You do know that there is an underhood fuse panel and another in the console on the passenger side, right?
Dr. Bob is offline  
Old 10-25-2003, 06:58 PM   #4
GRIFF
Member
GRIFF is on a distinguished road
 
Join Date: Aug 2003
Location: new york
Posts: 143
 
Default

Brother ~ Looking at my haynes manual for 91-99 saturns,In the instrument cluster wiring diag. It appears they all use the same ground ( i/p splice pack ( gnd) where ever that is. I need more time to study this thing.

do your turn signals light up ~ They will use this same ground also. as do your illumination lights. but one quick thing I see is the power feed is different for the gauges vs the illum. lights

The books says the feed to the speed,odometer,tach fuel temp feed off ( IGN 1 FUSE ) not sure where that is yet ~ I need to eat dinner and will study and try to get back to you

Greg
GRIFF is offline  
Old 10-25-2003, 07:25 PM   #5
GRIFF
Member
GRIFF is on a distinguished road
 
Join Date: Aug 2003
Location: new york
Posts: 143
 
Default

Does your service engine soon light up when you first turn the key? And how about the seat belt light . They also use the (IGN 1 FUSE ) Wich even though the layout in the book looks different then I remember from looking at the fuse box yesterday .It should be a 10 amp fuse by the passanger side kick plate marked ( IGN1 ) I know you checked fuses but you may want to pull this one and double check with an ohm meter.

I read a post yesterday that someone used a cheap tester and didn't find the bad fuse.

If the fuse reads good, then pull the kick plate off the drivers side look all the way through to the back of the fuse box

http://www.saturnfans.com/photos/sho...t=12072&page=1


and see if anything is loose. Did anybody add any after market items to this car?? What minor problems did the car have before you bought it ?

The picture from the above link is out of my 95SL2 I'm not sure if yours will look the same

Greg
GRIFF is offline  
Old 10-25-2003, 07:52 PM   #6
GRIFF
Member
GRIFF is on a distinguished road
 
Join Date: Aug 2003
Location: new york
Posts: 143
 
Default

Well it looks like wolfman is over in ( tech talk ) answering your question . I didn't know you posted it there also . So print them both off and let us know how you made out.

Follow his instructions first ` He's been around
GRIFF is offline  
Old 10-30-2003, 03:02 AM   #7
XtremeGrandAm
Master Member
XtremeGrandAm is on a distinguished road
 
Join Date: Apr 2001
Posts: 2,670
 
Default

Quote:
Originally posted by sloppyo
have you checked the intrument panel fluid lately???
lol thats a good one
XtremeGrandAm is offline  
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Instrument Panel dogpile S-Series Tech 8 02-09-2007 09:39 AM
Who knows how to get the instrument panel out? ryanmcabee Vue General 2 12-19-2005 03:26 PM
Instrument Panel.. Help!! JoshM20 S-Series Tech 3 05-23-2005 04:30 AM
Instrument panel SaturnVue'03 Vue General 8 12-26-2003 11:22 PM
instrument panel non functioning brotherhay S-Series Tech 2 10-25-2003 09:19 PM


All times are GMT -4. The time now is 04:08 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.