SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Vue > 2008 Vue

Reply
 
Thread Tools Display Modes
Old 07-06-2021, 11:39 AM   #1
dedezgoin
New Member
dedezgoin is on a distinguished road
 
Join Date: Jul 2021
Posts: 1
Default stumped with evap system

Upon checking my free computer check at advanced a.parts, found:

p2270 -O2 sensor stuck lean B1 S2
p2271 -O2 sensor stuck rich B1 S2

PO45s -evap system leak detected (gross leak no flow)
PO13e -sensor delayed response Rich to lean (bank1 sen2)

if I replace both O2 sensors do you think that could resolve my computer issue?
dedezgoin is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-06-2021, 01:13 PM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,318
 

2003 L-Series 3.0L Sedan
Default Re: stumped with evap system

Before jumping onto the parts wagon, try another store like AutoZone if you didn't reset the error codes. It's better to have a second scan of the codes are correct. They won't go away unless something changed like scanning the first time on a cold engine. It's presumed the check engine light is on to tell you something's wrong?

And the latter two error codes - all error codes have a letter followed by for(4) numbers, not ending with 's'.
fdryer is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
EVAP system question FilthySL2 S-Series General 0 06-24-2013 01:48 PM
evap system not available? ddeuces22 S-Series Tech 3 04-18-2013 12:40 AM
Evap system part? Avitar408 S-Series Tech 4 11-25-2012 02:45 PM
evap emissions error code...stumped loworange88 S-Series General 3 01-09-2011 03:46 PM
Charging System Issue Got Me Stumped KevinVarnes S-Series Tech 21 11-16-2008 12:53 AM


All times are GMT -4. The time now is 01:15 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.