SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 08-11-2006, 09:15 PM   #1
slowroller
Junior Member
slowroller is on a distinguished road
 
Join Date: Jul 2006
Location: Springfield IL
Posts: 15

2008 Astra XR
2000 SL1
Dizzy replaced Valve body but now what could be wrong?

I replaced the valve body and now I do have some reverse but only at about 3 K and it sounds feels like a clutch is slipping or something. Firstly this is better than having no reverse as I was dealing with but what could be the problem now. Is this valve body bad? Could it just need some time to relearn reverse? Is the clutch done for and now needing to be replaced? Any ideas or insight would be very helpful as I need this car to be working well again very soon. Thanks again guys, Dave.
slowroller is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-12-2006, 08:13 AM   #2
97coupe
Master Member
97coupe is on a distinguished road
 
Join Date: Jun 2006
Posts: 2,260

1997 SC2
Default Re: replaced Valve body but now what could be wrong?

Quote:
Originally Posted by slowroller
I replaced the valve body and now I do have some reverse but only at about 3 K and it sounds feels like a clutch is slipping or something. Firstly this is better than having no reverse as I was dealing with but what could be the problem now. Is this valve body bad? Could it just need some time to relearn reverse? Is the clutch done for and now needing to be replaced? Any ideas or insight would be very helpful as I need this car to be working well again very soon. Thanks again guys, Dave.

You have a big leak in the reverse pressure circuit. This is why it works some when you rev it up and then feels like it is slipping. THe leak is either in the valve body or the clutch pack itself and I tend to think it is the clutch pak here.
97coupe is offline   Reply With Quote
Old 08-13-2006, 07:04 PM   #3
slowroller
Junior Member
slowroller is on a distinguished road
 
Join Date: Jul 2006
Location: Springfield IL
Posts: 15

2008 Astra XR
2000 SL1
Default Re: replaced Valve body but now what could be wrong?

So Im wondering if the Input shaft nut is loose? Also now the reverse is gone again after driving the car for a couple of miles and again no 2nd gear. This is a different valve body, but could it be bad as well. I have valve body in hand now to possible rebuild but Im gonna go look for possible blown fuses, and maybe try swapping some of the actuators. I am just losing my mind trying to figue this out. I appreciate any ideas. Thanks again everyone, Dave.
slowroller is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Replaced Valve Body, now it won't start..? GStaz S-Series Tech 4 09-19-2009 04:32 PM
Replaced valve body, now having shifting problems richsaav S-Series Tech 18 12-08-2008 08:17 PM
Replaced Valve Body now getting Transaxe codes richsaav S-Series Tech 8 11-10-2008 08:00 PM
Replaced valve body and now won't shift at all opal S-Series Tech 9 04-09-2008 08:04 AM
Valve Body replaced...BUT here is something I learned jgcox6 S-Series General 0 04-10-2007 10:33 AM


All times are GMT -4. The time now is 08:27 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.