SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General

Reply
 
Thread Tools Display Modes
Old 09-23-2021, 09:42 AM   #1
lanxer57
Member
lanxer57 is on a distinguished road
 
Join Date: Oct 2020
Location: aurora, colorado, u.s.a
Posts: 115

1999 SC1
2001 SC1
Wrench just replaced the valve body, new problems arose

I replaced the valve body in my 1999 sc1 with one from my 2001 that I know was working a few months ago. It is now going forward in all gears except park. It also started making an alarming noise https://youtu.be/vp1_6WBBx2Y immediately after starting, I then panic and switch it off. This noise developed when I double checked to see if the spark plug wires were in the correct order.
If I need to swap the engine or trans, I need to know before 7 days, the city is coming for both non-running cars.
...
1997 V6 Mustang coupe 2018-2019(wrecked, airbags went off)
2001 SC1 2020-2021(wrecked, frame was bent)
1999 SC1 2021-now(working progress)
lanxer57 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-23-2021, 09:59 AM   #2
bumpdraft
Master Member
bumpdraft is just really nicebumpdraft is just really nicebumpdraft is just really nicebumpdraft is just really nice
 
bumpdraft's Avatar
 
Join Date: Apr 2006
Location: A full day’s drive from St. Louis
Posts: 4,222
 

1998 SC2
1998 SW2
Default Re: just replaced the valve body, new problems arose

To pinpoint the source of the noise, have a helper start the car while you listen.
Back in 2011, I replaced the valve body and the input shaft nut on a relative’s SL, but I'm no expert.
Is there anything that makes having the thickness of the installed gasket a critical dimension?
Also, there is a tool for holding the clutch: https://www.ebay.com/itm/Saturn-S-Se...-127632-2357-0
I think I wedged soft lead in the gears.
bumpdraft is offline   Reply With Quote
Old 09-23-2021, 07:15 PM   #3
lanxer57
Member
lanxer57 is on a distinguished road
 
Join Date: Oct 2020
Location: aurora, colorado, u.s.a
Posts: 115

1999 SC1
2001 SC1
Default Re: just replaced the valve body, new problems arose

It is coming from the back of the engine, by the transmission. mom let it run longer than I did, and I noticed that it got quieter as the RPM dropped. I believe it is either the transmission being low on fluid and not working right, or the starter solenoid staying in contact with the flywheel.
...
1997 V6 Mustang coupe 2018-2019(wrecked, airbags went off)
2001 SC1 2020-2021(wrecked, frame was bent)
1999 SC1 2021-now(working progress)
lanxer57 is offline   Reply With Quote
Old 09-23-2021, 10:42 PM   #4
lanxer57
Member
lanxer57 is on a distinguished road
 
Join Date: Oct 2020
Location: aurora, colorado, u.s.a
Posts: 115

1999 SC1
2001 SC1
Default Re: just replaced the valve body, new problems arose

I think the reason it was making that noise was because of how I was pushing it back into the garage. I could not push it in neutral, because neutral, like all other gears accept park is indistinguishable from drive idling 2 inches forward in the garage. the noise stopped as soon as I shifted out of park. I also filled the transmission up to the "OK" mark on the dipstick. The code P0301 is still there, and it still moves forward in all gears except park.
...
1997 V6 Mustang coupe 2018-2019(wrecked, airbags went off)
2001 SC1 2020-2021(wrecked, frame was bent)
1999 SC1 2021-now(working progress)
lanxer57 is offline   Reply With Quote
Old 09-24-2021, 08:09 PM   #5
lanxer57
Member
lanxer57 is on a distinguished road
 
Join Date: Oct 2020
Location: aurora, colorado, u.s.a
Posts: 115

1999 SC1
2001 SC1
Default Re: just replaced the valve body, new problems arose

A forum dad is using thinks it is a computer issue. can the computer tell the difference between the 2 valve bodies? It is not the shift cable, because park works normally. The only thing I could think of is that I installed the valve body incorrectly. This thread mentioned at some point that the same problem may have been solved by topping off the fluid, but the diver did not know until after driving it. http://www.saturnfans.com/forums/sho...d.php?t=185879 I would rather not drive it until I know that reverse will work, because if it does not, than it will get trapped in the garage that I also need to use to work on another car this weekend.
...
1997 V6 Mustang coupe 2018-2019(wrecked, airbags went off)
2001 SC1 2020-2021(wrecked, frame was bent)
1999 SC1 2021-now(working progress)
lanxer57 is offline   Reply With Quote
Old 09-25-2021, 02:54 AM   #6
lanxer57
Member
lanxer57 is on a distinguished road
 
Join Date: Oct 2020
Location: aurora, colorado, u.s.a
Posts: 115

1999 SC1
2001 SC1
Default Re: just replaced the valve body, new problems arose

I urgently need it out of the garage by saturday, so I need fast answers.

Does it need to "relearn" how to shift before reverse works?

Did I install the valve body wrong?

Or...

Has it somehow been rejected by the computor?

If I get no answers, I will remove and install the valve body just to be safe.
...
1997 V6 Mustang coupe 2018-2019(wrecked, airbags went off)
2001 SC1 2020-2021(wrecked, frame was bent)
1999 SC1 2021-now(working progress)
lanxer57 is offline   Reply With Quote
Old 09-25-2021, 10:05 AM   #7
bumpdraft
Master Member
bumpdraft is just really nicebumpdraft is just really nicebumpdraft is just really nicebumpdraft is just really nice
 
bumpdraft's Avatar
 
Join Date: Apr 2006
Location: A full day’s drive from St. Louis
Posts: 4,222
 

1998 SC2
1998 SW2
Default Re: just replaced the valve body, new problems arose

I know next-to-nothing about Saturn automatic transmissions...
The relearn shouldn’t have anything too with reverse gear going forward.
There could be Diagnostic Trouble Codes that would help to see how the computer sees the new valve body.
Careful with the torque of the bolts holding the valve body. I understand it is critical. Is there supposed to be a gasket?
bumpdraft is offline   Reply With Quote
Old 09-25-2021, 10:21 AM   #8
fetchitfido
Super Member
fetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant futurefetchitfido has a brilliant future
 
fetchitfido's Avatar
 
Join Date: May 2006
Posts: 14,987
 

2001 SC2
Default Re: just replaced the valve body, new problems arose

There is a relearn process for shifting but each "gear" should work. The relearn process just reduces the "slam" into each gear, has nothing to do with where the gears are.

It's possible the shift selector got knocked out of alignment, but I'd expect odd gear locations on the shift lever rather than "everything is drive except park."

If the VB were rejected you wouldn't even have "D". Something went wrong with the VB reinstall and that was made worse by running it low on fluid.
...
The proper way to fix a S-Series automatic is to replace it with a 5spd O:)
fetchitfido is offline   Reply With Quote
Old 09-25-2021, 05:07 PM   #9
lanxer57
Member
lanxer57 is on a distinguished road
 
Join Date: Oct 2020
Location: aurora, colorado, u.s.a
Posts: 115

1999 SC1
2001 SC1
Default Re: just replaced the valve body, new problems arose

WHOOPS! I forgot to connect the manual valve link... I think that may have been making the loud noise earlier, it got bent, and the end of it got chewed up. I have another link in the other transmission, but I need to remove a nut to get it off. I will now try to find the torque specs for that.
...
1997 V6 Mustang coupe 2018-2019(wrecked, airbags went off)
2001 SC1 2020-2021(wrecked, frame was bent)
1999 SC1 2021-now(working progress)
lanxer57 is offline   Reply With Quote
Old 09-25-2021, 09:34 PM   #10
macbox
Senior Member
macbox will become famous soon enough
 
macbox's Avatar
 
Join Date: Jul 2006
Location: Minneapolis, MN
Posts: 1,219
 

1995 SC2
1995 SC2
Default Re: just replaced the valve body, new problems arose

That's what I was going to ask. There is a steel L shaped prong in the transmission, and the end of that has to go into the little piston thing on the bottom of the valve body, otherwise it will clang on the gears. It's easy to miss this the first time you have one of these apart.

Quote:
Originally Posted by lanxer57 View Post
WHOOPS! I forgot to connect the manual valve link... I think that may have been making the loud noise earlier, it got bent, and the end of it got chewed up. I have another link in the other transmission, but I need to remove a nut to get it off. I will now try to find the torque specs for that.
...
#4, "Betty" 1995 SC2m, 167K, rebuilt engine, Garage Queen. Still squeaks and rattles but goes like hell.
macbox is offline   Reply With Quote
Old 09-25-2021, 09:54 PM   #11
lanxer57
Member
lanxer57 is on a distinguished road
 
Join Date: Oct 2020
Location: aurora, colorado, u.s.a
Posts: 115

1999 SC1
2001 SC1
Default Re: just replaced the valve body, new problems arose

the one originally in that transmission was bent, the edge of it all chewed-up. luckily, I just happened to have another one in the wrecked 2001. put it back together, stuck it in reverse, and it went backwards. It rolled forward slowly in neutral, but it moved faster in drive, so I think our garage may not be perfectly level. still need to test drive it, we only had time to go about 20 feet to the street, and 20 feet to its spot on the driveway.
...
1997 V6 Mustang coupe 2018-2019(wrecked, airbags went off)
2001 SC1 2020-2021(wrecked, frame was bent)
1999 SC1 2021-now(working progress)
lanxer57 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
replaced valve body. Tuberforlife S-Series Tech 2 07-31-2018 09:39 PM
replaced valve body still has same issues saturnmommy S-Series Tech 62 06-18-2016 03:08 PM
Just replaced transmission, needs valve body now? Disaffinity S-Series Tech 22 05-31-2016 02:10 PM
Replaced valve body, now having shifting problems richsaav S-Series Tech 18 12-08-2008 08:17 PM
replaced Valve body but now what could be wrong? slowroller S-Series Tech 2 08-13-2006 07:04 PM


All times are GMT -4. The time now is 08:20 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.