SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech

Reply
 
Thread Tools Display Modes
Old 08-02-2015, 12:43 AM   #1
Jonw943
New Member
Jonw943 is on a distinguished road
 
Join Date: Aug 2015
Posts: 1
Default None of my brake lights are working on my 03 lw300

My 3rd brake light hasn't been working for awhile today I noticed that none of the brake lights are working. I just replaced a bulb 2 weeks ago I went to check to see if it was a blown fuse but I didn't see a fuse labled for the breaks I it didn't look like any of the fuses were blown so I don't know what to do now any help would be greatly appreciated.
Jonw943 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-02-2015, 08:44 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 45,558
 

2003 L-Series 3.0L Sedan
Default Re: None of my brake lights are working on my 03 lw300

Blade fuses never show when an element burns out. A proper fuse inspection requires pulling every fuse to inspect each one. The 'S' element is either visible or missing (blown). Never assume any blade fuse is good unless you're willing to pull them. The engine fuse panel has a plastic fuse puller to help. In addition to this, two more fuse panels are located inside the car, one in each foot well. All panel covers are embossed with labeling to identify what fuse powers a circuit.
fdryer is offline   Reply With Quote
Old 08-02-2015, 12:00 PM   #3
rb6667
Advanced Member
rb6667 is a splendid one to beholdrb6667 is a splendid one to beholdrb6667 is a splendid one to beholdrb6667 is a splendid one to beholdrb6667 is a splendid one to beholdrb6667 is a splendid one to beholdrb6667 is a splendid one to behold
 
rb6667's Avatar
 
Join Date: Feb 2014
Location: USA
Posts: 767
 

2004 L-Series 2.2L Wagon
2004 L-Series 3.0L Wagon
Default Re: None of my brake lights are working on my 03 lw300

Yes, Carefully Check all the fuses. If they all are good. The other possibility is that your car did not have the tail light replaced during a recall that was issued for the wagon tail lights.

I believe it was just one of the tail lights that were replaced @ N/C. Can't remember which one. The story was that light over heated and then shorted out the other one.

Call you local Chevy dealer and give them your VIN #. They should be able to tell you if that offending tail light was replaced during the recall campaign.

Let us know what you find.
rb6667 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
help please- brake lights not working jcono Vue Tech 12 06-13-2018 04:08 AM
Help 2006 vue 6 cycl awd. Brake lights not working Obrientech Vue Tech 2 08-20-2012 07:01 PM
Brake lights arnt working????? jcurrieirocz S-Series General 9 03-15-2005 12:17 AM
Brake lights working intermittently silverblueL200 L-Series Tech 6 11-26-2004 12:08 PM


All times are GMT -4. The time now is 04:26 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.