SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 01-31-2019, 01:03 AM   #1
Silverblu02SL2
Member
Silverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the rough
 
Join Date: Jan 2019
Location: NYC
Posts: 394

2002 SL2
Default pending fault code P0410?

I am using Torque Lite with a Bluetooth OBD II adapter. My 2002 SL2 had a P0341 code. I cleaned the coil packs, ignition control module, ignition wires, installed new spark plugs, then cleared the code with Torque Lite. I also changed oil & filter 5W30 full synthetic.

After the above work was done yesterday, I started the engine to make sure it starts but did not drive it, P0341 has not returned since cleared, but Torque Lite says there's a pending fault code P0410. I selected it and it's a "Secondary injection system"

Today, I took the car for a short drive to warm up the transmission to change fluid and filter. Approx 2 miles into the 12 mile drive, the SES light came on, P0410 is a logged code rather than pending.

I found this nice video https://www.youtube.com/watch?v=dIrmkxj6wJE by richpin on troubleshooting P0410 so I will be doing that.

Could any of the work I've done trigger P0410? Did I knock some wires or hoses loose?
Silverblu02SL2 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 02-01-2019, 09:43 PM   #2
Silverblu02SL2
Member
Silverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the rough
 
Join Date: Jan 2019
Location: NYC
Posts: 394

2002 SL2
Default Re: pending fault code P0410?

Found this post http://www.saturnfans.com/forums/sho...d.php?t=232557 which has a thorough description of the secondary air injection system by Claybury.

This evening, I found no voltage at the secondary air pump connector. Will check air pump fuse and relay tomorrow.
Silverblu02SL2 is offline   Reply With Quote
Old 02-01-2019, 11:14 PM   #3
Silverblu02SL2
Member
Silverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the rough
 
Join Date: Jan 2019
Location: NYC
Posts: 394

2002 SL2
Default Re: pending fault code P0410?

Found this post http://www.saturnfans.com/forums/sho...d.php?t=232567 with a wiring diagram of the air injection system which will help. Thanks fdryer!
Silverblu02SL2 is offline   Reply With Quote
Old 02-02-2019, 05:49 PM   #4
Silverblu02SL2
Member
Silverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the roughSilverblu02SL2 is a jewel in the rough
 
Join Date: Jan 2019
Location: NYC
Posts: 394

2002 SL2
Default Re: pending fault code P0410?

I printed out the air pump wiring diagram verified fuse and air pump relay is good. I labeled the relay pin numbers on the diagram . By jumping pins 87 to 30, the pump runs. Not knowing when or how long the pump should run, I soldered a light bulb to 2 needles and shoved it in the air pump connector. Started the engine, the light did not come on while cranking but came on a few seconds after a cold engine (coolant at 32F).

The bulb (air pump) only stayed on for about 10 seconds though. I was able to capture a pic of the lit bulb before it went out.

P0410 code was cleared when I had the battery disconnected to clean its terminals yesterday. I took the car to Autozone for a battery load test and P0410 code has not come back so far.

10 seconds? Shouldn't the air pump run longer than that? What else should I be checking? O2 sensor under the car? My IAT and ECTS sensors seems to be fine per Torque Pro.



Attached Images
File Type: jpg 20190202_155405-612x816.jpg (72.3 KB, 11 views)
File Type: jpg 20190202_143123-1.jpg (135.8 KB, 11 views)
...
1/28/2019 2002 SL2 w 62k miles

Last edited by Silverblu02SL2; 02-02-2019 at 05:54 PM.
Silverblu02SL2 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Code P0446 is pending but emission readiness was all complete (green) vikasevan S-Series Tech 7 12-02-2018 04:31 PM
P0410 code, changed ECTS, code back mattwithcats S-Series Tech 1 06-24-2011 07:40 PM
Pending Code PO404 any suggestions gmman1978 S-Series Tech 21 05-14-2011 12:51 PM
02 Sensor Readings + Pending Code fmctaurus S-Series General 4 12-23-2010 06:29 PM
ABS fault code 57 sPuddingTime S-Series Tech 2 12-15-2006 12:50 PM


All times are GMT -4. The time now is 07:28 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.