SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General

Reply
 
Thread Tools Display Modes
Old 01-14-2015, 06:29 PM   #1
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default I'm Back! Here We Go Again!

...and this time with an SC2, instead of a SOHC, for a change. I didn't actually think to pull the picture up from Craigslist, (the guy I bought it from) since I don't have any pictures yet, but here she is:

http://lansing.craigslist.org/cto/4815097221.html

Fully loaded, power locks, windows, air conditioning (haven't checked to see if it works yet or not), sunroof, remote start, aftermarket radio...you name it!

Ended up driving down and picking it up for only $1,400. Had to drive her through a snow storm though, because Michigan weather, right? Lol.

Took about 3 hours roughly to get the car home. The wife followed in the ol' SL1. It was on a donut tire when I picked it up, so the drive through snow wasn't too easy. Easier than I thought, but none the less. 45 mph the whole way home, until about the last half an hour (snow cleared up the more north we got). The car just got titled and plated on Monday, and yesterday it got a new flex pipe (was loud from under the engine block when I picked it up) and 4 fresh new Ohtsu's to ride on. Straight and smooth on the highway now! It does need a front end alignment though...still just a hair off. All records and receipts were kept for the car since 2009. Bonus! The car was well maintained!

The car has a few small scratches and rust spots on the hood, but no dents, no dings, and no messed up door jambs/hinges. They are a little rusty though. Nothing a can of Liquid Wrench can't clean up!

Anything else I'm forgetting? Oh yah, the service engine soon light was on, so I had it reset after the exhaust work to see what came back up. I'll know by tomorrow afternoon and I'll keep everyone updated!

I've got to wash and clean the car out still, but it's been a nasty -5F here where I live in MI. More pictures to come when it warms up!
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 01-14-2015, 06:36 PM   #2
MikeNW
Master Member
MikeNW is a glorious beacon of lightMikeNW is a glorious beacon of lightMikeNW is a glorious beacon of lightMikeNW is a glorious beacon of lightMikeNW is a glorious beacon of light
 
MikeNW's Avatar
 
Join Date: Apr 2008
Location: Lower Alabama= God's country, if God wanted mosquito and red ant bites, and to be covered in mildew
Posts: 3,451
 

1997 SL
Default Re: I'm Back! Here We Go Again!

Congrats! I love this website Hope you have many carefree years with your new Saturn.
When I bought mine (new) in 97, the sales mgr. said "I hope you have many happy years" Little did he know- 17.5 years later and still purrs along
...
97 SL. Bought 7/07, reluctantly sold Dec 2019
Burgman 400- indestructible beast
Sportster 883- fun bike
Cannondale 29er- daily driver
MikeNW is offline   Reply With Quote
Old 01-14-2015, 11:53 PM   #3
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default Re: I'm Back! Here We Go Again!

Quote:
Originally Posted by MikeNW View Post
Congrats! I love this website Hope you have many carefree years with your new Saturn.
When I bought mine (new) in 97, the sales mgr. said "I hope you have many happy years" Little did he know- 17.5 years later and still purrs along
Wow, 17 years?!? Very nice! I'm hoping to just get my money's worth at minimum out of it. That's was I always shoot for.

I figure it kind of breaks down like this. Average brand new car MSRP is $20,000. You can expect with the right amount of car and maintenance that a (not a lemon) car would get 200,000 miles or more. Therefore, in that very simple, yet extended math, that every $100 is 1,000 miles in comparison with your car.

So I bought the car for $1,4000. New tires were $281 out the door. Exhaust work was like $82. Tune up should be like $50...so anyways. If I can get away with about $2,000 into her total, I would love to see 20,000 trouble free miles out of it (aside from oil changes and air filter of course).

I'm guessing you feel as if your Saturn has most definitely payed you back?
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Old 01-15-2015, 12:12 AM   #4
Saturninin
Senior Member
Saturninin will become famous soon enough
 
Saturninin's Avatar
 
Join Date: Jun 2009
Location: NW (The region), In
Posts: 1,810
 

2005 VUE 3.5L
1994 SL2
Default Re: I'm Back! Here We Go Again!

Quote:
Originally Posted by Dennyj1992 View Post
Wow, 17 years?!? Very nice! I'm hoping to just get my money's worth at minimum out of it. That's was I always shoot for.

I figure it kind of breaks down like this. Average brand new car MSRP is $20,000. You can expect with the right amount of car and maintenance that a (not a lemon) car would get 200,000 miles or more. Therefore, in that very simple, yet extended math, that every $100 is 1,000 miles in comparison with your car.

So I bought the car for $1,4000. New tires were $281 out the door. Exhaust work was like $82. Tune up should be like $50...so anyways. If I can get away with about $2,000 into her total, I would love to see 20,000 trouble free miles out of it (aside from oil changes and air filter of course).

I'm guessing you feel as if your Saturn has most definitely payed you back?
saturn's have definitely paid us back lol.... dad's right now has like 420....., bought her with like 20k on her...


Quote:
Originally Posted by Dennyj1992 View Post
...and this time with an SC2, instead of a SOHC, for a change. I didn't actually think to pull the picture up from Craigslist, (the guy I bought it from) since I don't have any pictures yet, but here she is:

http://lansing.craigslist.org/cto/4815097221.html

Fully loaded, power locks, windows, air conditioning (haven't checked to see if it works yet or not), sunroof, remote start, aftermarket radio...you name it!

Ended up driving down and picking it up for only $1,400. Had to drive her through a snow storm though, because Michigan weather, right? Lol.

Took about 3 hours roughly to get the car home. The wife followed in the ol' SL1. It was on a donut tire when I picked it up, so the drive through snow wasn't too easy. Easier than I thought, but none the less. 45 mph the whole way home, until about the last half an hour (snow cleared up the more north we got). The car just got titled and plated on Monday, and yesterday it got a new flex pipe (was loud from under the engine block when I picked it up) and 4 fresh new Ohtsu's to ride on. Straight and smooth on the highway now! It does need a front end alignment though...still just a hair off. All records and receipts were kept for the car since 2009. Bonus! The car was well maintained!

The car has a few small scratches and rust spots on the hood, but no dents, no dings, and no messed up door jambs/hinges. They are a little rusty though. Nothing a can of Liquid Wrench can't clean up!
Did you know about it only having 3 tires...... cause IMO making the 3 hr drive on a temp in the snow is not best idea..... If you knew ahead of time... I would of went out to the JY and pulled a decent looking 15 and ran with that... (but can figure like $20-$25 in most yards for a steel rim/tire & that way you have a full size spare) or if you got to lansing and found it out... there's
http://www.u-pullandsave.com/Price_List.cfm#37

(this is exactly what I did to bring home my parts 02 SC2 (the owner wanted to keep the rims on the car) so I picked up 2 tires from the JY for the rear tires and tossed 2 temp tires on the front (used a car dolly to bring it home)
...
Wanted: Dealer items (frames/ key-chains)

Miles(k) 2013~15
94 HCE ~180
05 Vue 3.5 87~140
98 SL1 260~426
08 Outlook XE 20~160
95 SC2 ~128

Past
96 SW2, 98 SL2
160k+ 95 SL,98 SW2, 03 Vue-I4
Saturninin is offline   Reply With Quote
Old 01-15-2015, 01:42 PM   #5
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 13,320
 

2002 SC2
1998 SL2
Default Re: I'm Back! Here We Go Again!

Congrats, nice looking vehicle.

Avoid I-94 in the winter, should be OK

Way I figured it, I got my money's worth, since I paid $800 for my car and saved $200 a year in gas, over my previous car, for each of the past 5 years.

Put 70,000 miles on the car, so I got my money's worth by your calculation, too
...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 151k DD
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles
alordofchaos is offline   Reply With Quote
Old 01-15-2015, 06:45 PM   #6
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default Re: I'm Back! Here We Go Again!

Quote:
saturn's have definitely paid us back lol.... dad's right now has like 420....., bought her with like 20k on her...

Did you know about it only having 3 tires......

Wow, 420,000 miles!? Looks like I have plenty to go on mine, lol. Pure American build, with pure import reliability. Gotta love it, lmao.

Yah, I knew it was on a spare. The guy I bought it from explained to me that the tire had blown out on the front driver's side before I even came out to look at the car. No, it was already almost 9pm by the time I picked up the car. We got the car home around midnight, safe and sound.

Quick update here: After fixing the exhaust and deleting the codes, it looks like only 1 code came back up. EGR insufficient flow. I just picked up an air filter, plugs, wires, an EGR valve gasket, and some carb and choke cleaner from the auto store.

I'm gonna tune it up and clean out the EGR as soon as it warms up (this weekend it's supposed to here in Bay City). Hoping for the best!
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Old 01-15-2015, 09:14 PM   #7
trottida
Master Member
trottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud oftrottida has much to be proud of
 
trottida's Avatar
 
Join Date: Oct 2005
Location: North of North of Toronto, Northern Ontario, Canada
Posts: 2,993
 

1999 SL2
2001 SL1
Default Re: I'm Back! Here We Go Again!

It's likely the craiglist ad will be pulled so for future reference here is the picture from the ad.....
Attached Images
File Type: jpg 01717_cjsI3Z6I9ay_600x450.jpg (33.1 KB, 38 views)
...
1999 SL2 MT (299,400 km @ 11/2021)
2012 Ford Focus SEL HB MT
2011 Suburban LT

Past Saturns
2001 SL1 MT (438,500 km 11y)
1993 SW2 AT (10y)
2001 LW200 MT (3.5y)
1992 SL2 MT (5y)

:canada:
trottida is offline   Reply With Quote
Old 01-16-2015, 04:59 PM   #8
alordofchaos
Super Member
alordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud ofalordofchaos has much to be proud of
 
alordofchaos's Avatar
 
Join Date: Jan 2009
Location: Central MI
Posts: 13,320
 

2002 SC2
1998 SL2
Default Re: I'm Back! Here We Go Again!

^ ^ ^ good move. I copied the whole ebay ad for my car, for posterity.
...
I'm not worthy to grovel in the shadow of Signmaster's wisdom

11/2016 red 2002 5 spd SC2 151k DD
12/2008 eBay silver 1998 SL2 5 spd 102k, now 201k+ miles
alordofchaos is offline   Reply With Quote
Old 01-19-2015, 12:48 AM   #9
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default Re: I'm Back! Here We Go Again!

Quote:
Originally Posted by trottida View Post
It's likely the craiglist ad will be pulled so for future reference here is the picture from the ad.....
Thank You!
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Old 01-19-2015, 09:19 PM   #10
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Wrench Re: I'm Back! Here We Go Again!

So while I've been busy the last few days, and haven't had time to snap some pictures of the new (to me) SC2, I'll post up just a few smaller issues I've noticed with the car.

First one: The car makes a high pitched (but somewhat quiet) whistling sound on the highway. I checked the wipers, headlight assemblies, if that's a possible issue, and sunroof. No go on any of them. Any suggestions?

Second problem: I just tuned up the car this past weekend. New air filter, plugs, (it had Bosch Plat's. in it, and I swapped them out to NGK-R copper's) wires, EGR Valve cleaning, PVC Valve, Seafoamed through the gas tank, crank, and intake, and I ended up just cleaning up the whole engine bay with some carb and choke and a rag...tried to stay away from the paint and metal, haha. Anyhow, the issue I noticed is that after doing all of this, the car ran fine for a while, but the underlying "stutter" issue I noticed when driving the car home the first night came back.

So here is the sum of what's going on with it... The car has a fairly nasty stutter under light load, (when warmed up) generally at the bottom of 4th gear. WOT and lighter acceleration usually doesn't give me a problem. When pulling the spark plugs, 1,3 and 4 (from left to right facing the front) had oil on them. Looking down into the spark plug wells, I noticed quite a fair amount of oil pooling in them. Valve cover gaskets? Could my spark plugs be fouling out bad enough from the oil, that they are causing a pretty obvious stutter?

Third issue. I've had two different mechanics now check the front end. Both have told me that it's fine, but one shop "claimed" that one of my ball joints had some play in it. Didn't tell me which side, nor which one, but I'm assuming that the SC1/2 ride on just one control arm with a ball joint attached, and it's not a dual ball joint system, correct?

So getting on the highway is actually pretty nice, but there is a small (and I emphasize small) shaking in the steering wheel, mostly felt above 70 MPH. The alignment is slightly off too. The car will pull gently to the left, and you have to hold the wheel just a hair to the right to keep the car straight. What's going on with it?

Fourth and final issue. This one is actually weird, but simple to describe. I start the car (the noise is much louder when the car's operating temperature is cold) and give it gas in park. As the RPM's come down and the car gentles it's idle, I hear a "rushing water" type of sound from almost under the hood. Not exactly sure where it's from. That's the only part of this that I feel is hard to describe, lol. Almost like water trickling somewhere...?

Sorry, I know it's a long read. I just figured I would get all the last little issues tackled down while I'm busy cleaning her up and getting pictures to post up here. They will be up soon!
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Old 01-20-2015, 06:32 AM   #11
Pitcher
Master Member
Pitcher has a spectacular aura aboutPitcher has a spectacular aura aboutPitcher has a spectacular aura about
 
Pitcher's Avatar
 
Join Date: Apr 2008
Location: USA
Posts: 2,745

1998 SC2
Default Re: I'm Back! Here We Go Again!

Quote:
Originally Posted by Dennyj1992 View Post

First one: The car makes a high pitched (but somewhat quiet) whistling sound on the highway. I checked the wipers, headlight assemblies, if that's a possible issue, and sunroof. No go on any of them. Any suggestions?

Second problem: I just tuned up the car this past weekend. New air filter, plugs, (it had Bosch Plat's. in it, and I swapped them out to NGK-R copper's) wires, EGR Valve cleaning, PVC Valve, Seafoamed through the gas tank, crank, and intake, and I ended up just cleaning up the whole engine bay with some carb and choke and a rag...tried to stay away from the paint and metal, haha. Anyhow, the issue I noticed is that after doing all of this, the car ran fine for a while, but the underlying "stutter" issue I noticed when driving the car home the first night came back.

So here is the sum of what's going on with it... The car has a fairly nasty stutter under light load, (when warmed up) generally at the bottom of 4th gear. WOT and lighter acceleration usually doesn't give me a problem. When pulling the spark plugs, 1,3 and 4 (from left to right facing the front) had oil on them. Looking down into the spark plug wells, I noticed quite a fair amount of oil pooling in them. Valve cover gaskets? Could my spark plugs be fouling out bad enough from the oil, that they are causing a pretty obvious stutter?

Third issue. I've had two different mechanics now check the front end. Both have told me that it's fine, but one shop "claimed" that one of my ball joints had some play in it. Didn't tell me which side, nor which one, but I'm assuming that the SC1/2 ride on just one control arm with a ball joint attached, and it's not a dual ball joint system, correct?

So getting on the highway is actually pretty nice, but there is a small (and I emphasize small) shaking in the steering wheel, mostly felt above 70 MPH. The alignment is slightly off too. The car will pull gently to the left, and you have to hold the wheel just a hair to the right to keep the car straight. What's going on with it?

Fourth and final issue. This one is actually weird, but simple to describe. I start the car (the noise is much louder when the car's operating temperature is cold) and give it gas in park. As the RPM's come down and the car gentles it's idle, I hear a "rushing water" type of sound from almost under the hood. Not exactly sure where it's from. That's the only part of this that I feel is hard to describe, lol. Almost like water trickling somewhere...?
1st & 4th: May be the same... You got air in your coolant system. My SC2 did the same thing, including the whistling noise. Try this first: When warn, NOT full hot, unscrew the coolant auxiliary tank cover, let it burp, then screw it back on tight.

2nd: Did it studder before the tune-up? Did you thoroughly clean the Throttle Body? It could also be the Fuel Filter.

3rd: Take it to a 3rd front-end specialty shop and see what they say. Front-end play could be part of your shaking. Did you rotate & balance the tires yet? If so and it's still there, it could be the front-end parts, but if not, go back to the shop and have them do a "Road Force" balance as that was the only balancing that got my SL2 to stop shaking lightly at those high speeds. If not those, you may have a tire out-of-round and it may not ever get totally smooth.

Let us know the follow-up!
...
Proud Owner of a '99 SC2 Rare "White Hot" 5-Speed.
DEEBS Build & 12:1 Compression. :-)
Rotella 10w-30 + M1 Ext Perf. Oil Filter.

Owned 5 other S-Series.
Pitcher is offline   Reply With Quote
Old 01-21-2015, 09:28 PM   #12
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default Re: I'm Back! Here We Go Again!

Quote:
Originally Posted by Pitcher View Post
1st & 4th: May be the same... You got air in your coolant system. My SC2 did the same thing, including the whistling noise. Try this first: When warn, NOT full hot, unscrew the coolant auxiliary tank cover, let it burp, then screw it back on tight.

2nd: Did it studder before the tune-up? Did you thoroughly clean the Throttle Body? It could also be the Fuel Filter.

3rd: Take it to a 3rd front-end specialty shop and see what they say. Front-end play could be part of your shaking. Did you rotate & balance the tires yet? If so and it's still there, it could be the front-end parts, but if not, go back to the shop and have them do a "Road Force" balance as that was the only balancing that got my SL2 to stop shaking lightly at those high speeds. If not those, you may have a tire out-of-round and it may not ever get totally smooth.

Let us know the follow-up!
I did try and let the car run to burp the coolant system. I took the cap off first, then started the car though. Did I do that wrong? The car seems to warm up a tad faster, and the heat blows a little hotter when warmed up, but the car is still whistling on the highway. The coolant is actually pretty dirty, so I'm just going to change it out soon, along with a new t-stat and ECTS.

Yes, the car did stutter (as I mentioned on the drive home, before) and it still does now. I may change the fuel filter here in the near future, but for right now, I have a big feeling it's the spark plugs being fouled out by the oil in the plug wells.

The car has brand new tires. When Discount Tire puts them on for me, I make sure to always watch what they are doing. Great guys there, but they do tend to be a little slow sometimes. They always make sure to brush and clean the dust off the rotors, outer edge of the calipers, and the backside of the rims, just to make sure everything is good to go. Tire size the car sits on now is 195/60/R15's. Ohtsu's, on stock alloy rims. Rims are getting older (clear coat is peeling) but I'm gonna try and clean those up this summer, along with a little bit of body work too.

Either way, IMO, they are the best tires you can get for $46, plus taxes and disposal fee out-the-door: http://www.discounttire.com/dtcs/sea...0&rd=15&cs=195
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Old 01-22-2015, 06:10 AM   #13
Pitcher
Master Member
Pitcher has a spectacular aura aboutPitcher has a spectacular aura aboutPitcher has a spectacular aura about
 
Pitcher's Avatar
 
Join Date: Apr 2008
Location: USA
Posts: 2,745

1998 SC2
Default Re: I'm Back! Here We Go Again!

Yes, dusting the cobwebs off my brain cells I remember I changed my coolant around the same time as I burped mine & remember the 1st burping did not stop the whistling. I think I burped it one more time & almost immediately changed the coolant; but I'm not exactly positive which one cured it though.

Sounds like your coolant is dirty (mine was as well), so you better get it changed anyway... Ley us know if that cures it.
...
Proud Owner of a '99 SC2 Rare "White Hot" 5-Speed.
DEEBS Build & 12:1 Compression. :-)
Rotella 10w-30 + M1 Ext Perf. Oil Filter.

Owned 5 other S-Series.
Pitcher is offline   Reply With Quote
Old 01-23-2015, 06:04 PM   #14
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default Re: I'm Back! Here We Go Again!

First off, thank you for the quick reply, Pitcher. The coolant was dirty, so I ended up flushing it out myself (yes, in the cold, lol) and I changed the t-stat and ECTS while I was at it. Another project down... check.

Oh, by the way, I took my brother out on the highway to listen to the whistling, since it was still there after a burp of the coolant system and coolant change. He said it sounded like it was coming from his side. I ended up twisting off the antenna to test it out. It was actually pretty loose, I could turn it without pliers, using just my fingers. The sound isn't there anymore, go figure. Problem solved! Thanks for all the help with that too, it was starting to get annoying, haha.

Now, the time has FINALLY come. Here are some pictures I snapped of the car. It's a little dirty right now, sorry. More to come, after I clean her up a bit. The engine bay has already been cleaned, but I'm gonna do some more work and cleaning on it very soon. The very last picture uploaded was the day I brought it home, taken from my front door, lol.
Attached Images
File Type: jpg WP_20150120_002[1].jpg (125.8 KB, 14 views)
File Type: jpg WP_20150120_006[1].jpg (86.6 KB, 11 views)
File Type: jpg WP_20150120_004[1].jpg (70.1 KB, 16 views)
File Type: jpg WP_20150120_005[1].jpg (77.8 KB, 9 views)
File Type: jpg WP_20150120_001[1].jpg (131.9 KB, 18 views)
File Type: jpg WP_20150120_003[1].jpg (61.4 KB, 11 views)
File Type: jpg WP_20150113_001[1].jpg (131.0 KB, 16 views)
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Old 01-23-2015, 06:13 PM   #15
Pitcher
Master Member
Pitcher has a spectacular aura aboutPitcher has a spectacular aura aboutPitcher has a spectacular aura about
 
Pitcher's Avatar
 
Join Date: Apr 2008
Location: USA
Posts: 2,745

1998 SC2
Default Re: I'm Back! Here We Go Again!

That's where it gets tough over the internet. My whistle was cured for sure with the cooling system maintenance. Hearing the whistle in person is way better.

Glad you got the maintenance done as well!!

Where does your temp gauge go to driving around at full hot?
...
Proud Owner of a '99 SC2 Rare "White Hot" 5-Speed.
DEEBS Build & 12:1 Compression. :-)
Rotella 10w-30 + M1 Ext Perf. Oil Filter.

Owned 5 other S-Series.
Pitcher is offline   Reply With Quote
Old 01-23-2015, 08:15 PM   #16
jesse8931
Member
jesse8931 is a jewel in the roughjesse8931 is a jewel in the roughjesse8931 is a jewel in the roughjesse8931 is a jewel in the rough
 
Join Date: Apr 2009
Posts: 242
 

1997 SL1
Default Re: I'm Back! Here We Go Again!

How many miles ?
jesse8931 is offline   Reply With Quote
Old 01-24-2015, 02:31 AM   #17
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default Re: I'm Back! Here We Go Again!

Mileage is at 176,26X now. Got it with 175,5XX before I drove her home.

The temp gauge sits just over 1/4 at idle, and goes up right around 3/8 during normal driving conditions. Remember, it's only 20 degrees in MI right now, hah. At long lights, or at fast food drive thru's, the gauge gets closer to 1/2.
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Old 03-21-2015, 01:37 PM   #18
MikeNW
Master Member
MikeNW is a glorious beacon of lightMikeNW is a glorious beacon of lightMikeNW is a glorious beacon of lightMikeNW is a glorious beacon of lightMikeNW is a glorious beacon of light
 
MikeNW's Avatar
 
Join Date: Apr 2008
Location: Lower Alabama= God's country, if God wanted mosquito and red ant bites, and to be covered in mildew
Posts: 3,451
 

1997 SL
Default Re: I'm Back! Here We Go Again!

Normal operating temp (according to my scangauge) is about 198. Which is just before "half" on the temp gauge
...
97 SL. Bought 7/07, reluctantly sold Dec 2019
Burgman 400- indestructible beast
Sportster 883- fun bike
Cannondale 29er- daily driver
MikeNW is offline   Reply With Quote
Old 03-23-2015, 02:57 PM   #19
Dennyj1992
Member
Dennyj1992 has a spectacular aura aboutDennyj1992 has a spectacular aura about
 
Dennyj1992's Avatar
 
Join Date: Mar 2013
Location: Bay City, MI
Posts: 483

2002 SC2
Default Re: I'm Back! Here We Go Again!

Quote:
Originally Posted by MikeNW View Post
Normal operating temp (according to my scangauge) is about 198. Which is just before "half" on the temp gauge
That's where mine sits now. Excellent!
...
13' Chevy Spark, 4 speed CVT. Wife's car. 67k.
02' SC2, DOHC, 5 speed M/T. Current DD. 232k.
Dennyj1992 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help, My back seat will not go back up! calvarystand Astra General 9 03-04-2013 02:16 PM
test drove Vue RL and RAV4 back to back MJD1001 2008 Vue 4 08-13-2007 09:55 PM
SPS Cat Back. Red97sc2 S-Series Mods 8 03-04-2006 11:45 PM
Need it to get there and back! jd_champ S-Series General 13 02-16-2006 11:50 AM
Back (well, almost) binkybaby Vue General 14 01-30-2005 10:26 PM


All times are GMT -4. The time now is 03:51 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.