SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 07-19-2006, 07:52 PM   #1
Dan48382
New Member
Dan48382 is on a distinguished road
 
Join Date: Jul 2006
Posts: 5

1995 SC2
Default Idle

I'm a new convert to Saturn. Out of need of a vehicle last winter I came across a 1995 SC2 (manual 5 speed) with 186,000 miles. The car was in great condition (the engine is understandably tired...uses oil).

I've spent countless hours going through these great Forums, benefiting from everyone's posts. THANKS!

I've been working on it a bit, the idle was all over the place, some cleaner took care of that. The temperature gauge never went much past cold so I replaced the thermostat and O2 sensor and the millage went from 27 to 32 mpg.

I'm not an expert on cars, but I've done my fair share of repairs. With all of these sensors.....things have changed.

This is my problem. When I put in the clutch and coast the idle drops way down to about 300 rpm if it doesn't stall completely. Once the car comes to a complete stop the Idle returns to about 700 rpm (steady no wavering). Where do I start the hunt for the FIX.
Dan48382 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-20-2006, 01:48 AM   #2
wolfman
Super Member
wolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of lightwolfman is a glorious beacon of light
 
wolfman's Avatar
 
Join Date: Jun 2002
Location: Texas
Posts: 12,066
 
Default Re: Idle

This assumes the speedometer is actually working, and that the SES (Service Engine Soon) light is NOT on.

The IAC valve is sticking OR the TPS (Throttle Position Sensor) is bad.

To test the TPS. With the car warmed up and idling, rap on the side of the TPS with the plastic handle of a screw driver. If the idle speed alters AT ALL, REPLACE the TPS. If it does not, the IAC (Idle Air Control) valve sounds like it is sticking SHUT. Remove and clean the IAC valve and its pasage, replace the "O" ring. If this does not improve things, the IAC valave probably needs to be replaced, or there may be a problem with its electrical connector.
...
Old Saturns never die, people KILL them, so check your damn oil!
"Unthinking respect for authority is the greatest enemy of truth." Albert Einstein
wolfman is offline   Reply With Quote
Old 07-20-2006, 07:07 AM   #3
Dan48382
New Member
Dan48382 is on a distinguished road
 
Join Date: Jul 2006
Posts: 5

1995 SC2
Default Re: Idle

Thanks for the help on where to look. The speedometer is working and the Service Engine Soon light has never come on. So I'll start with your suggestions. Thanks again.
Dan48382 is offline   Reply With Quote
Old 07-20-2006, 10:42 AM   #4
sps SOHC
Master Member
sps SOHC is on a distinguished road
 
sps SOHC's Avatar
 
Join Date: Dec 2002
Location: Gainesville, FL
Posts: 4,036
 

1996 SC2
Default Re: Idle

I have the same problem except reversed! Sometimes when I'm coming to a stop and push in the clutch the rpms will climb steadily to 1700 or so and stay there. I have to blip the throttle once or twice and it usually falls back down to 800ish.
...
-96 SC2 gets 35 mpg mix city/hw.
sps SOHC is offline   Reply With Quote
Old 07-20-2006, 12:47 PM   #5
Dan48382
New Member
Dan48382 is on a distinguished road
 
Join Date: Jul 2006
Posts: 5

1995 SC2
Default Re: Idle

Next time I'm out and have room, I'll have to get going in reverse to see if mind does what your's does while going forward (LOL). Hope we both can resolve this.
Dan48382 is offline   Reply With Quote
Old 07-24-2006, 05:21 PM   #6
Dan48382
New Member
Dan48382 is on a distinguished road
 
Join Date: Jul 2006
Posts: 5

1995 SC2
Default Re: Idle

A huge THANKS to Wolfman. This last weekend I checked it out. I can see why you said to use the plastic end of a screwdriver, there wasn't enough room to get in a good swing with my hammer . Anyhow while checking the location of the IAC I noticed that the plate in the throttle body seemed to be sticking a little.

I picked up some CRC air intake cleaner and got the area around the IAC and the Plate as best as I could.

Now when I put in the clutch the Idle slowly drops to about 900 and no further (about 100 rpm faster than before).

Thanks again for the help
Dan48382 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough IDLE/Low IDLE no check engine light savage21 Vue Tech 9 12-08-2010 01:27 AM
Occasional low idle speed - ECTS and/or idle air motor? 2003MercMaraude S-Series Tech 2 05-29-2009 04:03 PM
Low Idle, Idle Stall after PCV change LazLoe S-Series Tech 5 04-10-2007 05:40 PM
idle idle idle idle idle idle (dead) nocolourblue S-Series Tech 23 12-29-2006 03:08 PM
No Fast Idle on Cold Start Up and Strange Idle There After Larry Horne S-Series Tech 11 07-21-2006 03:18 PM


All times are GMT -4. The time now is 08:52 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.