SaturnFans.com
saturnfans.com - classifieds - forums


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 04-10-2007, 04:35 PM   #1
LazLoe
Junior Member
LazLoe is on a distinguished road
 
Join Date: Apr 2007
Posts: 21
 
Default Low Idle, Idle Stall after PCV change

So yea ... was getting a rattling from the PCV so I figured it was time for a change. While I was at the auto parts store I was in process of removing the hose when I decided to make absolute sure it wasnt a fluke that I heard it rattling during my checks.

As I was replacing the hose I had someone start the motor. As that was happening i burned myself and didnt get the hose back on in time.

The motor started without the PCV hose connected and as such revved up pretty good. It wasnt high enough to be dangerous in itself but now the car will idle at about 600 where it used to idle at about 800. It will also stall if I am in drive and idling along, like in a parking lot.

I would like to know if someone could advise how to get this thing going again, I assume the computer is just a bit hosed, or it could be that this thing is sensitive to aftermarket junk (PCV Valve, which I am replacing today with a dealer item).

I would like to know if there are others who can verify the conditions I have explained and the proper fix for this. After some searching I have found the possibility of a bad aftermarket PCV which I am ruling out today, but if i hosed the computer ... what is my next step?

Thanks.
LazLoe is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-10-2007, 04:39 PM   #2
ayoung002
Member
ayoung002 is on a distinguished road
 
Join Date: Dec 2006
Location: Atlanta, GA
Posts: 132

1998 SC1
Default Re: Low Idle, Idle Stall after PCV change

Quote:
Originally Posted by LazLoe View Post
So yea ... was getting a rattling from the PCV so I figured it was time for a change. While I was at the auto parts store I was in process of removing the hose when I decided to make absolute sure it wasnt a fluke that I heard it rattling during my checks.

As I was replacing the hose I had someone start the motor. As that was happening i burned myself and didnt get the hose back on in time.

The motor started without the PCV hose connected and as such revved up pretty good. It wasnt high enough to be dangerous in itself but now the car will idle at about 600 where it used to idle at about 800. It will also stall if I am in drive and idling along, like in a parking lot.

I would like to know if someone could advise how to get this thing going again, I assume the computer is just a bit hosed, or it could be that this thing is sensitive to aftermarket junk (PCV Valve, which I am replacing today with a dealer item).

I would like to know if there are others who can verify the conditions I have explained and the proper fix for this. After some searching I have found the possibility of a bad aftermarket PCV which I am ruling out today, but if i hosed the computer ... what is my next step?

Thanks.
It's probably just the aftermarket PCV. I was skeptical about there being a big difference in factory and aftermarket PCV's but if you compare them side by side, the factory PCV is more restrictive and there for less of a vacuum. 99.9% sure that this is your issue.
ayoung002 is offline   Reply With Quote
Old 04-10-2007, 04:46 PM   #3
acman
Member
acman has a spectacular aura aboutacman has a spectacular aura aboutacman has a spectacular aura about
 
Join Date: Mar 2006
Location: Blair, NE 68008
Posts: 247
 
1999 SC1
Default Re: Low Idle, Idle Stall after PCV change

Try disconnecting the battery for 10 minutes to clear the computer memory and then restart the engine. I use Autozone $1.49 PCV valves and they always work great. My 1997 SL2 with 147,000 miles burns less than 1/2 qt oil in 4,000 miles, the distance between oil changes, and idles smoothly. It also gets great mpg, between 35 - 40 mpg depending on A/C usage and how fast I drive.
acman is offline   Reply With Quote
Old 04-10-2007, 05:01 PM   #4
LazLoe
Junior Member
LazLoe is on a distinguished road
 
Join Date: Apr 2007
Posts: 21
 
Default Re: Low Idle, Idle Stall after PCV change

Acman .. THAT is exactly one thing I was wondering about. I was unsure of how long and whether or not it was effective. Any more ideas are still greatly appreciated. I will try the battery thing right now though because its the easiest I can do before going to work
LazLoe is offline   Reply With Quote
Old 04-10-2007, 05:30 PM   #5
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,715
 

1996 SW2
Default Re: Low Idle, Idle Stall after PCV change

If you don't want to lose your radio presets and time, you can simply remove the "PCM B" fuse from the under-hood fuse box, for the same effect. But I think it has to be 30 minutes.
madpogue is offline   Reply With Quote
Old 04-10-2007, 05:40 PM   #6
LazLoe
Junior Member
LazLoe is on a distinguished road
 
Join Date: Apr 2007
Posts: 21
 
Default Re: Low Idle, Idle Stall after PCV change

Hah, thanks madpogue, but I dont really listen to RIAA controlled media anymore. Besides, the ratio here is usually about 20 minutes or more of commercials and blabbering for every hour. Satellite and Ipod FTW!

BUT, it seems the battery disconnection worked here, as apparently was what my counterpart actually told me last night. Sure wish that would have registered then.


While I'm at it, figure I'd also ask if anyone has replaced their battery bracket after installing a larger battery
This Duralast Gold I bought here doesnt want to fit in the factory bracket and I cannot decide which aftermarket style I wish to use.

....and I am still planning on replacing that pcv ....


THANKS
LazLoe is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Rough IDLE/Low IDLE no check engine light savage21 Vue Tech 9 12-08-2010 01:27 AM
Strange Idle, Almost Stall, Vibration WhaleBiologist S-Series General 7 12-22-2009 09:31 AM
Occasional low idle speed - ECTS and/or idle air motor? 2003MercMaraude S-Series Tech 2 05-29-2009 04:03 PM
2000 rpm idle / stall Static S-Series General 2 07-21-2006 01:26 AM
High Idle, Low Idle, Hesitation Shawn S-Series Tech 11 04-26-2004 01:29 PM


All times are GMT -4. The time now is 01:40 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.