SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 07-30-2021, 03:12 PM   #1
dbuck423
New Member
dbuck423 is on a distinguished road
 
Join Date: Dec 2015
Posts: 3

2002 SL2
Default Transmission Issues. P0732, P0733, P0741, P0783

2002 SL2 210K miles, gets 50K mile ATF and filter changes, last one at 200K. Had the valve body replaced at about 80K with a Sonnex updated valve body for the usual slamming into gears, haven't had any issue with the transmission since the new valve body was installed. Yesterday i made a 350 mile tip all highway, Everything was fine until i exited by my house and stopped at a traffic light, when i went to leave from the light i had no power, it feels like the car only has 4th gear. I limped it to my house looked over the transmission, no leaks and fluid is no low, the check engine light came on and i got codes:
P0732: Gear 2 incorrect ratio
P0733: Gear 3 incorrect ratio
P0741: Torque converter clutch circuit performance/stuck off
P0783: 3-4 shift.

Reverse works fine, no slamming, everything feels normal in reverse. In Drive from a dead stop accelerating to 70 mph, it bogs down the transmission doesn't shift and at highway speed it feels normal unless i floor it, it will downshift rev really fast while not accelerating then go back to 4th.

From the search i have done it appears my problem may be a solenoid issue, I'm going to go check test those now, There are a few threads with similar issues but no follow up to what ended up being the problem. I'm reaching out to see if anyone has any further insight.
dbuck423 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-30-2021, 05:46 PM   #2
billr
Master Member
billr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to behold
 
Join Date: Jul 2013
Posts: 6,205
Default Re: Transmission Issues. P0732, P0733, P0741, P0783

Check the three trans fuses. Besides checking the solenoid resistance, check for (solenoid) coil shorts to ground.

Check for 12V on the five power wires to the 10-pin connector on top the trans. I think that power comes through the fuel pump relay, so you will have to have the engine running to check for the 12V.

Still no joy? Then disconnect that 10-pin cable from the trans and take it for a drive. With all solenoids disabled (cable off) the trans should act nearly as you describe, R and 4th only; but I don't think it should downshift to 1st. Also, the shifts from N to either R or D will be a bit harsh, as line-pressure will be forced to max.
billr is offline   Reply With Quote
Old 07-31-2021, 02:49 PM   #3
dbuck423
New Member
dbuck423 is on a distinguished road
 
Join Date: Dec 2015
Posts: 3

2002 SL2
Default Re: Transmission Issues. P0732, P0733, P0741, P0783

An Update:

I checked the fuses and had a blown fuse, I replaced it everything was back to normal drove around a few minutes and the fuse blew again. limped it back home I took the battery tray out and went to test the solenoids from the connector, I could get consistent ohm readings on everything but the 2nd gear solenoid. I removed the valve body cover, solenoid cover and bus plate and tested at the solenoids and everything checked out fine, I put the bus plate back on and tested at the connector again and still couldn't get a good reading on 2nd gear solenoid, I swapped the solenoids around and the kept getting inconsistent ohm reading on 2nd gear. I checked local auto parts stored no one sold just the bus plate. So I went to the junk yard and was going to buy a valve body so I could get extra solenoids but they wanted $75 for it so I asked how much for just the bus plate and they said $5, I pulled the bus plate(after testing it) walked to the register and they looked at it and said it's free. Went home installed the junkyard bus plate, tested everything multiple times and got consistent ohm reading on all solenoids from the connector. I put everything back together and after about an hour of driving around everything works great.
dbuck423 is offline   Reply With Quote
Old 07-31-2021, 03:33 PM   #4
DevinPotter
Member
DevinPotter is on a distinguished road
 
Join Date: Mar 2016
Location: Utah
Posts: 106

1998 SL1
Default Re: Transmission Issues. P0732, P0733, P0741, P0783

Thats great to hear .. ive be watching this post was going to jump in and say change the valve bodybut thats not needed A+++++ work ! Keep us posted
DevinPotter is offline   Reply With Quote
Old 07-31-2021, 03:59 PM   #5
billr
Master Member
billr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to beholdbillr is a splendid one to behold
 
Join Date: Jul 2013
Posts: 6,205
Default Re: Transmission Issues. P0732, P0733, P0741, P0783

Just curious... what reading were you getting on the bad solenoid circuit; >5 ohms or < 5 ohms? (Yes, I understand the solenoid itself is OK, the problem was in the bus plate)
billr is offline   Reply With Quote
Old 08-05-2021, 05:56 PM   #6
dbuck423
New Member
dbuck423 is on a distinguished road
 
Join Date: Dec 2015
Posts: 3

2002 SL2
Default Re: Transmission Issues. P0732, P0733, P0741, P0783

Quote:
Originally Posted by billr View Post
Just curious... what reading were you getting on the bad solenoid circuit; >5 ohms or < 5 ohms? (Yes, I understand the solenoid itself is OK, the problem was in the bus plate)
Testing at the connector it was all over the place for 2nd gear, from 1 ohm to like 15 ohms, every time i tested it it would give me a different read out.
dbuck423 is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 Saturn Sl1 Automatic with P0732, P0733, P0783, and reverse bang SaturnMass S-Series Tech 2 01-14-2018 09:08 PM
Help...P0783, P0732, P0733 AlsCars S-Series Tech 8 11-19-2014 10:59 PM
P0732, P0733, P0734 on SWP ii311hive S-Series Tech 60 04-19-2014 09:27 AM
Transmission slipping - Codes P0732, P0733, P0734 - HELP!! firestorm1284 S-Series Tech 0 08-24-2011 07:23 PM
SL1 Transmission P0732, P0733 & P0734 Codes pzys6k S-Series Tech 3 01-26-2006 12:35 AM


All times are GMT -4. The time now is 10:00 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.