SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn Ion > Ion Tech

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 04-01-2021, 08:31 PM   #1
Treystoys
New Member
Treystoys is on a distinguished road
 
Join Date: Mar 2021
Location: Kenner Louisiana
Posts: 7

2004 ION-2 Sedan
Default Communications link error, service vehicle and brake warning

How’s it going everyone. I just picked up a high mileage 04 Ion 2 sedan. The car is in pretty good shape cosmetically, a little funky inside, a bit clunky suspension wise, but actually runs and shifts great and has cold AC. It’s a car for my teen to go back and forth to school, practice...

So, as my thread title says, I have the service vehicle and brake warning lamps lit, and I get a communications link error with my scanner and I have attempted to use 3 different scan tools, all giving me the same error message.

So first, the brake light...the reservoir is full of brake fluid, the connector is plugged into the sensor (have not pulled the sensor yet to look at it or checked for float operation if there is one?) and the grounding strap on the e brake handle has continuity and looses it as per its design.

I found the fuse blown for the lighter and got very excited thinking the scanners would link, but no dice, fuse still intact and none of the readers I’ve used will link.

The service vehicle light? I don’t know, is it tied to the brake light and link error or one or the other? I’m kind of thinking it’s tied to the brake light issue, but am still brainstorming it.

The car has another issue dealing with the door locks. The issue being sporadic working but most times not, and sometimes all or some will unlock when I shut the car off and open the drivers door.

It would be easy to call all of it a bcm issue, but I don’t know. I have a reasonable skill set with regards to automotive repair, part of which involves researching before hand, which landed me here. This being a car I am keeping, I figured I’d join up here and get sone help with the researching.

Thanks in advance! and my name is Trey

Last edited by Treystoys; 04-01-2021 at 08:45 PM.
Treystoys is offline   Reply With Quote
SaturnFans.com Sponsored Links
 

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2002 SL 2, service & brake warning after radiator replacement 2002_SL2 S-Series General 8 03-12-2017 12:41 AM
Service Vehicle and red Brake light came on? ddemier7 Ion Tech 9 06-25-2015 08:22 PM
Error Code link grunthaner S-Series Tech 2 06-20-2012 06:36 PM
Service wrench and brake warning light mgordon1100 S-Series Tech 3 02-18-2010 04:26 PM
Vehicle Communications Interface Module (VCIM) ottastra Astra Tech 3 12-05-2009 04:55 PM


All times are GMT -4. The time now is 12:49 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.