SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Reply
 
Thread Tools Display Modes
Old 04-04-2021, 09:16 PM   #1
Upstate Saturn
Member
Upstate Saturn is just really niceUpstate Saturn is just really niceUpstate Saturn is just really niceUpstate Saturn is just really niceUpstate Saturn is just really nice
 
Upstate Saturn's Avatar
 
Join Date: Jan 2014
Location: Raleigh, North Carolina
Posts: 460
 

2001 SL2
Default Check engine light staying on for a noticeable few seconds after starting

My 2001 SL2 just started a new and alarming behavior. When I start her, the red check engine light stays on for a few more seconds after all the other dash starting lights have gone off. It's a noticeable length of time, at least for a hyper-alert Saturn owner like myself.

The oil level is fine, and the oil was changed about 500 miles ago. Do you think that the oil pump is failing, and if so, is there any other way to check it? Does this seem like a catastrophic failure waiting to happen, or am I just paranoid?

She has about 290,000 miles on her, and I had a remanufactered motor put in at 228,000 miles. I'm 99% sure the oil pump was replaced then as I had most pumps, etc. replaced while the engine was out of the car.
...
.

2001 SL2 manual - original owner - remanufactured engine at 228k miles, December 2015
1992 SL1 manual - bought used in '93, totaled in '00 at 170k miles, drove it cross-country a lot!
.
Upstate Saturn is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-04-2021, 11:08 PM   #2
Waiex191
Master Member
Waiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to beholdWaiex191 is a splendid one to behold
 
Waiex191's Avatar
 
Join Date: Oct 2016
Location: Poplar Grove, IL
Posts: 3,083

1999 SL2
1998 SC2
Default Re: Check engine light staying on for a noticeable few seconds after starting

Do you mean the red oil can light? Mine stays on for a bit.
https://youtu.be/EEeYtufQUOI

That is not affected by oil level - unless it is so low the pump starves for oil. It is just a pressure switch on the oil galley.

This does not sound very catastrophic to me.
...
Bryan Cotton
'99 SL2, 5SP bought new
Rebuilt at 204,067 September 2017
Engine, subframe, diff pin mod, brake lines, headliner, alternator, and so on!
'98 SC2, 5SP bought 2018
Waiex191 is offline   Reply With Quote
Old 04-05-2021, 11:20 PM   #3
Zeebins
Senior Member
Zeebins has much to be proud ofZeebins has much to be proud ofZeebins has much to be proud ofZeebins has much to be proud ofZeebins has much to be proud ofZeebins has much to be proud ofZeebins has much to be proud ofZeebins has much to be proud of
 
Zeebins's Avatar
 
Join Date: Jun 2017
Location: Massachusetts
Posts: 1,282
 

1997 SL2
Default Re: Check engine light staying on for a noticeable few seconds after starting

The pump may be bad but it could also be the pressure sender. The only way to know for sure would be to hook up a pressure gauge in place of the oil pressure sender. Then you could see exactly how long the car takes to build pressure, and how much of it. Doing that would be kinda pointless without a reference of what it should be, so hopefully someone else happens to know what the oil pressure should be.
...
97 SL2, auto, 123K miles
Zeebins is offline   Reply With Quote
Old 04-07-2021, 08:42 AM   #4
Ricketts
Member
Ricketts is a glorious beacon of lightRicketts is a glorious beacon of lightRicketts is a glorious beacon of lightRicketts is a glorious beacon of lightRicketts is a glorious beacon of light
 
Join Date: Jul 2014
Posts: 247

2000 SC1
Default Re: Check engine light staying on for a noticeable few seconds after starting

Mine did this 4 years ago - I was concerned but reading through many posts here it seems the oil pump is not prone to failure. I bit the bullet and replaced the oil pressure sending unit and it has been fine ever since.
...
2000 SC1 - Bone Stock
No power windows, no power locks, no AC, no cruise control...just a good DD that has nothing to break on it
Ricketts is offline   Reply With Quote
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed Smog Check After Erasing Check Engine Light Code trench619 Ion General 9 05-01-2015 11:58 AM
Check Engine Light/Trouble Starting theCTgrower Astra Tech 10 04-03-2015 09:11 PM
stuck in park, check engine light, brake light flashing Wemble Ion General 8 02-08-2014 05:38 PM
1999 SL2 Dies 5 Seconds After Starting jedijohn82 S-Series Tech 19 04-14-2009 09:27 PM
Battery light turns on 30 seconds after starting car, failing alternator? phitchow L-Series General 4 08-14-2006 03:59 PM


All times are GMT -4. The time now is 10:22 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.