SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech

Closed Thread
 
Thread Tools Display Modes
Old 04-01-2001, 07:57 PM   #1
therapist
Member
therapist is on a distinguished road
 
Join Date: Jun 2000
Location: new jersey
Posts: 220
Default cruise control refuses to engage.

got a new problem on my beat up 94sl2. this has been a recurring problem but it really bothered me this time. my cruise control is temperamental and refuses to work at times. when the cruise control is suddenly disengaged by braking or turning off the thumb switch i can hear/feel the accelerator pedal suddenly slap upwards. and when i try to set it back to cruise all i hear and feel is a mechanical clicking noise on the accelerator pedal area which sounds like a mechanism is trying to grab my accelerator cable but fails to do so. this condition will stay with the car for several weeks and then magically function again. can someone tell me anything i can possibly do?
therapist is offline  
SaturnFans.com Sponsored Links
Old 04-02-2001, 09:52 AM   #2
Heartbeat - '95 SL2
Senior Member
Heartbeat - '95 SL2 is on a distinguished road
 
Heartbeat - '95 SL2's Avatar
 
Join Date: Jan 2001
Location: Southern California
Posts: 1,324
 

1995 SL2
Default

I had my intermittent cruise fixed while under warranty. They adjusted the clutch/brake disengage switches. Now that it's out of warranty, it still does it, but less frequently. Anytime it doesn't engage, I just pull up on the clutch pedal with my foot, and it works again.
Heartbeat - '95 SL2 is offline  
Old 04-02-2001, 08:42 PM   #3
ssicarman
Super Member
ssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to beholdssicarman is a splendid one to behold
 
ssicarman's Avatar
 
Join Date: Oct 2000
Location: Western Canada
Posts: 10,468
 
Default

With the cruise sounding like it's trying to engage I would say that the problem is likely in the cruise module. This is the black plastic box mounted at the bottom area of the steering column. Check it visually to make sure that the connection from the module to to gas pedal bracket is good. If it is then you are likely looking at replacing the module. Your store should have a tester for the cruise that will check all the switches and the module, but if the cruise is working when you bring it in it will show nothing. In my experience with the cruises though it is usually the module that goes rather than anything else.
ssicarman is offline  
Old 04-03-2001, 09:54 AM   #4
Jon94SoLo2
Guest
 
Posts: n/a
Default

Wow, here I am thinking I'm the only person with this problem...then this post appears. I had actually given up on my cruise control ever working consistently. I have the EXACT SAME problem and I've had it since day 1 in 1994. Another symptom of mine is that it will occasionaly start decelerating by as much as 20mph while still engaged then suddenly accelerate back up to the set speed. I've had everything replaced except for the on/off switch on the steering wheel and the wiring (new cruise module, new/adjusted clutch switch, new/adjusted brake switch). Like I said, I had given up on my cruise ever working consistently. After going round and round with Saturn about it for months without any solution, I just gave up. I don't even use the thing anymore, really, although I'd like to.

Jon
'94 SL2 (cruise...sort of <img src="http://64.77.2.166/cgi-bin/UltraBoard/Images/Sad.gif" border="0" align="middle"> )
 
Closed Thread

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
cruise control ohios4turn S-Series Mods 7 07-22-2008 12:29 PM
cruise control??? TheGreenOne S-Series Tech 1 04-13-2008 11:36 PM
Cruise Control Not so good on the control part? aph3x Outlook General 2 10-15-2007 08:39 PM
I've lost control of my cruise control stainlesswelder S-Series General 10 10-21-2006 12:18 AM
Cruise control problems: won't engage! 98greenSC2 S-Series Tech 8 12-17-2004 11:27 AM


All times are GMT -4. The time now is 10:19 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.