SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech

Reply
 
Thread Tools Display Modes
Old 07-31-2021, 07:19 PM   #1
lrbraner
Member
lrbraner is a jewel in the roughlrbraner is a jewel in the roughlrbraner is a jewel in the roughlrbraner is a jewel in the rough
 
Join Date: Jan 2018
Location: Ft. Wayne, IN
Posts: 373

2002 L-Series 3.0L Sedan
2003 L-Series 3.0L Wagon
Default On to the next issue with my 02 L300; P/S hoses.

Has any one replaced the P/S hoses from the rack to the pump ?
Mine are leaking where there are clamped to the frame near the front tire. The metal portion has rusted away.
...
2002 L300 Sedan
2003 LW300 Wagon
2005 L300 Sedan
lrbraner is offline   Reply With Quote
SaturnFans.com Sponsored Links
Reply

Bookmarks


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
L300 Headlight Issue jbcul L-Series Tech 22 01-28-2018 01:35 PM
l300 ses issue theophage L-Series Tech 11 11-06-2013 08:43 AM
L300 3.0L Tranny Issue felixthecat L-Series General 4 12-21-2009 11:15 AM
Nagging Issue w/ 01 L300 V6 caffeineboy L-Series Tech 2 09-08-2009 12:58 PM
Coolant Issue w/L300 Shadowless L-Series General 1 03-09-2007 06:25 PM


All times are GMT -4. The time now is 08:32 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.