View Single Post
Old 02-24-2021, 09:29 AM   #14
Highmile
Senior Member
Highmile will become famous soon enoughHighmile will become famous soon enough
 
Highmile's Avatar
 
Join Date: Mar 2001
Location: St. Louis, Mo.
Posts: 1,315

1995 SL1
Default Re: Sl1 engine rebuild

Quote:
Originally Posted by Ccrussell View Post
Highmile,
As was suggested by Billr , I am going to put on A oil pressure gauge already have the adapters for that. Are you suggesting that I re-prime and just try to start this motor ? After doing the inspections you folks have recommended of course. the squealing sounds that emanated from this were pretty disturbing. Also going to pull the trans inspection cover no harm in that.
May get to this tonight as there is another winter blast headed our way,
Probably no work tomorrow .
Yes repeat the oil prime but not for the reason of priming the oil system but more for listening for strange noises. I'd start with plugs out and then repeat with plugs in and fuel pump relay pulled out.

I had something similar happen to one I built and it turned out to the be the rocker shaft bolts had pulled out of the head, taking the threads out with them, on the exhaust side. I helicoiled them and engine has been running perfectly for several years now.

I'd also take a very close look for anything that could have gotten overlooked, like a wrench or screwdriver that has gotten stuck somewhere and is now making a racket. Same goes for exhaust. Shake the tailpipe to make sure no strange noise like it's hitting something.

Highmile
'95 SL1 725k and counting
Highmile is offline   Reply With Quote