View Single Post
Old 07-31-2021, 09:24 AM   #6
j.small17
New Member
j.small17 has a spectacular aura aboutj.small17 has a spectacular aura aboutj.small17 has a spectacular aura about
 
Join Date: Nov 2017
Location: Ottawa, On
Posts: 5

2009 Astra XE
Default Re: Oil in spark plug well

My main reason for getting the used parts was to get the vehicle back on the road asap, as I wasn't able to wait around for parts to get here.

I used RTV to help seal the gasket on the newly installed valve cover and will keep an eye on it over the next few weeks. If needed, I'll get a new cover with gasket. I've found some on Amazon.ca and elsewhere for about $100CAD.

Thanks for the tip on the coil packs. I will try swapping the rubber ends, as the rubber on the aftermarket coil pack was shredded. If that doesn't work, there are a bunch of options for coil packs on Amazon.ca.

I did not replace the spark plugs, as I had replaced them when I did the coil pack a few years ago. I used towels to absorb the oil out of the wells, then used a water bottle brush to scrub the wells clean. I also removed and cleaned off the spark plugs. The gap on them is still good.

The thermostat change went well, once I had some vice grips to loosen the clamp on the hose. I also changed the coolant temp sensor, as I've seen people on here suggest replacing it when doing the thermostat, just for sake of convenience.

Thanks for the tip on the flex pipe. I did have that replaced in March 2021, so I do not anticipate that being an issue.

I ran it in park for about 15 minutes and didn't have any codes pop-up. Going to do a coolant flush and try again. Hopefully, everything is fixed.
j.small17 is offline   Reply With Quote