View Single Post
Old 01-19-2009, 09:42 PM   #1
DarkNexxus
New Member
DarkNexxus is on a distinguished road
 
Join Date: Jan 2009
Posts: 8
Default Electrical issues

I apologize if this isn't the right forum to post this in.

I have a 97 Sc1 or SL1, something like that. If it's a big issue, I can find out, but it's cold outside! I bought the car off a good friend. His wife used to travel around the state in it because of her job. Basically it's got a lot of miles on it, but mostly highway. 150k+

Okay, not that any of that matters, but still it's out there. Here's my issues:

1. When I bought the car, the interior lights will not work when opening a door or by any switch. The overhead dome light is the only one that comes on, and that is by switch only.

2. The car power locks are worn out. We have a slight cold snap in this area right now and tonight I went to go out and found that my lock switch had gotten stuck and drained the battery. I jumped it, ran it around the block, and in doing so, found out that my rear defroster will not work now.

3. I smell antifreeze from time to time, but nothing is leaking. I don't see any leakage around the overflow container nor the lid, is there any known problems on this? Car does not overheat, and it does produce good heat while driving.

Those are my big issues right now. The other stuff will be fixed after a visit to the tire store (car sounds like a 4x4 while driving).

Any tips you can give me will be greatly appreciated.
DarkNexxus is offline   Reply With Quote
SaturnFans.com Sponsored Links