SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Search Forums

Showing results 1 to 25 of 111
Search took 0.04 seconds.
Search: Posts Made By: todd8
Forum: S-Series Tech 12-05-2016, 08:18 PM
Replies: 10
Views: 550
Posted By todd8
Re: Water Pump on Its Way Out????

The original went around 140k, this was an AutoZone replacement and it lasted about 42k
Forum: S-Series Tech 12-03-2016, 09:06 PM
Replies: 10
Views: 550
Posted By todd8
Re: Water Pump on Its Way Out????

Thanks for all the responses, I pulled the wheel and splash shield off today and there was no question at all, the water pump was the culprit. Also noticed where it has begun to weep. Glad I caught...
Forum: S-Series Tech 12-02-2016, 04:35 PM
Replies: 10
Views: 550
Posted By todd8
Water Pump on Its Way Out????

Recently developed a squeaking sound from the front passenger side of my 1999 Saturn SL2. It is worst when the car is cold and gradually lessens as the car warms up. I checked with the hood up and...
Forum: S-Series Tech 09-25-2015, 09:27 AM
Replies: 7
Views: 456
Posted By todd8
Re: Driver's Side Brake Pic

Thanks again to all. I checked things out last night and sure enough, the caliper was spun around the wrong way! I simply turned it, the hose looped towards the back of the car and I reinstalled.
...
Forum: S-Series Tech 09-24-2015, 03:26 PM
Replies: 7
Views: 456
Posted By todd8
Re: Driver's Side Brake Pic

Thanks to all for your help. It is appreciated!!!!!
Forum: S-Series Tech 09-24-2015, 08:47 AM
Replies: 7
Views: 456
Posted By todd8
Driver's Side Brake Pic

This may sound like an odd request, but I was wondering if anyone has or can take a pic of the way the brake hose is routed on the driver's side (front) of an S-Series? I have a 1999 model and have...
Forum: S-Series Tech 09-22-2015, 03:53 PM
Replies: 5
Views: 463
Posted By todd8
Re: Grinding Noise

I thank you for the response and will check both the bearing and the shaft as you suggested.

Have a great day!
Forum: S-Series Tech 09-22-2015, 12:14 PM
Replies: 5
Views: 463
Posted By todd8
Grinding Noise

Hello, I have a 1999 SL2 that has developed a grinding noise in the driver's side front wheel area. It only happens when I am in reverse and turning the wheel hard to the right or left. Quiet as a...
Forum: S-Series Tech 01-11-2015, 04:46 PM
Replies: 11
Views: 575
Posted By todd8
Re: Intermittant Power to the AIR Pump

Thanks for that information. Will give it a try and report back....
Forum: S-Series Tech 01-11-2015, 08:45 AM
Replies: 11
Views: 575
Posted By todd8
Re: Intermittant Power to the AIR Pump

located in NE Pennsylvania....has been very cold lately, so the pump should be running. Haven't had the code set in about a week, but will try cleaning that pcm ground.

Thanks for continuing to...
Forum: S-Series Tech 01-10-2015, 11:01 PM
Replies: 11
Views: 575
Posted By todd8
Re: Intermittant Power to the AIR Pump

The problem started with the pump not running maybe once out of every five starts. It progressed to the point where now the pump might run once out of every ten or fifteen starts. Have had no blown...
Forum: S-Series Tech 01-10-2015, 03:02 PM
Replies: 11
Views: 575
Posted By todd8
Re: Intermittant Power to the AIR Pump

Followed your instructions but found no corroded or loose connections. Verified continuity between the uhjb and the power connector to the pump. again verified pump runs when connected directly to...
Forum: S-Series Tech 01-08-2015, 12:25 PM
Replies: 11
Views: 575
Posted By todd8
Re: Intermittant Power to the AIR Pump

Thanks! Will check the connections at the UHJB as soon as it warms up a bit. Currently 7 degrees outside. I did check the connection at the pump and it appeared to be fine.
Forum: S-Series Tech 01-07-2015, 12:36 PM
Replies: 11
Views: 575
Posted By todd8
Intermittant Power to the AIR Pump

Been having a problem with intermittant power to the connector to the AIR pump on a 1999 SL2 with 157K.

- Have verified that the pump works just fine by connecting it directly to a
12 v...
Forum: S-Series Tech 07-11-2012, 12:31 PM
Replies: 9
Views: 1,189
Posted By todd8
Re: Coolant/water ratio too high?

There is a small petcock drain on the radiator - passenger side. It's plastic, so becalf when turning.
Forum: S-Series Tech 03-04-2012, 08:36 PM
Replies: 4
Views: 1,149
Posted By todd8
Re: 1999 SL2 Rough Idle When Cold

OEM Mounts, yes and yes - no luck
Forum: S-Series Tech 03-04-2012, 05:36 PM
Replies: 4
Views: 1,149
Posted By todd8
1999 SL2 Rough Idle When Cold

Have a 1999 SL2 5 Speed with 118,000 miles and a rough idle when the engine is cold. Seems to smooth out once the engine reaches operating temperature, but prior to that it's rough. When I say...
Forum: Vue Tech 02-10-2011, 12:56 PM
Replies: 8
Views: 2,035
Posted By todd8
Re: Squeek Squeek Squeek Goes the rear Wheel

Well after many hours under this VUE, I finally discovered the source of the SQUEEK - and the worst part is it seems to have been my doing. Back in the fall, I replaced the RDM fluid with Royal...
Forum: Vue Tech 02-07-2011, 09:04 AM
Replies: 11
Views: 1,517
Posted By todd8
Re: Fuel Pump

If it is the axle seals, how hard are they to replace? This noise starts up after about 20 minutes of driving. On short trips it is not present.

I did change the old differential fluid to Royal...
Forum: Vue Tech 01-28-2011, 07:13 PM
Replies: 11
Views: 1,517
Posted By todd8
Fuel Pump

Does the fuel pump run at a continuous speed, supplying a constant pressure in the fuel system, or does it speed up and slow down based on the throttle position.

I am under the impression that it...
Forum: Vue Tech 01-20-2011, 01:06 PM
Replies: 1
Views: 905
Posted By todd8
Squeakin' Vue

Hey Guys,

I am still trying to track down the source of the squeak in my 2004 VUE V6 AWD. As was stated in previous post, the squeak sounds like it is coming from the rear of the vehicle and...
Forum: Vue Tech 12-23-2010, 09:26 AM
Replies: 8
Views: 2,035
Posted By todd8
Re: Squeek Squeek Squeek Goes the rear Wheel

Gene,

Thanks for leading me to check the universal joints, I think you may have found the culprit. I had hoped to find a greasable u-joint, but unfortunately, there is no zerk fitting. In any...
Forum: Vue Tech 12-22-2010, 01:00 PM
Replies: 8
Views: 2,035
Posted By todd8
Re: Squeek Squeek Squeek Goes the rear Wheel

Hey Grumpy - I knew you'd reply. I checked things out again and here is some additional information.

I really don't hear any noise when coasting or driving at low speeds, noise seems to appear at...
Forum: Vue Tech 12-22-2010, 09:18 AM
Replies: 8
Views: 2,035
Posted By todd8
Squeek Squeek Squeek Goes the rear Wheel

Ok, another question. My 2004 V6 Vue has developed an annoying squeek, squeek, squeek noise from the rear passenger wheel. It increases and decreases with the speed of the vehicle, and is most...
Forum: Vue Tech 12-17-2010, 12:28 PM
Replies: 17
Views: 19,764
Posted By todd8
Re: 2004 3.5 V6 Multiple Misfire Codes

Fdryer,

The misfire did come back, but still does clear up when the engine is run at higher rpms for a short period. Say like when driving at cruising speeds for a short while.

Some others...
Showing results 1 to 25 of 111

 
Forum Jump

All times are GMT -4. The time now is 07:50 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.