SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Search Forums

Showing results 1 to 25 of 145
Search took 0.05 seconds.
Search: Posts Made By: Keblar
Forum: S-Series Tech 09-27-2021, 02:43 PM
Replies: 8
Views: 503
Posted By Keblar
Re: Need a new radiator

I went with a Denso (#2219001) from RA. The price was decent at $56. It's been fine so far, 2 years, but as I recall I had to use my old hardware because the mounting bolts/screw that came with it...
Forum: S-Series Tech 09-16-2021, 03:50 PM
Replies: 19
Views: 922
Posted By Keblar
Re: Worried engine seized, but hopefully just the Starter

Follow up: It was indeed the starter. Replaced the dead one with a DB Electric and everything is back to "normal".

For whoever comes across this while digging for starter replacement help, it is...
Forum: S-Series Tech 09-10-2021, 10:32 AM
Replies: 19
Views: 922
Posted By Keblar
Re: Worried engine seized, but hopefully just the Starter

I hear ya. I started using an old runner rug, on top of an yoga mat on top of cardboard this past winter when I had to cut off the rust frozen bolt for the lower control arm. At least I had the...
Forum: S-Series Tech 09-08-2021, 03:28 PM
Replies: 19
Views: 922
Posted By Keblar
Re: Worried engine seized, but hopefully just the Starter

I've replaced the starter before, but it was THIS one which means it was over 8 years ago. I have no particular memory of it being difficult or not, but it doesn't stick in my mind as being a repair...
Forum: S-Series Tech 09-07-2021, 11:59 AM
Replies: 19
Views: 922
Posted By Keblar
Re: Worried engine seized, but hopefully just the Starter

A seized engine wasn't my 1st thought, but any other time I've had a starter fail the symptoms were different. I think the solenoid has always failed 1st, and so far that doesn't seem to be the case...
Forum: S-Series Tech 09-07-2021, 11:49 AM
Replies: 19
Views: 922
Posted By Keblar
Re: Worried engine seized, but hopefully just the Starter

Oh I did. Turning easy using a Standard 3/8 wrench with plugs out. Confirmed that pistons are moving in opposition and topping out properly.
Forum: S-Series Tech 09-06-2021, 05:04 PM
Replies: 19
Views: 922
Posted By Keblar
Worried engine seized, but hopefully just the Starter

Skip to the break if you don't want the details.

I stopped to gas up on the way home from my hour plus commute. When I tried to restart I got instrument panel, radio, and AC but no starter, just a...
Forum: S-Series Tech 02-28-2021, 03:32 PM
Replies: 18
Views: 595
Posted By Keblar
Re: Power loss under load at speed. 0401 code after new EGR.

It was not. Once the power loss problem was resolved, I didn't bother checking compression, given the limited time I had/have. I decided it would either come back eventually and I could keep digging,...
Forum: S-Series Tech 02-26-2021, 05:46 AM
Replies: 18
Views: 595
Posted By Keblar
Re: Power loss under load at speed. 0401 code after new EGR.

Correct, it was a 0442 code. That has not returned. I suspect that was from the compromised seal on the old original EGR, since the ACDELCO "GM Original Equipment" replacement gas cap never fixed it....
Forum: S-Series Tech 02-25-2021, 03:35 PM
Replies: 18
Views: 595
Posted By Keblar
Re: Power loss under load at speed. 0401 code after new EGR.

I'd have to go through the original maintenance records that I have from the previous driver, but I'd say almost certainly yes.

If I can get the problem to recur, or it does it on its own again,...
Forum: S-Series Tech 02-24-2021, 05:00 PM
Replies: 18
Views: 595
Posted By Keblar
Re: Power loss under load at speed. 0401 code after new EGR.

That was nice while it lasted: The 0401code is back. However, my wife says she can't replicate the same sudden power loss issue that I experienced. I'll have to wait to get to it this weekend. I'll...
Forum: S-Series Tech 02-23-2021, 03:08 PM
Replies: 18
Views: 595
Posted By Keblar
Re: Power loss under load at speed. 0401 code after new EGR.

I was finally able to troubleshoot on Sunday. The problem seems to be alleviated for now.

I took off the new EGR to put on a new screen gasket. While I had it off I sprayed some more throttle...
Forum: S-Series Tech 02-21-2021, 05:06 PM
Replies: 7
Views: 348
Posted By Keblar
Re: Best brand of harmonic balancer?

Late to the party, but my replacement combo was OEM for the trans mount, prothane inserts for both dogbone / torque mounts, and Westar EM-2827 for the top. This seemed to have worked out well. I'm...
Forum: S-Series Tech 02-17-2021, 07:20 PM
Replies: 18
Views: 595
Posted By Keblar
Re: Power loss under load at speed. 0401 code after new EGR.

Is the vacuum reading off the OBDII in Torque accurate and useful for anything? The screenshot I took yesterday only showed 1.3 in/Hg at 3555 RPM.

I may wind up with a snow day tomorrow. If so...
Forum: S-Series Tech 02-17-2021, 06:25 PM
Replies: 18
Views: 595
Posted By Keblar
Re: Power loss under load at speed. 0401 code after new EGR.

I should probably inspect the plugs anyway to see their condition, although I'd expect to get a misfire code if it was a fouled plug. I can check compression then, but I have no idea when I'll be...
Forum: S-Series Tech 02-17-2021, 02:31 PM
Replies: 11
Views: 510
Posted By Keblar
Re: How to "fix" muffler strap

This is what I did. I don't expect it to hold up to salt for much longer, but between new rubber middle hangers and construction adhesive on the heat shield, it's kept it from rattling and bouncing....
Forum: S-Series Tech 02-17-2021, 02:07 PM
Replies: 18
Views: 595
Posted By Keblar
Power loss under load at speed. 0401 code after new EGR.

I'm currently experiencing loss of power and hesitation under load around or above 55 to 60MPH. Idle is fine at ~870-900 RPM. Around town power seems steady, if a little more sluggish than usual.
...
Forum: S-Series General 04-15-2020, 07:54 PM
Replies: 109
Views: 10,684
Posted By Keblar
Re: Post Your Latest Oil & Filter Change.

The info on Supertech and Warren could be outdated. I want to say the post I found on Warren was from around 2016, in the BITOG forum. I only discovered it today while researching Amazon Oil to...
Forum: S-Series General 04-15-2020, 04:31 PM
Replies: 109
Views: 10,684
Posted By Keblar
Re: Post Your Latest Oil & Filter Change.

all of that data can be found here (https://540ratblog.wordpress.com/)

From what I've found, Warren Distribution makes several "White Label" oils for different outlets. Most notably, they make...
Forum: Classifieds 08-28-2019, 04:00 PM
Replies: 3
Views: 926
Posted By Keblar
Re: OEM Wheels Available

Concur.

"Hey, give me all your information so we can spam your inbox for the rest of time, then you can find out that we're (probably) 90% aftermarket stuff, and almost never, if ever, have any...
Forum: S-Series Tech 08-28-2019, 03:32 PM
Replies: 8
Views: 424
Posted By Keblar
Re: Serpentine Pulley Questions

Just to add my recent experience to this thread:

Last moth I installed a full Gates Kit that I sourced from Rock Auto - Tensioner, Pulley and belt for system with AC compressor. The price was...
Forum: S-Series Tech 08-25-2019, 08:04 PM
Replies: 15
Views: 549
Posted By Keblar
Re: 880 vs 893 Fog Light Bulbs or Something else?

Replaced bulbs. Nothing.

Switch does nothing.

Swapped horn and fog relays. Fog lights on, but won't turn off.
But horn still works.

Swapped Relays back... Same thing. Fogs are now on, but...
Forum: S-Series Mods 08-23-2019, 11:43 PM
Replies: 7
Views: 789
Posted By Keblar
Re: Masking Tape for handling HIR bulb for 9011 mod? Necessary?

Cannibalize a glove. Damn, that's a great idea!




I wound up buying a whole round of bulbs for both vehicles from RA, and got a mix of brands to try out some side by side.
Forum: S-Series Mods 08-23-2019, 05:25 PM
Replies: 7
Views: 789
Posted By Keblar
Masking Tape for handling HIR bulb for 9011 mod? Necessary?

I'm doing the 9011 9012 Bulb modification and was wondering if it's safe to mask off the bulb with blue painters tape while I cut away with a Dremel.

Anyone know if this will damage bulb?

Or,...
Forum: S-Series Tech 08-22-2019, 06:04 PM
Replies: 9
Views: 290
Posted By Keblar
Re: Wheel cylinders

Correction #2 for me:

I double checked and mine were actually AC Delco, not Wagner.
...
Showing results 1 to 25 of 145

 
Forum Jump

All times are GMT -4. The time now is 12:38 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.