SaturnFans.com
saturnfans.com - classifieds - forums - webmail


Go Back   SaturnFans.com Forums > Search Forums

Showing results 1 to 25 of 50
Search took 0.02 seconds.
Search: Posts Made By: 1999saturnsl
Forum: S-Series General 02-09-2021, 02:22 PM
Replies: 2,158
Views: 342,311
Posted By 1999saturnsl
Re: Saturn Craigslist Deal of the Day!

Ehunter can you post pictures of the 96?
Forum: S-Series General 11-09-2020, 03:02 PM
Replies: 9
Views: 322
Posted By 1999saturnsl
Re: Hit a tree, condenser damage to 99 SL1

I installed a used radiator from the junkyard, and filled up the coolant again. No leak! Drives like new. Thanks yall, you're the best
Forum: S-Series General 11-09-2020, 11:43 AM
Replies: 9
Views: 322
Posted By 1999saturnsl
Re: Hit a tree, condenser damage to 99 SL1

I took out the ac condenser and disconnected the electrical switch to the compressor. Now i have these two lines dangling here that used to go to the condenser. One is attached to the ac compressor...
Forum: S-Series General 11-09-2020, 09:48 AM
Replies: 9
Views: 322
Posted By 1999saturnsl
Re: Hit a tree, condenser damage to 99 SL1

Thank you so much for all the info! I am going to replace the radiator here shortly and see what that does to the leak situation. Out of curiosity, if I took out the ac condenser, what would I do...
Forum: S-Series General 11-08-2020, 12:49 PM
Replies: 9
Views: 322
Posted By 1999saturnsl
Hit a tree, condenser damage to 99 SL1

So I had an accident last week and ran into a tree at about 35 mph. Car still drives, but there is a pretty quick coolant leak that I don't want to go anywhere with.
Looking at the front...
Forum: S-Series General 07-27-2018, 05:08 PM
Replies: 8
Views: 556
Posted By 1999saturnsl
Re: Scraping noise in 99 sl engine

Brought a more mechanically-aligned friend over, who said the tensioner was out of place, lower than it should be. Suggested replacement. Thoughts?
Forum: S-Series General 06-21-2018, 03:34 PM
Replies: 8
Views: 556
Posted By 1999saturnsl
Re: Scraping noise in 99 sl engine

Yes, I turned the blue one
Forum: S-Series General 06-19-2018, 01:17 PM
Replies: 8
Views: 556
Posted By 1999saturnsl
Re: Scraping noise in 99 sl engine

I just gave it a couple twists of a ratchet, as I thought that was the thing to do..is that not suggested?
Forum: S-Series General 06-19-2018, 11:38 AM
Replies: 8
Views: 556
Posted By 1999saturnsl
Scraping noise in 99 sl engine

Hey y'all,
I tightened up the tensioner and replaced the water pump last week, and now I've got this metal scraping noise in my engine. Real bad when I start up, and sometimes shows up again at...
Forum: S-Series General 06-19-2018, 11:32 AM
Replies: 11
Views: 501
Posted By 1999saturnsl
Re: Coolant leak in 99 SL

Used a strap wrench, got a New Water Pump on. $35 in all thx yall
Forum: S-Series General 06-12-2018, 11:50 AM
Replies: 11
Views: 501
Posted By 1999saturnsl
Re: Coolant leak in 99 SL

Alright I got the pump and pulley off, replaced with a new one. Now screwing in the pulley again, and one of the bolts disappeared. Can i use a generic 10mm bolt? Thank you everyone for your help
Forum: S-Series General 06-09-2018, 04:42 AM
Replies: 11
Views: 501
Posted By 1999saturnsl
Re: Coolant leak in 99 SL

Haven't got impact tools or a prybar...any other way to keep the water pump pulley from spinning?
Forum: S-Series General 06-08-2018, 03:28 PM
Replies: 11
Views: 501
Posted By 1999saturnsl
Re: Coolant leak in 99 SL

The issue is, I can't see the source of the leak from any angle. Should I remove the water pump?
Forum: S-Series General 06-07-2018, 05:51 PM
Replies: 11
Views: 501
Posted By 1999saturnsl
Coolant leak in 99 SL

Coolant leak has been getting much worse, almost a liter a minute. Sometimes leaks onto s belt and makes a whirring noise. How to find source of leak?
Forum: S-Series Tech 04-26-2018, 11:17 PM
Replies: 7
Views: 462
Posted By 1999saturnsl
Re: 99 SL click, no start

So a jump started the car for about two minutes. Died while driving and exhibiting electrical symptoms (speedometer and rpm shorting out). The S belt was loose, so I pulled it back over the tensioner...
Forum: S-Series Tech 04-26-2018, 01:25 PM
Replies: 7
Views: 462
Posted By 1999saturnsl
Re: 99 SL click, no start

I am operating on a thin budget. Would an attempt to use booster cables signal to me the battery's condition?
Forum: S-Series Tech 04-26-2018, 02:20 AM
Replies: 7
Views: 462
Posted By 1999saturnsl
99 SL click, no start

Baby was actin weird on the way to work, rpm and speedometer shorting out. engine coughed a few times. Low on coolant. This evening tried to start her back up and i got a crank and then a click....
Forum: S-Series Tech 01-04-2017, 10:35 AM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Re: Crank! But no start...

So a mechanic replaced the crank sensor and apparently the car starts now. Going to pick it up tomorrow. How on earth did this not work when I did it?
Forum: S-Series Tech 12-29-2016, 03:19 PM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Re: Crank! But no start...

I can take pictures!
Forum: S-Series Tech 12-29-2016, 02:46 PM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Re: Crank! But no start...

I'm not sure I trust my one electricity class at N.C. State to have prepared me for this task. I am attempting to get my hands on a noid light. Is there a specific light for Saturn, or for GM, that I...
Forum: S-Series Tech 12-29-2016, 02:38 PM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Re: Crank! But no start...

Is there a richpin video for this? I can't seem to pick up any voltage or resistance for these wires. I might just go get a noid light if they are that much easier to use
Forum: S-Series Tech 12-28-2016, 11:39 PM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Re: Crank! But no start...

So my electricals are a complete no-go...what should I do fuel-wise? I don't think my injectors are firing, but how can I confirm this?
Forum: S-Series Tech 12-28-2016, 11:32 PM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Forum: S-Series Tech 12-28-2016, 11:00 PM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Re: Crank! But no start...

the pump definitely comes on at "key-on" but beyond that all I hear is crank. Do I need to have the ignition coils bolted in for this? I've heard rumors of these mounting bolts serving as grounds of...
Forum: S-Series Tech 12-28-2016, 08:55 PM
Replies: 65
Views: 2,452
Posted By 1999saturnsl
Re: Crank! But no start...

Alright, I have crank again. I charged the battery, and repositioned the Crank Sensor(desperation move), and now my fuel pump is humming! No spark across either coil though. I have replaced the...
Showing results 1 to 25 of 50

 
Forum Jump

All times are GMT -4. The time now is 11:40 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.
SaturnFans.com. The Saturn Enthusiasts Site.