SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 04-25-2007, 08:45 AM   #1
jims95sl2
New Member
jims95sl2 is on a distinguished road
 
Join Date: Apr 2007
Posts: 2
Default Bad alternator?

I was wondering if someone could confirm that a bad alternator could affect the shifting of the transmission on my 1995 Saturn SL2?

When I came to a stop yesterday, it felt like the transmission shifted up. This proved out when I tried to accelerate. At the same time the speedometer did not move and it appeared as though I was running off the battery (no fan, dimmed lights, etc).

I restarted it this morning and the generator light is on now and the transmission shifts hard into reverse and it still feels like it is in 3rd gear.

This would make sense to me as being just an alternator problem if it weren't for the weird speedometer and transmission symptoms.

Please let me know if this is normal. My background is mainly in old Chevys where no electronics were involved at all in the transmission.

Thanks,
Jim

REWARD EXCELLENCE!

Add to jims95sl2's Reputation
Rate the quality of this post and help jims95sl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jims95sl2 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 04-25-2007, 09:24 AM   #2
1994Saturn
Senior Member
1994Saturn will become famous soon enough
 
1994Saturn's Avatar
 
Join Date: Sep 2006
Location: New York. Upstate.
Posts: 1,762

1994 SL2
1994 SL1
Happy Re: Bad alternator?

Quote:
Originally Posted by jims95sl2 View Post
I was wondering if someone could confirm that a bad alternator could affect the shifting of the transmission on my 1995 Saturn SL2?

When I came to a stop yesterday, it felt like the transmission shifted up. This proved out when I tried to accelerate. At the same time the speedometer did not move and it appeared as though I was running off the battery (no fan, dimmed lights, etc).

I restarted it this morning and the generator light is on now and the transmission shifts hard into reverse and it still feels like it is in 3rd gear.

This would make sense to me as being just an alternator problem if it weren't for the weird speedometer and transmission symptoms.

Please let me know if this is normal. My background is mainly in old Chevys where no electronics were involved at all in the transmission.

Thanks,
Jim

Sounds like a bad alt to me, Have it tested, also the battery too..

...
Current:
1998 SL2 Auto issues 112K
1995 Eagle Vision 3.5L TSI 117K
Past:
98 SL1 254k miles Valves Burnt.
94 SL2 125K miles Diff Pin Blew!
94 SL1 Sold @134K.

REWARD EXCELLENCE!

Add to 1994Saturn's Reputation
Rate the quality of this post and help 1994Saturn reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
1994Saturn is offline   Reply With Quote
Old 04-25-2007, 09:36 AM   #3
Gerry Proctor
Master Member
Gerry Proctor has a spectacular aura aboutGerry Proctor has a spectacular aura about
 
Join Date: Oct 2002
Location: San Antonio, Texas
Posts: 2,683

2008 Astra XR
2008 SKY Red Line
Default Re: Bad alternator?

Funky auto transmission behavior is one of the clues of a faulty alternator, even if the alt light doesn't come on. The trans is very sensitive to the phase output.

REWARD EXCELLENCE!

Add to Gerry Proctor's Reputation
Rate the quality of this post and help Gerry Proctor reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Gerry Proctor is offline   Reply With Quote
Old 04-25-2007, 04:18 PM   #4
jims95sl2
New Member
jims95sl2 is on a distinguished road
 
Join Date: Apr 2007
Posts: 2
Default Re: Bad alternator?

Thanks guys. I replaced the alternator and it is back to normal now.

REWARD EXCELLENCE!

Add to jims95sl2's Reputation
Rate the quality of this post and help jims95sl2 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jims95sl2 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
what do you think, bad alternator? vegasdude S-Series Tech 4 03-31-2008 05:57 PM
bad alternator? xupthree60 S-Series General 1 11-09-2006 07:29 AM
alternator bad?? 94SW2 S-Series Tech 2 01-16-2006 12:51 PM
bad alternator?? need help.. PlumSL1 S-Series Tech 2 10-09-2005 11:51 AM
Think I got a bad alternator Phil S-Series Tech 6 06-23-2001 11:22 AM


All times are GMT -5. The time now is 11:56 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.