SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn L-Series > L-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-18-2006, 02:43 PM   #1
L300Boy
Master Member
L300Boy is on a distinguished road
 
L300Boy's Avatar
 
Join Date: Jul 2001
Location: Puyallup, WA
Posts: 4,249
 
Dizzy Stock radio died?! Some functions still work?!

Hey,

I have a 2001 L300, 130k miles, stock premium sound radio/CD deck. This is not the 6 disc changer version.

I was listening to the radio on the freeway last week, and it just went out. It didnt pop or anything. I thought the station was having technical problems.

I cannot turn it on, but the clock still shows the time, the RCL button makes the display light briefly, and I can eject the disc. Headlights do not turn on the backlight. Its acting as if i didnt even have the keys in the ignition.

Over the last couple of days, when i pressed the RCL button, the backlight has become dimmer and dimmer. Now, the backlight does not even come on anymore. It still keeps the time.

I checked the radio fuse in the engine compartment, and it looked good. I even swapped it out with another. I have noticed no other changes in car behavior or electrical systems.

Any ideas?

REWARD EXCELLENCE!

Add to L300Boy's Reputation
Rate the quality of this post and help L300Boy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
L300Boy is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-18-2006, 08:43 PM   #2
mattcav1
New Member
mattcav1 is on a distinguished road
 
Join Date: Sep 2006
Posts: 3
Default Re: Stock radio died?! Some functions still work?!

It is a fuse mine did this there is a second set of fuses in the car in the front quarter there is a plastic door that comes off i cant remember if it is on pass or drivers side. Check there. I did the same thing you did and then took it to the dealer that told me about the second pannels.

REWARD EXCELLENCE!

Add to mattcav1's Reputation
Rate the quality of this post and help mattcav1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
mattcav1 is offline   Reply With Quote
Old 09-19-2006, 08:22 AM   #3
tackepj
Senior Member
tackepj will become famous soon enough
 
tackepj's Avatar
 
Join Date: Nov 2004
Location: West Lafayette, IN
Posts: 1,206
 

2008 Astra XE
Default Re: Stock radio died?! Some functions still work?!

Agree that it's probably a fuse. There are two power sources to the radio, one that is constant (to power the clock, eject CDs, etc when the radio power is off) and one is switched. Sounds like the switched power fuse blew.

REWARD EXCELLENCE!

Add to tackepj's Reputation
Rate the quality of this post and help tackepj reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tackepj is offline   Reply With Quote
Old 09-19-2006, 11:19 AM   #4
L300Boy
Master Member
L300Boy is on a distinguished road
 
L300Boy's Avatar
 
Join Date: Jul 2001
Location: Puyallup, WA
Posts: 4,249
 
Default Re: Stock radio died?! Some functions still work?!

!!!
I knew there had to be two power sources to the radio

Thanks, i'll break off the panels and take a look.

REWARD EXCELLENCE!

Add to L300Boy's Reputation
Rate the quality of this post and help L300Boy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
L300Boy is offline   Reply With Quote
Old 09-21-2006, 05:52 PM   #5
L300Boy
Master Member
L300Boy is on a distinguished road
 
L300Boy's Avatar
 
Join Date: Jul 2001
Location: Puyallup, WA
Posts: 4,249
 
Default Re: Stock radio died?! Some functions still work?!

I still have problems.

I checked the fuse under the hood, the fuse for the "radio" on the passenger side, and the "premium amp" fuse on the right passenger side. All fuses look good... i even replaced them just in case.

I even pulled the digital clock fuse and gave the radio a nice hard reset by pulling every fuse out for a short time. Still, no luck.

Any other ideas?

Slightly off topic, but i got a kick out of the ECM/electric mirror fuse. No wonder the L series has so many bizzare electrical problems and ECM burnouts.

REWARD EXCELLENCE!

Add to L300Boy's Reputation
Rate the quality of this post and help L300Boy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
L300Boy is offline   Reply With Quote
Old 09-22-2006, 07:37 AM   #6
tackepj
Senior Member
tackepj will become famous soon enough
 
tackepj's Avatar
 
Join Date: Nov 2004
Location: West Lafayette, IN
Posts: 1,206
 

2008 Astra XE
Default Re: Stock radio died?! Some functions still work?!

Quote:
Originally Posted by L300Boy
Slightly off topic, but i got a kick out of the ECM/electric mirror fuse. No wonder the L series has so many bizzare electrical problems and ECM burnouts.
Haha...interesting combination. Is it right next to the BCM / power seat fuse?

Not sure what else you could try with the radio. I know some aftermarket units have an inline fuse (usually a cylinder type) wired directly behind the radio. Some radios themselves are fused at the unit, too--usually a small blade fuse at the rear of the unit. Not sure about the AAS radio, though.

I would try two things: First, I would pull the battery cable and do a hard reset on the whole car / computer. I think after about 30 minutes or so from disconnection it completely resets. With the flaky BCMs on these cars, it's hard to pinpoint electrical system problems.

If that doesn't change anything, I would pull the radio and check the head unit for power using a multimeter. The harness probably isn't labelled wire-by-wire, but you may be able to find a pinout diagram on the internet. Either way, you should find 2 12VDC sources somewhere. Typically, aftermarket radios use a white wire for ignition power (switched), and a red wire for constant power. Make sure you have a good ground when testing. If you see 12VDC at both with the key in the accessory position, it's probably the radio itself.

FYI--the radio is quite easy to pull. Just pop the fake wood trim off around the center stack using your fingers, and the radio mount screws are right there in front of you.

Let us know how it goes...

REWARD EXCELLENCE!

Add to tackepj's Reputation
Rate the quality of this post and help tackepj reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tackepj is offline   Reply With Quote
Old 11-19-2006, 02:58 PM   #7
L300Boy
Master Member
L300Boy is on a distinguished road
 
L300Boy's Avatar
 
Join Date: Jul 2001
Location: Puyallup, WA
Posts: 4,249
 
Default Re: Stock radio died?! Some functions still work?!

With the connector facing you, i have determined the bottom left pin is 12VDC and the one directly next to it is accessory switched 12VDC. It seems like the radio is receiving the proper power it needs.

I popped both the top and bottom plate (very easy to remove) of the radio just to see if there was a fuse, and I did not see one off hand. If there is one in there, it is not user servicable.

Here's the fun part of this all. I noticed something rattling in the radio ... i finally shook it out -- it was a canadian dime. It is possible that a kid put this into the CD slot, it fell into the radio, and shorted out a critical
component. Or maybe, this happened a long time ago and the radio just died.

Who knows.

REWARD EXCELLENCE!

Add to L300Boy's Reputation
Rate the quality of this post and help L300Boy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
L300Boy is offline   Reply With Quote
Old 11-20-2006, 08:45 AM   #8
tackepj
Senior Member
tackepj will become famous soon enough
 
tackepj's Avatar
 
Join Date: Nov 2004
Location: West Lafayette, IN
Posts: 1,206
 

2008 Astra XE
Default Re: Stock radio died?! Some functions still work?!

Quote:
Originally Posted by L300Boy
With the connector facing you, i have determined the bottom left pin is 12VDC and the one directly next to it is accessory switched 12VDC. It seems like the radio is receiving the proper power it needs.

I popped both the top and bottom plate (very easy to remove) of the radio just to see if there was a fuse, and I did not see one off hand. If there is one in there, it is not user servicable.

Here's the fun part of this all. I noticed something rattling in the radio ... i finally shook it out -- it was a canadian dime. It is possible that a kid put this into the CD slot, it fell into the radio, and shorted out a critical
component. Or maybe, this happened a long time ago and the radio just died.

Who knows.
Sounds like the radio is toast. Were you riding with someone who thought your radio was a jukebox?

REWARD EXCELLENCE!

Add to tackepj's Reputation
Rate the quality of this post and help tackepj reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
tackepj is offline   Reply With Quote
Old 11-20-2006, 01:00 PM   #9
beensmoked
Senior Member
beensmoked will become famous soon enough
 
Join Date: Sep 2004
Location: Long Island, NY
Posts: 1,340

2001 L-Series 3.0L Sedan
2002 L-Series 2.2L Sedan
Default Re: Stock radio died?! Some functions still work?!

you can easily find a 6 Disc OEM change on ebay for under a 100. i did and haven't had a problem yet.

REWARD EXCELLENCE!

Add to beensmoked's Reputation
Rate the quality of this post and help beensmoked reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
beensmoked is offline   Reply With Quote
Old 11-24-2006, 11:33 PM   #10
L300Boy
Master Member
L300Boy is on a distinguished road
 
L300Boy's Avatar
 
Join Date: Jul 2001
Location: Puyallup, WA
Posts: 4,249
 
Default Re: Stock radio died?! Some functions still work?!

That would definately be a good option .. especially a 6 disc.. would be an upgrade at the fraction of an aftermarket replacement. Does the newer 6 disc have higher wattage output or anything nicer about it?

REWARD EXCELLENCE!

Add to L300Boy's Reputation
Rate the quality of this post and help L300Boy reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
L300Boy is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Day the music (and my radio) died - 2004 Saturn Ion 2 Chocolaterice Ion Tech 3 02-01-2009 09:28 AM
Can I replace my 01 SL1 CD/Radio with a newer GM Stock radio? SuperCujo S-Series General 46 01-27-2009 09:13 PM
Radio works fine, CD player died? guitar_stitch Vue General 22 10-29-2007 11:35 PM
Reinstalling Stock Radio doesn't work Why? violet12877 S-Series Tech 17 04-10-2007 05:12 PM
Removed Radio -> Car died ? Phonespider S-Series General 7 06-28-2005 06:32 PM


All times are GMT -5. The time now is 11:28 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.