SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-29-2006, 07:29 PM   #1
hammand
Junior Member
hammand is on a distinguished road
 
Join Date: May 2006
Posts: 16

1995 SC2
Default No Tach, speedo or engine temp

Can anybody tell me which fuse controls these items ?
Which fuse box ?

1995 sc2, just completed auto to manual swap.

REWARD EXCELLENCE!

Add to hammand's Reputation
Rate the quality of this post and help hammand reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
hammand is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-29-2006, 10:08 PM   #2
madpogue
Super Member
madpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud ofmadpogue has much to be proud of
 
Join Date: Sep 2004
Location: Madison, WI USA
Posts: 25,713
 

1996 SW2
Default Re: No Tach, speedo or engine temp

Um, all fuses in both fuse boxes are marked, and the owner's manual provides more detail. Anyway, check the IGN 1 fuse in the IP box.

REWARD EXCELLENCE!

Add to madpogue's Reputation
Rate the quality of this post and help madpogue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
madpogue is offline   Reply With Quote
Old 08-29-2006, 10:33 PM   #3
dave.sl
Advanced Member
dave.sl has a spectacular aura aboutdave.sl has a spectacular aura about
 
Join Date: May 2004
Posts: 526
Default Re: No Tach, speedo or engine temp

I can't recall the fuse data, but as posted above it is all in the manual. I had the same issue last year on my 98SL and it ended up being a bad instrument cluster. Had it replaced with a used one and it has been fine. My fuses all checked out good. A few of the cluster lights went out too, but I don't remember which ones.

REWARD EXCELLENCE!

Add to dave.sl's Reputation
Rate the quality of this post and help dave.sl reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
dave.sl is offline   Reply With Quote
Old 08-29-2006, 10:37 PM   #4
hammand
Junior Member
hammand is on a distinguished road
 
Join Date: May 2006
Posts: 16

1995 SC2
Default Re: No Tach, speedo or engine temp

Thanks, worked like a charm.

REWARD EXCELLENCE!

Add to hammand's Reputation
Rate the quality of this post and help hammand reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
hammand is offline   Reply With Quote
Old 09-05-2006, 06:37 PM   #5
charcoal
Member
charcoal is on a distinguished road
 
Join Date: Nov 2005
Location: Kansas
Posts: 303

1993 SC2
Default Re: No Tach, speedo or engine temp

I have the same problem on my '93 SC2.

Ok, so its the I/P...so what shorts?
anybody got a pinout or schematic?

It seems to me that the four D'Arsonval type meters on the I/P are just simple meters and that the odometers (trip and total accumulation) are watch-motor type actuated and I would suspect them to be more prone to short than a meter movement.

Can anybody shed more light on this?

Thanks in advance!

...
MAD works!

REWARD EXCELLENCE!

Add to charcoal's Reputation
Rate the quality of this post and help charcoal reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
charcoal is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedo/Tach issues Keeter S-Series Tech 1 10-11-2009 05:11 PM
has anyone swapped the speedo with the tach Tom S2 Astra General 8 06-27-2009 09:17 PM
Speedo & Tach "Strange" behaviour? surprisinguy S-Series Tech 0 06-15-2009 10:04 AM
Information Center (DIC) Engine temp or Coolant Temp ? Astrafirstsatur Astra Tech 10 02-16-2009 08:10 AM
HELP!!! Tach / Engine Problems!!! Still need someone to help!!! Lizzy S-Series Tech 10 05-02-2006 09:15 PM


All times are GMT -5. The time now is 02:44 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.