SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 11-16-2005, 07:31 PM   #1
shaner123
Member
shaner123 is on a distinguished road
 
shaner123's Avatar
 
Join Date: Sep 2005
Location: Windsor, Ontario - kinda
Posts: 293
 

2001 SL
Default idle & vent problem?? makin me crazy!!

hi, if you guys goto automotiveforums ive posted a simular thread, but thought id get more responces here...

if your like me and have an intermittant mistery high idle around 1700RPM well i think i have it narrowed down to the A/C condensor..

i dont think its the condensor itself, but whenever my A/C is on, or my front window vents, i SOMETIMES, get a high idle, its still intermittant so its not a normail RPM jump to compensate for the increased load on the engine... because most of the time its idles normally 700ish with the A/C condensor running.. but i still have the intermittant jump that only occours if the A/C condensor is on.

When my idle jumps up, i couldnt get it to go down without turning off the car but if i turn my dial to face or floor vents, sometimes this will make the idle go down...

so i guess my question is, is there some sort of sensor malfunctioning and reving the car up too high from time to time, and overcompensating for the increased load ?? if so which one is it?

also, my vents are always soooo weak, it sounds like there is a hurricane blowing through my car, but hardly anything comes out of the vent! it sucks, my moms cavalier is like 5 times more powerful and quieter!! so i think this is a seperate problem.. well it is.. but it kinda goes with my a/c condensor problem

im really getting annoyed, ive had these problems since i got my car a few mts ago and the saturn dealer kept telling me that it was all normal, but if this is normal, than theres somthing wrong with saturns.. but i know that its not normal.. they just screwed me out of fixing it when i actually had a warranty, which i dont have anymore..

thanks so much for anyhelp, many headaches latly cuz of this poop

- shaner

2001 SL 5spd 1.9L ohc

REWARD EXCELLENCE!

Add to shaner123's Reputation
Rate the quality of this post and help shaner123 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
shaner123 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 11-16-2005, 11:22 PM   #2
JerryHughes
Master Member
JerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of light
 
JerryHughes's Avatar
 
Join Date: Jan 2005
Location: None
Posts: 4,016
 

1997 SL
Default Re: idle & vent problem?? makin me crazy!!

Welcome! For one of the cheapest fixes that I'd try first, to fix the high idle, is to spray carb. cleaner into the throttle body area to clean it out. If you disconnect the large plastic intake that leads to the throttle body and see a lot of black soot inside the throttle body and valve area---that's probably the problem. When you do spray the area out, make sure you spray clean the IAC. It's in the small hole in the bottom of the throttle body area, just before the valve. Clean it well and then see if there is a difference in the high idle. If no difference, clean it again. Some on this board recommend taking the throttle body completely off but I've had good luck with simply spray cleaning it while on the car. You can check the "How To" section on this site for more directions. Good luck,

Jerry

REWARD EXCELLENCE!

Add to JerryHughes's Reputation
Rate the quality of this post and help JerryHughes reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
JerryHughes is offline   Reply With Quote
Old 11-16-2005, 11:36 PM   #3
shaner123
Member
shaner123 is on a distinguished road
 
shaner123's Avatar
 
Join Date: Sep 2005
Location: Windsor, Ontario - kinda
Posts: 293
 

2001 SL
Default Re: idle & vent problem?? makin me crazy!!

thanks for the quick reply, but i forgot to mention that i have cleaned all that stuff out, EGR, IAC, TB, etc, i also have a new PCV, no change : (

REWARD EXCELLENCE!

Add to shaner123's Reputation
Rate the quality of this post and help shaner123 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
shaner123 is offline   Reply With Quote
Old 11-17-2005, 01:41 PM   #4
JerryHughes
Master Member
JerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of light
 
JerryHughes's Avatar
 
Join Date: Jan 2005
Location: None
Posts: 4,016
 

1997 SL
Default Re: idle & vent problem?? makin me crazy!!

Quote:
Originally Posted by shaner123
thanks for the quick reply, but i forgot to mention that i have cleaned all that stuff out, EGR, IAC, TB, etc, i also have a new PCV, no change : (
Check for vacumn leaks????

Jerry

REWARD EXCELLENCE!

Add to JerryHughes's Reputation
Rate the quality of this post and help JerryHughes reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
JerryHughes is offline   Reply With Quote
Old 11-17-2005, 01:47 PM   #5
shaner123
Member
shaner123 is on a distinguished road
 
shaner123's Avatar
 
Join Date: Sep 2005
Location: Windsor, Ontario - kinda
Posts: 293
 

2001 SL
Default Re: idle & vent problem?? makin me crazy!!

ya, none found.. spreay carb cleaner around my engine head seal and nothing,, besides i think its not that because would there be in intermittant vaccuum leak?

REWARD EXCELLENCE!

Add to shaner123's Reputation
Rate the quality of this post and help shaner123 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
shaner123 is offline   Reply With Quote
Old 11-17-2005, 01:56 PM   #6
JerryHughes
Master Member
JerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of light
 
JerryHughes's Avatar
 
Join Date: Jan 2005
Location: None
Posts: 4,016
 

1997 SL
Default Re: idle & vent problem?? makin me crazy!!

Quote:
Originally Posted by shaner123
ya, none found.. spreay carb cleaner around my engine head seal and nothing,, besides i think its not that because would there be in intermittant vaccuum leak?
Spray all around the hoses, PCV hose, etc.? If no leak, ya got me stumped. Have you searched through the library for this problem? Others have found various solutions to your problem and that may help you. Good luck,

Jerry

REWARD EXCELLENCE!

Add to JerryHughes's Reputation
Rate the quality of this post and help JerryHughes reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
JerryHughes is offline   Reply With Quote
Old 11-17-2005, 01:59 PM   #7
JS593
Senior Member
JS593 is on a distinguished road
 
JS593's Avatar
 
Join Date: Aug 2005
Posts: 1,531
 

1992 SL1
Default Re: idle & vent problem?? makin me crazy!!

Did you check your MAP sensor...? Thats usually a comon issue with domestic cars.

...
92 SL1 SOHC TBI
Custom intake
Alpine deck, speakers, amp
JBL Sub
Ultimate amp
Volometer gauge mounted in dash
Magnaflow exhaust
....DEAD.... Car towed away Jan 18 2007. RIP

REWARD EXCELLENCE!

Add to JS593's Reputation
Rate the quality of this post and help JS593 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
JS593 is offline   Reply With Quote
Old 11-17-2005, 02:02 PM   #8
JerryHughes
Master Member
JerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of lightJerryHughes is a glorious beacon of light
 
JerryHughes's Avatar
 
Join Date: Jan 2005
Location: None
Posts: 4,016
 

1997 SL
Default Re: idle & vent problem?? makin me crazy!!

Quote:
Originally Posted by JS593
Did you check your MAP sensor...? Thats usually a comon issue with domestic cars.
Not to get off on another subject here but JS, did you ever figure your gas mileage? What'd it turn out to be?

Jerry

REWARD EXCELLENCE!

Add to JerryHughes's Reputation
Rate the quality of this post and help JerryHughes reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
JerryHughes is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle Stutter & Cold Start Problem rjnewt S-Series Tech 7 01-24-2008 09:55 AM
crazy idle!! opus S-Series Tech 5 01-02-2008 11:13 PM
'99 SC1 misfire & high idle problem solved nwmike S-Series Tech 2 12-13-2006 04:10 AM
Crazy High Idle... Bertillion Ion General 26 05-18-2006 08:18 PM
High idle then crazy bucking and jerking 98greenSC2 S-Series Tech 14 01-06-2006 12:03 AM


All times are GMT -4. The time now is 06:48 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.