SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-21-2005, 09:54 PM   #1
Paulapoohcarr
New Member
Paulapoohcarr is on a distinguished road
 
Join Date: Sep 2005
Posts: 4
Question Starts but won't stay running

I'm having major issues with this Saturn SL2. We have spent 800.00 on getting this car to stay running. The O2 sensor was replaced first. The car would run and able to drive for 4 days, then it would start and die out. We sprayed starter fluid in the throttle and it would start and stay running. We replaced the fuel pressure regulator, the fuel pump was pressured at 40 so we changed it even though it was only a year old. The flex pipe was bad and muffler so that was replaced also. The s belt has been replaced. The throttle was cleaned out. The final part was the EGR valve. Please help me

REWARD EXCELLENCE!

Add to Paulapoohcarr's Reputation
Rate the quality of this post and help Paulapoohcarr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Paulapoohcarr is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-21-2005, 10:04 PM   #2
WingsOfSaturn
Senior Member
WingsOfSaturn will become famous soon enoughWingsOfSaturn will become famous soon enough
 
WingsOfSaturn's Avatar
 
Join Date: Jul 2005
Location: Northern Virginia
Posts: 1,606
 

1998 SL2
1995 SL2
Default Re: Starts but won't stay running

What is the year/mileage of your SL2? Sounds like the fuel filter, maybe some more advanced members can give better advice. Side note: stay away from starter fluid.

...
"When you stop to fill up on oil, don't forget to check the gas"
98 SL2 MT 213K+ Daily Driver 38+ mpg
97 SL2 AT 150K Original Owner
95 SL2 MT 220K+
My Saturns have BRASS ones!

REWARD EXCELLENCE!

Add to WingsOfSaturn's Reputation
Rate the quality of this post and help WingsOfSaturn reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
WingsOfSaturn is offline   Reply With Quote
Old 09-21-2005, 10:38 PM   #3
RalliArt16
Senior Member
RalliArt16 is on a distinguished road
 
RalliArt16's Avatar
 
Join Date: Dec 2004
Location: Orlando, FL
Posts: 1,418
 

1996 SC1
1995 SC2
Default Re: Starts but won't stay running

Quote:
Originally Posted by romzek
What is the year/mileage of your SL2? Sounds like the fuel filter, maybe some more advanced members can give better advice. Side note: stay away from starter fluid.
Not to hijack the thread, but what is so bad about starter fluid? I've never used it myself nor plan to, but curious as to its negative effects.

REWARD EXCELLENCE!

Add to RalliArt16's Reputation
Rate the quality of this post and help RalliArt16 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
RalliArt16 is offline   Reply With Quote
Old 09-22-2005, 09:14 AM   #4
sps SOHC
Master Member
sps SOHC is on a distinguished road
 
sps SOHC's Avatar
 
Join Date: Dec 2002
Location: Gainesville, FL
Posts: 4,047
 

1996 SC2
Default Re: Starts but won't stay running

ECTS maybe? SEARCH!

...
-96 SC2 gets 35 mpg mix city/hw.

REWARD EXCELLENCE!

Add to sps SOHC's Reputation
Rate the quality of this post and help sps SOHC reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
sps SOHC is offline   Reply With Quote
Old 09-23-2005, 10:57 AM   #5
Paulapoohcarr
New Member
Paulapoohcarr is on a distinguished road
 
Join Date: Sep 2005
Posts: 4
Default Re: Starts but won't stay running

It is a 1991 it has 188,000 miles. The fuel filter was replaced last year when the fuel pump was replaced.

REWARD EXCELLENCE!

Add to Paulapoohcarr's Reputation
Rate the quality of this post and help Paulapoohcarr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Paulapoohcarr is offline   Reply With Quote
Old 09-23-2005, 12:39 PM   #6
BarnOwl
Super Member
BarnOwl is just really niceBarnOwl is just really niceBarnOwl is just really niceBarnOwl is just really nice
 
BarnOwl's Avatar
 
Join Date: May 2005
Location: Hickory, NC
Posts: 10,015
 

2000 SW2
1998 SL2
Default Re: Starts but won't stay running

I think to provide any better answers we need more info:

Is the SES light on? If so, what codes are being generated?

When the car dies, is it like you turned off the key or more like a sputtering death?

When it dies, does it die hot?

Can you restart it once it cools down?

When you get it started, does it smoke a lot?

Can you get a smell of gasoline when you're behind the car when it's running?

How's your mileage been lately?

...
There is nothing more frightening than ignorance in action.

REWARD EXCELLENCE!

Add to BarnOwl's Reputation
Rate the quality of this post and help BarnOwl reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
BarnOwl is offline   Reply With Quote
Old 09-23-2005, 06:16 PM   #7
Paulapoohcarr
New Member
Paulapoohcarr is on a distinguished road
 
Join Date: Sep 2005
Posts: 4
Default Re: Starts but won't stay running

Quote:
Originally Posted by BarnOwl
I think to provide any better answers we need more info:

Is the SES light on? If so, what codes are being generated?

When the car dies, is it like you turned off the key or more like a sputtering death?

When it dies, does it die hot?

Can you restart it once it cools down?

When you get it started, does it smoke a lot?

Can you get a smell of gasoline when you're behind the car when it's running?

How's your mileage been lately?

No lights coming on or I should say staying on. It starts and runs for about 5 seconds and sputters out, sometimes backs fire from intake. The car will restart every time. It doesn't die hot it, it does it whenever you try to start it. No smoke, no smell of gasoline. The mileage has been pretty good. The codes I got was a 45, 22, and 32. The last time I was driving the car it died out after driving it for about 30 minutes. We haven't been able to get it to keep running since. The fuel filter and fuel pump was replaced last year. The fuel pump pressure is 40 psi, so the pump was just changed again and it still says 40 psi.

REWARD EXCELLENCE!

Add to Paulapoohcarr's Reputation
Rate the quality of this post and help Paulapoohcarr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Paulapoohcarr is offline   Reply With Quote
Old 09-23-2005, 06:40 PM   #8
classic_racer
New Member
classic_racer is on a distinguished road
 
Join Date: Sep 2005
Location: Ogden, Utah
Posts: 2
Default Re: Starts but won't stay running

Okay, first off starter fluid id only bad in deisel motors because the glow plugs can egnite the fluid prematurely and because there is no air restriction on the motor so you can overrev very easily and blow something up, it is near impossible to do such with a gas motor, other than that it is very safe.

Onto diagnosis, you need to test your pressure again, but this time you need to test your VOLUME, it isn't a common test but you can have it done, your pressure can be good (40 is just right for your car I have the same motor and mine sits right at 40) and your flow can be bad. If your flow is bad, it is usually only one of three things, a pinched fuel line, a bad fuel pump, or a bad fuel filter, sorry to say it but you might have gotten a bad pump. I would check the lines first, then get a new filter and then see about maybe getting a new pump. Have a volume test done first though.

"If the women don't find you handsome, they should at least find you HANDY"

REWARD EXCELLENCE!

Add to classic_racer's Reputation
Rate the quality of this post and help classic_racer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
classic_racer is offline   Reply With Quote
Old 09-23-2005, 07:11 PM   #9
Paulapoohcarr
New Member
Paulapoohcarr is on a distinguished road
 
Join Date: Sep 2005
Posts: 4
Default Re: Starts but won't stay running

Quote:
Originally Posted by classic_racer
Okay, first off starter fluid id only bad in deisel motors because the glow plugs can egnite the fluid prematurely and because there is no air restriction on the motor so you can overrev very easily and blow something up, it is near impossible to do such with a gas motor, other than that it is very safe.

Onto diagnosis, you need to test your pressure again, but this time you need to test your VOLUME, it isn't a common test but you can have it done, your pressure can be good (40 is just right for your car I have the same motor and mine sits right at 40) and your flow can be bad. If your flow is bad, it is usually only one of three things, a pinched fuel line, a bad fuel pump, or a bad fuel filter, sorry to say it but you might have gotten a bad pump. I would check the lines first, then get a new filter and then see about maybe getting a new pump. Have a volume test done first though.

"If the women don't find you handsome, they should at least find you HANDY"

Thanks for the information, I hope this helps and gets my car running again.

REWARD EXCELLENCE!

Add to Paulapoohcarr's Reputation
Rate the quality of this post and help Paulapoohcarr reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Paulapoohcarr is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Daytime Running lights stay on? Mr. Callaway L-Series Tech 12 04-16-2014 04:28 PM
91 sc won't stay running medwards22 S-Series Tech 24 05-05-2009 01:52 PM
Starts but won't stay running RickD. S-Series Tech 10 04-08-2008 08:26 AM
Help! L200 Won't Stay Running.. tfmc369 L-Series Tech 3 06-07-2007 01:14 PM
car wont stay running pkuptrk Miscellaneous Tech 1 01-04-2003 10:06 PM


All times are GMT -5. The time now is 05:42 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.