SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Closed Thread
 
Thread Tools Display Modes
Old 05-10-2005, 08:56 AM   #1
renadena
New Member
renadena is on a distinguished road
 
Join Date: May 2005
Location: Virginia
Posts: 6

1996 SL
1997 SW2
Default turn signals and hazards just stopped working

Hello,
On my 96 SL the turn signals and hazard lights just stopped working mid traffic. I don't get it. I have nothing. No lights or clicking noises on the exterior or interior of the car.
My first thought was a bad fuse. All of the fuses are fine.
Next thought was a relay....has anyone dealt with this problem?
Do you really have to take off the steering wheel to get the relay? I am reading the Haynes manual and that's what it looks like.
Just wondering if there is an easier way around this or if anyone else has any other suggestions if they might have dealt with this problem before. Something other than the relay maybe?
Thanks in advance.
- Rena

REWARD EXCELLENCE!

Add to renadena's Reputation
Rate the quality of this post and help renadena reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
renadena is offline  
SaturnFans.com Sponsored Links
Old 05-10-2005, 09:08 AM   #2
NavyCPO
Member
NavyCPO is on a distinguished road
 
NavyCPO's Avatar
 
Join Date: Nov 2004
Location: Norfolk, VA
Posts: 180
 

1993 SL2
Default Re: turn signals and hazards just stopped working

Well,

If you have checked both fuse panels, under the hood and inside the car, then It may be the combo switch. I'm having a problem with my instrument lights not coming on (but all other lights working) and have narrowed it down to the combo switch(turnsignal/windshield wiper arms are all one unit) and yes, you have to remove the steering wheel off the column to get it off. The switch itself slides onto the column. Mine is rather expensive from the dealer. $250.00 to be exact and they want a total of $467.00 adding the labor. I, myself, am going to try a junk yard to get a switch. One where you can pull it yourself, so that I can get some experience and work out the bugs before I tear into mine. Everything for me seems to go easier the second time around. Hope this helps you out.

...
Jim Hunter, Chief Petty Officer, USN, Retired
93 Saturn SL2 Automatic

REWARD EXCELLENCE!

Add to NavyCPO's Reputation
Rate the quality of this post and help NavyCPO reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
NavyCPO is offline  
Old 05-10-2005, 09:54 AM   #3
NavyCPO
Member
NavyCPO is on a distinguished road
 
NavyCPO's Avatar
 
Join Date: Nov 2004
Location: Norfolk, VA
Posts: 180
 

1993 SL2
Default Re: turn signals and hazards just stopped working



The combo switch (#6) I'm referring to is right behind the steering wheel in this exploded view. Is that the part you were referring to in your post?

...
Jim Hunter, Chief Petty Officer, USN, Retired
93 Saturn SL2 Automatic

REWARD EXCELLENCE!

Add to NavyCPO's Reputation
Rate the quality of this post and help NavyCPO reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
NavyCPO is offline  
Old 05-10-2005, 03:17 PM   #4
renadena
New Member
renadena is on a distinguished road
 
Join Date: May 2005
Location: Virginia
Posts: 6

1996 SL
1997 SW2
Default Re: turn signals and hazards just stopped working

Thanks so much for your help.
It didn't occur to me to check the wiper switch until you mentioned it in your post. The wipers and everything on the right side of the steering wheel work fine. It's the left side that is not. I also noticed that the high beams will not stay in the on position but do come on when you hold it in the on position.
Does this mean I still need to replace the entire combination switch?
Thanks

REWARD EXCELLENCE!

Add to renadena's Reputation
Rate the quality of this post and help renadena reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
renadena is offline  
Old 05-10-2005, 03:29 PM   #5
NavyCPO
Member
NavyCPO is on a distinguished road
 
NavyCPO's Avatar
 
Join Date: Nov 2004
Location: Norfolk, VA
Posts: 180
 

1993 SL2
Default Re: turn signals and hazards just stopped working

Rena,

I can only give you my situation. My instrument lights work very intermitently. Sometimes they will come on when I turn on my headlights and sometimes they won't. I've traced the wires and my electrician friend seems to think that it is the switch. Plus, sometimes I can give a sharp rap to the column cover by the turn signal/headlight arm and the instrument lights will come on. Since my turn signals, hazard lights, head lights and everything but the instrument lights work, I'm 99.9% sure that it's my combo switch. Maybe you could yourself or have someone read the wires for you to see if it is a short or if it is actually your switch itself. Maybe able to save yourself some money in having it fixed.
Sorry I can't be of more help to you. Good luck.

...
Jim Hunter, Chief Petty Officer, USN, Retired
93 Saturn SL2 Automatic

REWARD EXCELLENCE!

Add to NavyCPO's Reputation
Rate the quality of this post and help NavyCPO reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
NavyCPO is offline  
Old 05-10-2005, 06:42 PM   #6
David 93 SL2m
Master Member
David 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the rough
 
David 93 SL2m's Avatar
 
Join Date: May 2000
Location: North America
Posts: 3,594
 

2004 VUE 2.2L
2007 ION-3 Sedan
Default Re: turn signals and hazards just stopped working

Quote:
Originally Posted by renadena
Hello,
On my 96 SL the turn signals and hazard lights just stopped working mid traffic. I don't get it. I have nothing. No lights or clicking noises on the exterior or interior of the car.
My first thought was a bad fuse. All of the fuses are fine.
Next thought was a relay....has anyone dealt with this problem?
Do you really have to take off the steering wheel to get the relay? I am reading the Haynes manual and that's what it looks like.
Just wondering if there is an easier way around this or if anyone else has any other suggestions if they might have dealt with this problem before. Something other than the relay maybe?
Thanks in advance.
- Rena
I would check the flasher unit next. This is easy and don't panic if the flasher unit is bad because we can get replacements at most auto parts stores for about $5. The flasher unit is located next to the relays inside the car in the fuse/relay area. To test it find a friend with a Saturn S-Series car and temporarily swap flasher units between your car and theirs.

...
Current
∙ 2004 VUE 124K
∙ 2007 ION3 112K
...
Past
∙ 1993 SL2 212K
∙ 1993 SC2 140K
∙ 1996 SC2 157K
∙ 1996 SC2 126K
∙ 2001 SC2, 145K
∙ 2002 L200 20K
∙ 2002 SL1 129K
...

REWARD EXCELLENCE!

Add to David 93 SL2m's Reputation
Rate the quality of this post and help David 93 SL2m reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
David 93 SL2m is offline  
Old 05-14-2005, 03:14 PM   #7
David 93 SL2m
Master Member
David 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the roughDavid 93 SL2m is a jewel in the rough
 
David 93 SL2m's Avatar
 
Join Date: May 2000
Location: North America
Posts: 3,594
 

2004 VUE 2.2L
2007 ION-3 Sedan
Checkered Flag Re: turn signals and hazards just stopped working

Renadena and I exchanged a few PMs and it turned out to indeed be the flasher unit. It was replaced at a cost of $12 and now the turn signals and hazard lights are working again. While doing research we discovered the flasher unit is not in the same place on our cars. On my 1993 SL2 the flasher unit is on the side of the fuse/relay panel facing the front passenger footwell area while on Renadena's 1996 SL1 it is on the side of the fuse/relay panel facing the driver footwell area.

...
Current
∙ 2004 VUE 124K
∙ 2007 ION3 112K
...
Past
∙ 1993 SL2 212K
∙ 1993 SC2 140K
∙ 1996 SC2 157K
∙ 1996 SC2 126K
∙ 2001 SC2, 145K
∙ 2002 L200 20K
∙ 2002 SL1 129K
...

REWARD EXCELLENCE!

Add to David 93 SL2m's Reputation
Rate the quality of this post and help David 93 SL2m reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
David 93 SL2m is offline  
Closed Thread



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
98 sl2 - turn signals not working / hazards working normal Jetfixer10 S-Series Tech 14 10-31-2016 03:10 PM
Turn signals not working. Hazards work cwills2 L-Series Tech 17 03-20-2016 07:37 PM
Turn signals don't work, hazards do a7x_audiojunkie S-Series Tech 2 06-03-2009 04:03 PM
Saturn Vue Turn Signals And Stopped Working Clan MacLaren Vue Tech 1 11-28-2007 11:38 PM
Saturn Vue Turn Signals Have Stopped Working Clan MacLaren Vue Tech 2 11-28-2007 07:58 PM


All times are GMT -5. The time now is 01:59 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.