SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-04-2019, 08:11 AM   #1
Medd1
New Member
Medd1 is on a distinguished road
 
Join Date: Sep 2019
Posts: 1
Default BCM problem??

Hey everyone, I have a 2003 saturn vue v6 awd
Automatic. I went camping and somehow a light got left on and killed the battery, so the only thing I could do was jump the car off my buddy's car. So now after jumping it the car runs and drives fine but I have no power locks, can't even open the rear hatch.. and no dash lights at all but the radio still works. Also the headlights are pretty dim. Did I fry the BCM on this thing? Or maybe a relay if if lucky? And help/input is appreciated, thanks.

REWARD EXCELLENCE!

Add to Medd1's Reputation
Rate the quality of this post and help Medd1 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Medd1 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 09-04-2019, 08:42 AM   #2
jnoonfelt14
Junior Member
jnoonfelt14 is a jewel in the roughjnoonfelt14 is a jewel in the roughjnoonfelt14 is a jewel in the rough
 
jnoonfelt14's Avatar
 
Join Date: Mar 2019
Location: Saginaw, Michigan
Posts: 15

2005 VUE 2.2L
2007 AURA XE
Default Re: BCM problem??

I highly doubt jump starting a car would cause electrical damage unless it was hooked up backwards and jumped... that'll destroy the electronics in any car. Do your power locks not work on the inside switches, key FOB, or both? Also, have your battery and alternator tested. Usually if a battery dies, and one uses the alternator to recharge it, it usually damages the charging system. Have them tested. Places like Autozone do that for free.

REWARD EXCELLENCE!

Add to jnoonfelt14's Reputation
Rate the quality of this post and help jnoonfelt14 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
jnoonfelt14 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem: Weird no-start-shift lock problem vstringbassist Ion Tech 8 12-09-2012 01:55 AM
Acceleration problem...gets stuck...possibly transmission? Or a gas problem? Dingo Warrior S-Series General 34 03-29-2009 01:20 PM
Irratic temp guage problem & CC problem 98dingo S-Series Tech 14 07-19-2007 11:43 AM
i found out want was the lack of power problem and shifting problem gypsy35 S-Series General 4 01-06-2006 08:49 AM
RADIO problem? and door lock problem please help 95sl2urbo S-Series Tech 15 01-11-2004 09:25 PM


All times are GMT -4. The time now is 01:11 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.