SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Vue > Vue General
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-24-2019, 02:37 PM   #1
teacher1974
New Member
teacher1974 is on a distinguished road
 
Join Date: Jun 2019
Location: NJ
Posts: 4

2007 VUE 3.5L
Default 2007 Body mount to subframe rot

Hello All. Been reading the posts for a while, and was wondering whether anyone had success repairing serious body mount rust. I'm posting a pic of what it looks like. Husband says most of the subframe still looks good.
Attached Images
File Type: jpg MVIMG_20190824_122200~2.jpg (186.2 KB, 30 views)

REWARD EXCELLENCE!

Add to teacher1974's Reputation
Rate the quality of this post and help teacher1974 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
teacher1974 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 08-26-2019, 01:10 PM   #2
teacher1974
New Member
teacher1974 is on a distinguished road
 
Join Date: Jun 2019
Location: NJ
Posts: 4

2007 VUE 3.5L
Default Re: 2007 Body mount to subframe rot

Update: Took it to body shop to see extent of rot. They were shocked that the subframe itself is in very good shape with the body mounts being so extensively decayed. Now I'm looking for replacement mounts. Don't want to scrap the car that's otherwise in good condition if the rust is confined to the mounts. Will post updates in case anyone is interested since this seems to be an issue on so many Vues.

REWARD EXCELLENCE!

Add to teacher1974's Reputation
Rate the quality of this post and help teacher1974 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
teacher1974 is offline   Reply With Quote
Old 09-01-2019, 04:17 PM   #3
teacher1974
New Member
teacher1974 is on a distinguished road
 
Join Date: Jun 2019
Location: NJ
Posts: 4

2007 VUE 3.5L
Default Re: 2007 Body mount to subframe rot

Update 2: Being towed into a shop that specializes in welding/fabrication this week. Fingers crossed. Will let everyone know how it turns out.

REWARD EXCELLENCE!

Add to teacher1974's Reputation
Rate the quality of this post and help teacher1974 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
teacher1974 is offline   Reply With Quote
Old 09-13-2019, 12:08 PM   #4
Bismarck318
Senior Member
Bismarck318 is on a distinguished road
 
Join Date: Feb 2009
Location: Birthplace of Rust, FKA The Heart of the Rustbelt, AKA The Angry White Planet Ohth
Posts: 1,030

2006 VUE 3.5L
Default Re: 2007 Body mount to subframe rot

I believe that rubber mount was replaced on mine to the tune of $500 back in '14 that was suppose to stop front end shaking, it helped a bit but did not completely stop it.

REWARD EXCELLENCE!

Add to Bismarck318's Reputation
Rate the quality of this post and help Bismarck318 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Bismarck318 is offline   Reply With Quote
Old 09-13-2019, 01:27 PM   #5
ScotSHO
New Member
ScotSHO is on a distinguished road
 
Join Date: Jul 2019
Posts: 4
Default Re: 2007 Body mount to subframe rot

I have seen pictures of that rusted area repaired on FB. It takes some welding and metal fabrication skills, but it can be done. It is probably 80% labor, so find a guy that can fix it and get a quote for how long he thinks it will take.

They have to cut the area back to solid steel, and then bend, piece and weld together a new mounting area.

REWARD EXCELLENCE!

Add to ScotSHO's Reputation
Rate the quality of this post and help ScotSHO reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
ScotSHO is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2005 Vue V6 subframe to frame mount broken patnmike427 Vue Tech 3 01-09-2019 09:29 PM
2007 Ion Body Code? (eg; GM W-Body, J-Body, F-Body) NotAHondaDriver Ion General 2 04-16-2013 01:27 PM
how to fix a spinning captive subframe to body nut eljefino S-Series Tech 3 12-19-2010 12:23 PM
Mount for iPod (iPhone) in 2007 XR audiofx Aura General 9 09-15-2009 11:52 AM
Subframe/mount stupidity jeep4523 S-Series Tech 2 07-24-2006 06:09 AM


All times are GMT -4. The time now is 11:36 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.