SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Vue > 2008 Vue
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-18-2018, 07:18 PM   #1
MRundell
New Member
MRundell is on a distinguished road
 
Join Date: Jul 2018
Posts: 2
Default Electrical issue

Hi all, new to the forums and dropped in to see if anyone can help me out. I have a 2008 Vue (took over as my DD when my wife got a new car) and I started having some problems the other day. To save some time here is a list of my problems:

Turn signal/high beam switch is not working,
Windshield wiper control switch not working,
Wipers ran on their own for about 10 minutes then stopped in the middle of the windshield,
Hazard light button not working,
Headlight switch not working,
Door lock switch not working,
Rear hatch wonít open and/or unlock,
Radio and lights will stay on when I shut off the car even after taking the key out and opening the door (eventually everything turns off when the system times out). I think thatís it...

Not sure if itís a fuse/relay issue or maybe a BCM problem? I started checking fuses and so far all the BCM fuses seem fine. Car has 154,000 miles. Any help would be greatly appreciated other wise this thing is getting traded in for a $2,000 or less car, I donít even care if get $100.

Thanks,

A fed up Vue owner.

REWARD EXCELLENCE!

Add to MRundell's Reputation
Rate the quality of this post and help MRundell reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MRundell is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-18-2018, 07:42 PM   #2
MacVue
New Member
MacVue is on a distinguished road
 
Join Date: Jun 2013
Posts: 5
Default Re: Electrical issue

It sure sounds as if it is related to BCM.

REWARD EXCELLENCE!

Add to MacVue's Reputation
Rate the quality of this post and help MacVue reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MacVue is offline   Reply With Quote
Old 07-18-2018, 07:50 PM   #3
MRundell
New Member
MRundell is on a distinguished road
 
Join Date: Jul 2018
Posts: 2
Default Re: Electrical issue

I have no idea where to start after the fuses/relays

REWARD EXCELLENCE!

Add to MRundell's Reputation
Rate the quality of this post and help MRundell reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
MRundell is offline   Reply With Quote
Old 10-13-2018, 08:31 PM   #4
DJHMOCHA
New Member
DJHMOCHA is on a distinguished road
 
Join Date: Sep 2018
Posts: 2
Default Re: Electrical issue

2008 VUE had brand new battery drained by leaving doors open? We were evacuating the Hurricane Michael and it would not start. Tried to get it to charge but the text on the charger showed no charging was occurring. The charger had a red light that said CHECK ELECTRICAL. Charging cables were in the spare tire compartment so have not tried that yet. Can anyone tell me why this battery would not charge? Is it OK to try and jump it without damaging the electrical system? We just got back from evacuating and my husband went to the hospital and has not been able to work on this. Please help.

REWARD EXCELLENCE!

Add to DJHMOCHA's Reputation
Rate the quality of this post and help DJHMOCHA reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
DJHMOCHA is offline   Reply With Quote
Old 10-14-2018, 10:34 AM   #5
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,156
 

2003 L-Series 3.0L Sedan
Default Re: Electrical issue

MRundell, does your Vue startup? Can it be driven? Are battery cables clean, free of corrosion, tightly connected to cables?

DJHMOCHA, are both battery cable connections clean, free of corrosion and tightly connected? A boost from another car can help and usually never harms the electrical system as long as red goes to red and black goes to black. Better yet - red to red, black to engine block.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Electrical Issue and Starting Issue 1995SW2 S-Series General 5 12-02-2015 06:55 PM
SC1 Electrical Issue deondoond S-Series Tech 1 08-27-2013 12:26 AM
Odd electrical issue... lastcall190 L-Series Tech 6 12-11-2011 05:42 PM
AC issue - Electrical help dsieme01 L-Series Tech 7 06-07-2010 10:03 PM
Electrical Issue blackeagle1 S-Series Tech 3 07-30-2006 02:02 PM


All times are GMT -5. The time now is 02:59 AM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.