SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn Sky > Sky Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 07-04-2018, 01:46 AM   #1
virtualking
New Member
virtualking is on a distinguished road
 
Join Date: Jun 2018
Posts: 5
Default A/C fan not working.

Mr. dealer tells me that it is a ECM problem behind the switch and asking for $ 450+, give me advice what to do?

REWARD EXCELLENCE!

Add to virtualking's Reputation
Rate the quality of this post and help virtualking reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
virtualking is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 07-04-2018, 04:35 AM   #2
fdryer
Super Member
fdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond reputefdryer has a reputation beyond repute
 
fdryer's Avatar
 
Join Date: Jan 2006
Location: NYC
Posts: 41,446
 

2003 L-Series 3.0L Sedan
Default Re: A/C fan not working.

Are you describing the ac blower fan inside the car or the radiator/ac condenser cooling fan? Each fan has it's own circuit, downstream of the engine computer, ecm. Without more info, my initial guess is this dealer may be attempting to emptying your wallet. Fans have fuses and some use a relay. Fans are controlled by circuits. Engine cooling fan(s) use the same circuit whether or not its for overheating coolant or using ac. Every ac system turns on cooking fan - the ac condenser coil gets hot and it's in front of the radiator. Without the fan running when ac is used, hot air from the condenser coil flows into the radiator that's already hot and can result in overheating. Cooling system and ac suffers if the cooling fan doesn't run. Without ac the cooling fan runs only when coolant reaches a temperature the engine computer determines warm enough to turn on. The cooling fan operates on the same circuit for either the ac system demands it or when engine coolant demands it.

Fuse, relay or faulty fan may be the problem and not the ecm. You're always free to try another dealer or reputable auto electric shop experienced in electrical systems. Some may even be knowledgeable about engine computers in general to make honest assessments.

REWARD EXCELLENCE!

Add to fdryer's Reputation
Rate the quality of this post and help fdryer reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
fdryer is offline   Reply With Quote
Old 07-04-2018, 10:10 AM   #3
kg6mvb
Member
kg6mvb has a spectacular aura aboutkg6mvb has a spectacular aura about
 
kg6mvb's Avatar
 
Join Date: Oct 2003
Location: DM65pe
Posts: 348
 

2003 ION-1 Sedan
2002 SL2
Default Re: A/C fan not working.

My Ion has an ECM problem triggering the fan as well. The ECM should pull one pin to ground to trigger the fan relay (which it doesn’t). Jumping it to ground turns on the fan.

Rather than replacing the ECM, I wired up a relay to turn on the fan anytime the AC compressor is powered. I also added a switch so I can turn the fan on in the winter. The only time I need that is when sitting in traffic (or drive through lines).

You have a different model so of course YMMV.

...
Proud to be a member of both the Ham Radio and Saturn Cults.

Avitar is a Saturn V rocket engine.

REWARD EXCELLENCE!

Add to kg6mvb's Reputation
Rate the quality of this post and help kg6mvb reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
kg6mvb is offline   Reply With Quote
Old 07-05-2018, 08:46 PM   #4
pierrot
Master Member
pierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud ofpierrot has much to be proud of
 
pierrot's Avatar
 
Join Date: Jun 2012
Location: Glendora, CA
Posts: 3,433
 

2000 L-Series 2.2L Sedan
Default Re: A/C fan not working.

Quote:
Originally Posted by virtualking View Post
Mr. dealer tells me that it is a ECM problem behind the switch and asking for $ 450+, give me advice what to do?
I have looked through the five posts you've written here at SaturnFans to date and nowhere have you identified what vehicle it is that you own, or are working on. From the quality of the posts you've written I am dubious that your posting here is for any positive purpose...perhaps I'm wrong and that would be fine if it were so. At this point, however, I believe that assisting you with your issue is a most unfruitful endeavor.

...
298,000 miles-it keeps on rolling!
The blessings of liberty erode in my country.
Gov't's grown bigger, but a chance exists that it will be reduced. I'm cautiously hopeful.

REWARD EXCELLENCE!

Add to pierrot's Reputation
Rate the quality of this post and help pierrot reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
pierrot is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
08 3.5 temp gauge not working and a/c not working explorerbigjon Aura General 13 06-30-2017 06:43 AM
98 sl2 - turn signals not working / hazards working normal Jetfixer10 S-Series Tech 14 10-31-2016 04:10 PM
Ac not working. AC, recirc, and defrost lights not working emg77 Astra General 1 06-01-2013 03:56 PM
front air fan not working rear air still working scott31525 Outlook General 2 06-25-2011 08:49 AM
94 SL2 Odo Not working but speedo is working cordy74 S-Series General 3 04-09-2007 05:34 PM


All times are GMT -4. The time now is 09:54 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.