SaturnFans.com
what's new (beta) - classifieds - forums - photos


Go Back   SaturnFans.com Forums > Models > Saturn S-Series > S-Series Tech
Register FAQ Members List Groups Calendar Chat Room Search Today's Posts Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 06-24-2018, 03:59 PM   #1
Hiram_32
Member
Hiram_32 is on a distinguished road
 
Join Date: Aug 2014
Posts: 77
Default 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

Got the following trouble codes:
02 SL2 with 154k on engine
Second Owner
-P0708 Trans Range Sensor High Input (twice in a row)
-P0037 HO2S-12 (Bank 1 Sensor 2) Heater Circuit Low Input

The codes remained after having about 4-5 other codes (don't have info onhand--will post later), one of which indicated TCC Stuck On or Off. Proceeded to remove VB and test solenoids, only to find out that the multimeter I was using was faulty (set to correct 200ohm), and was giving high readings of solenoids (16.7 or so). Swapped out with new multimeter, and all solenoids tested around 5.9.
PROBLEM (self-created): When closing up VB after reattaching to trans, the last bolt wouldn't toque down flush with the VB as it was the incorrect length. Under duress (1am, had to work next morning), torqued bolt to spec, despite it not going down flush with VB casing, and closed up Trans Pan. Out of necessity (intense work sched, no backup car), been driving the car for 1 week, putting on at least 200 miles. It should be noted that over 2yrs ago, I successfully (and correctly) replaced a bad solenoid, which solved some reverse slamming I had been experiencing (caused by dodgy home mechanic-- left trans filter 3/4 on, leaked trans fluid without my knowing about it for over 1000miles).


SYMPTOMS:
-Hard reverse slamming (wasn’t as pronounced before removing VB and improperly sealing it)
-Slamming when shifting into drive (not nearly as intense as R)
-On 3 occasions, shifting into R has acted as if it were in D (remedied after shifting into N then back into R)
-Slamming into high gears when driving on highways (been like that since I got the vehicle)

QUESTIONS:
-Any suggestions/links/tutorials on how to remedy codes?
-Did I screw up the trans now? Or does it seem like it will be okay after correcting VB bolt positions?
-Can anyone please share or direct me to info/images for the correct VB bolt positions?
-Would it be advisable (or even make sense) to buy a new VB and swap it with old one?
-Someone suggested this could be a chain linkage issue—thoughts?

Any feedback, suggestions, solutions are greatly appreciated. Thank you!

REWARD EXCELLENCE!

Add to Hiram_32's Reputation
Rate the quality of this post and help Hiram_32 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Hiram_32 is offline   Reply With Quote
SaturnFans.com Sponsored Links
Old 06-25-2018, 08:56 AM   #2
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,966

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

Quote:
Originally Posted by Hiram_32 View Post
-P0708 Trans Range Sensor High Input (twice in a row)
First check the ground wire on your Range Switch.

Quote:
Originally Posted by Hiram_32 View Post
-Can anyone please share or direct me to info/images for the correct VB bolt positions?
Here's the diagram that shows bolt lengths . . .
http://www.saturnfans.com/forums/att...6&d=1416505869

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 06-26-2018, 06:50 AM   #3
Hiram_32
Member
Hiram_32 is on a distinguished road
 
Join Date: Aug 2014
Posts: 77
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

Quote:
Originally Posted by Chazberry View Post
First check the ground wire on your Range Switch.
Where is the ground wire located for the Range Switch?


Quote:
Originally Posted by Chazberry View Post
Here's the diagram that shows bolt lengths . . .
http://www.saturnfans.com/forums/att...6&d=1416505869
Thank you for the diagram!

REWARD EXCELLENCE!

Add to Hiram_32's Reputation
Rate the quality of this post and help Hiram_32 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Hiram_32 is offline   Reply With Quote
Old 06-26-2018, 08:15 AM   #4
Chazberry
Master Member
Chazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to beholdChazberry is a splendid one to behold
 
Chazberry's Avatar
 
Join Date: Feb 2005
Posts: 6,966

2003 VUE 3.0L
2007 VUE 3.5L
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

Quote:
Originally Posted by Hiram_32 View Post
Where is the ground wire located for the Range Switch?
It goes from the Switch to the Chassis . . .
http://www.saturnfans.com/forums/sho...2&postcount=11

REWARD EXCELLENCE!

Add to Chazberry's Reputation
Rate the quality of this post and help Chazberry reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Chazberry is offline   Reply With Quote
Old 06-26-2018, 09:40 PM   #5
Hiram_32
Member
Hiram_32 is on a distinguished road
 
Join Date: Aug 2014
Posts: 77
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

Quote:
Originally Posted by Chazberry View Post
It goes from the Switch to the Chassis . . .
http://www.saturnfans.com/forums/sho...2&postcount=11
Thank you for this.

REWARD EXCELLENCE!

Add to Hiram_32's Reputation
Rate the quality of this post and help Hiram_32 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Hiram_32 is offline   Reply With Quote
Old 07-12-2018, 09:09 AM   #6
Hiram_32
Member
Hiram_32 is on a distinguished road
 
Join Date: Aug 2014
Posts: 77
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

@Chazberry: Thank you for pointing out the Range Sensor grounding. Turns out the cord had gotten ripped out of it's clip as a result of pulling the wire harnesses away from the valve pan. Reconnected the wire, and it solved the shifting problem---for short time.

The reverse slam issue is still happening, though not as intensely. Still experiencing hard shifts into higher gears, and have noted the RPM is greatly disproportionate to the MpH (30MpH, 60RPM for instance). Also, the engine idles high, I think around 15 or so RPM from what I recall (will make note later).

NEW CODES POST-REPAIR (as appears on print-out):
P0037 HO2S-12 (Bank 1 Sensor 2) Heater Circuit Low Input
P0037 HO2S-12 (Bank 1 Sensor 2) Circuit Low Input
P0410 Secondary Air System Performance
P0741 TCC Solenoid Circuit Performance or Stuck Off
P0037 HO2S-12 (Bank 1 Sensor 2) Heater Circuit Low Input
P0037 HO2S-12 (Bank 1 Sensor 2) Circuit Low Input
P0410 Secondary Air System Performance
P0741 TCC Solenoid Circuit Performance or Stuck Off

Any insights as to what is causing these? The P0410 is brand new, and have never gotten that code before in the past. Also, what would cause the P0741 when I know the TCC solenoid to be good (5.9 Ohms)? Should I buy a rebuilt TAAT transmission off Ebay and swap it out with the old one? It should be noted that I did not reuse the old trans fluid, as the first time it was mistakenly opened by a foolish home mechanic, the fluid all got dumped. I note this, as a few folks I've spoke with said reusing old fluid can be helpful as the particulates help keep the internals shifting well after they have worn from years of use (156k on engine).

As always, insights, feedback, and remedies are greatly appreciated.

REWARD EXCELLENCE!

Add to Hiram_32's Reputation
Rate the quality of this post and help Hiram_32 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Hiram_32 is offline   Reply With Quote
Old 07-12-2018, 11:27 AM   #7
Saturn Night
Master Member
Saturn Night is a jewel in the roughSaturn Night is a jewel in the roughSaturn Night is a jewel in the roughSaturn Night is a jewel in the rough
 
Join Date: Aug 2016
Location: Leavittsburg, OH
Posts: 2,712

1995 SC2
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

I would contact Special Forces and order a new Valve Body. Reverse Slam has always been present, which means the Valve Body is shot.

Slamming in forward gears is likely an issue with the pressure regulator valve bore and/or the line pressure solenoid.

Special Forces will send instructions on which bolts go where.

Fixing the engine codes will also help with shifting. If the engine misfires, runs too rich/lean, it will cause poor shifting.

...
"What does a Saturn owner do, at the gas station?"

"He checks the gas, and fills the oil....."

REWARD EXCELLENCE!

Add to Saturn Night's Reputation
Rate the quality of this post and help Saturn Night reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Saturn Night is offline   Reply With Quote
Old 07-12-2018, 11:32 AM   #8
Saturn Night
Master Member
Saturn Night is a jewel in the roughSaturn Night is a jewel in the roughSaturn Night is a jewel in the roughSaturn Night is a jewel in the rough
 
Join Date: Aug 2016
Location: Leavittsburg, OH
Posts: 2,712

1995 SC2
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

And make sure to change the fluid. The Saturn TAAT is the one transmission, that changing worn fluid will not hurt it. My TAAT had 163k, reverse slam, a quirky downshifting issue when cold, and the TCC solenoid was sticking. The fluid had never been changed and it had a factory trans filter still on it.

Changed the fluid. Replaced the valve body. Currently at 197k. Just did my scheduled service at 193,999 miles, for the trans fluid, since I did the repair work.

Runs and shifts fine. Has even gone to the drag strip a few times and been beat on going down the track at WOT.

...
"What does a Saturn owner do, at the gas station?"

"He checks the gas, and fills the oil....."

REWARD EXCELLENCE!

Add to Saturn Night's Reputation
Rate the quality of this post and help Saturn Night reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Saturn Night is offline   Reply With Quote
Old 07-12-2018, 02:00 PM   #9
J.W.
Member
J.W. is on a distinguished road
 
Join Date: Oct 2012
Location: Western N.Y.
Posts: 168

2001 SL2
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

[QUOTE=Hiram_32;2276200]Got the following trouble codes:
02 SL2 with 154k on engine
Second Owner
-P0708 Trans Range Sensor High Input (twice in a row)
-P0037 HO2S-12 (Bank 1 Sensor 2) Heater Circuit Low Input
~~~~~
Somewhere in the archives is a lot of info about the electrical plug wires on top the automatic tranny. They tend to vibrate a bit and break inside the insulation. That broken wire(s) give you the indications you describe.
Check that out before you get into the tranny...it can be just a broken wire.
Maybe someone remembers that ?
JW

REWARD EXCELLENCE!

Add to J.W.'s Reputation
Rate the quality of this post and help J.W. reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
J.W. is offline   Reply With Quote
Old 07-16-2018, 03:36 PM   #10
Hiram_32
Member
Hiram_32 is on a distinguished road
 
Join Date: Aug 2014
Posts: 77
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

Quote:
Originally Posted by Saturn Night View Post
I would contact Special Forces and order a new Valve Body. Reverse Slam has always been present, which means the Valve Body is shot.

Slamming in forward gears is likely an issue with the pressure regulator valve bore and/or the line pressure solenoid.

Special Forces will send instructions on which bolts go where.

Fixing the engine codes will also help with shifting. If the engine misfires, runs too rich/lean, it will cause poor shifting.

And make sure to change the fluid. The Saturn TAAT is the one transmission, that changing worn fluid will not hurt it. My TAAT had 163k, reverse slam, a quirky downshifting issue when cold, and the TCC solenoid was sticking. The fluid had never been changed and it had a factory trans filter still on it.

Changed the fluid. Replaced the valve body. Currently at 197k. Just did my scheduled service at 193,999 miles, for the trans fluid, since I did the repair work.

Runs and shifts fine. Has even gone to the drag strip a few times and been beat on going down the track at WOT.
@Saturn Night
Thank you for the feedback! A compromised VB seems to make sense here, given all these issues popping up. I'll look into Special Forces VBs. Will also change the fluid, too.

REWARD EXCELLENCE!

Add to Hiram_32's Reputation
Rate the quality of this post and help Hiram_32 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Hiram_32 is offline   Reply With Quote
Old 07-16-2018, 03:40 PM   #11
Hiram_32
Member
Hiram_32 is on a distinguished road
 
Join Date: Aug 2014
Posts: 77
Default Re: 02 SL2 Trouble Codes P0708 (2 instances), P0037, plus VB issue/questions

[QUOTE=J.W.;2277413]
Quote:
Originally Posted by Hiram_32 View Post
Got the following trouble codes:
02 SL2 with 154k on engine
Second Owner
-P0708 Trans Range Sensor High Input (twice in a row)
-P0037 HO2S-12 (Bank 1 Sensor 2) Heater Circuit Low Input
~~~~~
Somewhere in the archives is a lot of info about the electrical plug wires on top the automatic tranny. They tend to vibrate a bit and break inside the insulation. That broken wire(s) give you the indications you describe.
Check that out before you get into the tranny...it can be just a broken wire.
Maybe someone remembers that ?
JW

@JW
Thank you for the info! I was wondering about electrical issues, and will investigate this further. Is there any way to assess broken wires when they are exposed from their color-coded cover? Would it be advisable to replace the wires to the VB/wiring harness and plug altogether? Clipping them back a few inches from wiring harness and replacing with a new one? If so, have you any suggested resources for getting a new set of wires/wiring harness? There's a U-Pull yard not too far from me I could call and ask about said part.

REWARD EXCELLENCE!

Add to Hiram_32's Reputation
Rate the quality of this post and help Hiram_32 reputation points. Click the reputation button near the bottom left corner of this message box. Thank you!
Hiram_32 is offline   Reply With Quote
Reply



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Ion with P0031 and P0037 codes memorizeme Ion Tech 1 08-10-2015 06:11 PM
trouble codes wadenie S-Series Tech 3 12-22-2011 07:18 PM
Trouble Codes m2k_us Ion Tech 0 11-07-2009 07:06 PM
Trouble with Transmission Trouble Codes Toaster_Man S-Series Tech 0 05-22-2008 06:32 PM
'92 SL2 trouble codes Alex's Dad S-Series Tech 7 03-30-2002 08:24 PM


All times are GMT -5. The time now is 08:03 PM.

Advanced Forum Search | Advanced Photo Search


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
SaturnFans.com. The Saturn Enthusiasts Site.